Windows Update Makes S Series MK1 Controllers Unrecognized in Komplete Kontrol

Discussion in 'KONTAKT: Sampling, Programming & Scripting' started by TigerTheFrog, Mar 2, 2019.

  1. TigerTheFrog

    TigerTheFrog Senior Member

    986
    1,268
    Nov 18, 2016
    Brooklyn, NY
    "Dear Customer" email from Native Instruments:

    We are currently investigating an issue that affects our TRAKTOR KONTROL S4 Mk2, MASCHINE STUDIO, and all KOMPLETE KONTROL S-Series Mk1 hardware. Following the latest updates to Microsoft Windows 7, 8, and 10, these controllers are no longer recognized.

    The issue was introduced in the most recent Windows update. We are in contact with Microsoft to try to narrow down the cause and find possible solutions. Until there’s a permanent fix, you’ll need to roll Windows back to the previous version in order to keep using your hardware. We’ve created a support page showing you how to do this:

    Windows 10
    https://support.native-instruments.com/hc/en-us/articles/360000983457

    Windows 8
    https://support.native-instruments.com/hc/en-us/articles/360001078378

    Windows 7
    https://support.native-instruments.com/hc/en-us/articles/360001061717

    We apologize for any inconvenience caused, and hope to resolve the issue very soon.

    Best wishes,

    The Native Instruments team

    Rather than follow these instructions, I found it simpler to do a System Restore to before the update, and then turn off Automatic Updates. I sure hope they fix this soon.
     
  2. Mornats

    Mornats Senior Member

    807
    649
    Feb 21, 2016
    Bristol, UK
    I've been hit by this and I'm on Windows 10 Home so I can't turn off the updates. I'm left with trying to uninstall the update every time I reboot. Plus I think I lose the option to uninstall after 10 days.

    What Native Instruments fail to say in their email and support section is that if you're not on Windows 10 pro you're pretty much screwed. They don't even tell you that their recommendation only works in Pro.
     
  3. OP
    OP
    TigerTheFrog

    TigerTheFrog Senior Member

    986
    1,268
    Nov 18, 2016
    Brooklyn, NY
    I explained how to turn off Windows Updates in Windows 10 Home in this thread.
     
  4. Mornats

    Mornats Senior Member

    807
    649
    Feb 21, 2016
    Bristol, UK
    Ah, nice thanks! I'll give that a go :)
     
  5. Mornats

    Mornats Senior Member

    807
    649
    Feb 21, 2016
    Bristol, UK
  6. sostenuto

    sostenuto Senior Member

    3,756
    1,774
    Mar 10, 2017
    St George, UT USA
    Win10 Pro latest; Reaper 64 latest; S49 Mk1.
    Symptoms quite different. S49 works somewhat normally, recognized by Reaper Audio, is NOT recognized by Komplete Kontrol latest. When Expression Pedal seemed to work incorrectly (not continuous), Komplete Kontrol displays all 'S' devices, but all greyed out; none selected/selectable.

    Tried uninstalling Controller Editor, back to 1.7,4, then Update in Native Access to current 2.3.2. (per one NI Support instruction). Problem remains.
     
    Last edited: Mar 14, 2019 at 4:56 PM
  7. Mornats

    Mornats Senior Member

    807
    649
    Feb 21, 2016
    Bristol, UK
    I only tested mine quickly in Komplete Kontrol standalone. I'll check in Reaper tomorrow if I get a chance. On win 10 home with S61 mk 1.
     
    sostenuto likes this.
  8. OP
    OP
    TigerTheFrog

    TigerTheFrog Senior Member

    986
    1,268
    Nov 18, 2016
    Brooklyn, NY
    Mornats likes this.
  9. I got the 2019-02 Cumulative Update for Windows 10 Version 1803 for x64-based Systems (KB4487017) and after installing it my Komplete Kontrol is not working :/

    So I am having uninstall it again, but I am not sure what the latest update is meant to be since NI have not supplied the name of the KB for reference!
     
  10. EvilDragon

    EvilDragon KSP Wizard

    5,787
    3,634
    May 25, 2010
    Croatia
  11. C-Wave

    C-Wave Senior Member

    906
    325
    Feb 27, 2016
  12. Thanks man, I turned on my Security Updates again in Updates, which pulled down the new KB that fixed it :)

    Left it off for one month as I was unsure who was going to fix the issue first ;)

    UPDATE: After all I have to admit that with a few Powershell scripts and some Local Group Policy tweaks... Windows 10 Pro can be a dream :cool:
     

Share This Page