What's new

Windows 10 Hangs on Boot

patrick76

Senior Member
So I've been having this issue recently. Windows 10 will now hang when booting up. I have to restart the pc by holding the power button down and it will then boot up correctly.

After trying several things to fix the issue, I am more confused now than ever. After removing all usb devices I found it would boot correctly. Then I tried removing one usb device at a time to determine which one(s) were causing the issue. The problem is that there is not a consistent pattern. Sometimes after removing one usb device, the computer will boot fine. The next time I try booting up with that same usb device removed, it will not boot. This is true for several usb devices. Sometimes it will boot up and sometimes it won't. WTF. I really, really cannot stand windows 10.... one of many problems that I won't get into that I have with windows 10..

Anyone have any ideas? Thank you.
 

tokatila

Senior Member
So I've been having this issue recently. Windows 10 will now hang when booting up. I have to restart the pc by holding the power button down and it will then boot up correctly.

After trying several things to fix the issue, I am more confused now than ever. After removing all usb devices I found it would boot correctly. Then I tried removing one usb device at a time to determine which one(s) were causing the issue. The problem is that there is not a consistent pattern. Sometimes after removing one usb device, the computer will boot fine. The next time I try booting up with that same usb device removed, it will not boot. This is true for several usb devices. Sometimes it will boot up and sometimes it won't. WTF. I really, really cannot stand windows 10.... one of many problems that I won't get into that I have with windows 10..

Anyone have any ideas? Thank you.
Mine exhibited same kind of behavior, but this was after overclocking, in my case it won't even got to the boot screen.

In my case I finally found out after trial and error that if I disconnected one of the SATA cables, the computer started normally. I replaced the cable and no problems after that (I can even overclock my 4.2 GHz to 5.0 now and it's stable (unfortunately too hot).

Also have you tried this utility? It may be helpful with pinpointing the problem:
https://www.nirsoft.net/utils/usb_devices_view.html
 

Synetos

Gear Addict
I would make sure the boot order is right in the BIOS. I also think tokatila has a good recommendation. You might have a bad (or simply) a loose SATA connection. Is your boot drive old? Perhaps it is beginning to fail and it is timing out in the boot order and then the system tries to find a boot partition on other devices in the boot order...hence USB, cdrom, etc.
 

Satorious

Active Member
Mine does this from time to time also (it's a boot problem - but I find it works if I hit the button again!). On an O/S level - can't seem to use "Sleep" now either without it completely crashing and needing a reboot. Rather frustrating, but working fine aside from these "quirks".
 

Killiard

Active Member
I have a bizarre issue with my machine where it will always hang on the first boot of the day. It only happens when overclocking, if I turn that off it boots cold fine.

What I have to do is every morning when I start it up I go straight into UEFI and change something minor, like toggle the motherboard lighting, hit f10 to save and restart and it restarts fine.

If I don’t go into UEFI it will blue screen and I have to do a hard reset (and it boots up fine) but I don’t like getting a blue screen every day!
 
OP
patrick76

patrick76

Senior Member
Thanks for the replies!

Thanks tokatila, I will check my SATA cables and perhaps replace them.

Thanks Synetos. I will double check the boot order in the BIOS. The boot drive is getting a bit old. If the other options do not resolve my problem, perhaps I will clone the boot drive and buy a new one.

Thanks onebitboy. It hangs before the Windows logo.

Thanks Satorious. It is indeed frustrating.
 
OP
patrick76

patrick76

Senior Member
Thanks Killiard. For me Windows 10 has been just awful. It seems after every update I have some gremlins I have to hunt down and it has just gotten very frustrating. Initially I was excited for Windows 10, but that has been replaced by a complete disgust aimed at microsoft...lol
 

kitekrazy

Senior Member
Thanks Killiard. For me Windows 10 has been just awful. It seems after every update I have some gremlins I have to hunt down and it has just gotten very frustrating. Initially I was excited for Windows 10, but that has been replaced by a complete disgust aimed at microsoft...lol
Once you get a good working build of 10, don't upgrade it.
 

MrLinssi

A glorified bedroom musician.
Once you get a good working build of 10, don't upgrade it.
Agreed. I had a fairly hassle free experience, until one update just messed up everything, which led to the reinstallation of Windows. There went my day off from work. Haven't installed a single update since then, ain't nobody got time for that shit. :D
 

JohnG

Senior Member
For me Windows 10 has been just awful.
I haven't had such a bad experience overall. Maybe that's because I leave my PCs offline 99% of the time.

Just at the moment I am having a teeeerrrriiiible time with my percussion PC so I feel your pain.
 
OP
patrick76

patrick76

Senior Member
Thanks guys.

DavidY - I had already turned off Fast Startup but unfortunately that didn't solve it for me. From what I can tell thought that seems to fix the issue for most people.

kitecrazy - Good advice.

MrLinssi - Completely agree. I really don't have time for this stuff. I was working for hours on the issue yesterday. Computer got locked in some kind of loop, had to do a system repair,... still not sure it is fixed.

JohnG - Thanks for the sympathy! Good luck with your PC. The pain is indeed more than we should have to bear imho :)
 
Top Bottom