Vienna Ensemble - Error loading plugins: Could not create plugin

sprout

New Member
When I load a project, Vienna Ensemble Pro could not load the updated SynthMaster 2.8.2 plugin:

Errors occurred while loading plugins:
AU: KV331Audio| SynthMaster 2.7 Instrument (Could not create plugin)

I tried with my Logic X project and a lone vframe save file.

I can assign Synthmaster 2.8.2 to the instrument channel strips using the Replace Plugin menu item but I obviously lose my settings, have to reload each preset in Synthmaster instances, of course. But I don't remember which I used in my huge number of instances.

Works in Logic Pro X channels, why not in VEP? Is VEP being picky about the plugin name provided?

Synthmaster developer, Bulent Biyikoglu, recommended I install 2.7 for now. Not clear if he can fix the issue. I don't know why he has to put the version number in the name id. Who does that?

Paul at VSL assigned the bug to the development team but he apologized saying it has a low priority.

So, I need a workaround to use Synthmaster with VEP without losing my settings everytime I install a new version. Otherwise, I'll invest more time learning other synths which there are plenty of replacement available that I've already purchased, UVI Falcon, iZotope Iris2, Sylenth1, AIR synths like Hybrid 3, Output Signal Synth. Looking at Xfer Serum and Tone2 Icarus.

I invested a lot of time learning Synthmaster, purchased all their expansions. A good synth that I must use less instances of because of Logic Pro X's CPU handling :( Not that Synthmaster uses a lot of CPU, I just use so many instances per project.
 

Tysmall

Senior Citizen
I've had trouble with his install paths without vepro. make sure when you reinstall you manually delete all traces of the old version, and do not move anything.
Can you change the name in vepro to Synthmaster 2.82? Maybe it's just a naming conflict. Or rename the dll file you are using to load. (this could cause problems, make a backup).

Maybe vepro is looking for the name 2.7 which does not exist.
 
OP
sprout

sprout

New Member
I've had trouble with his install paths without vepro. make sure when you reinstall you manually delete all traces of the old version, and do not move anything.
Can you change the name in vepro to Synthmaster 2.82? Maybe it's just a naming conflict. Or rename the dll file you are using to load. (this could cause problems, make a backup).

Maybe vepro is looking for the name 2.7 which does not exist.
It's on a MAC, no DLL. I had already looked at what I could rename. No luck. I'll look into it again but I don't think its that simple. I'll try the full reinstall.