What's new

VEPro 7 now available!

TigerTheFrog

Amphibiousician
Based on my experience with Synchron Strings, I would recommend not pre-ordering anything from VSL. Wait for VE Pro 7 to be released, and try the demo.

Epic Orchestra 2.0 isn't a comprehensive collection, and being able to download it now isn't a compelling reason to pre-order VE Pro 7 except for the most sample-starved composer. And if you're a sample-starved composer, you probably don't need VE Pro in the first place.
For a potential new VE Pro purchaser like me, it is 50 euros less to pre-order.
As it comes with a copy of VE Pro 6, I don't see the risk.
 

shomynik

Active Member
No, you don't. You don't have to install it, but if you buy VEPro it is included in your license.

I think we should see it as follows: It is bonus material for potential VSL instruments customers. Bonus as in "you don't pay for it" and "it's a gift on top of the product itself".
The development of such software like VEPro is really expensive; so I fully understand if they can't lower the price, even if they would exclude the Epic Orchestra. The making of Epic Orchestra 2.0 is not that complicated and expensive for VSL and it is not good enough to hurt their instruments business. It's just a marketing move.
I don't think anybody here thinks that VEP alone doesn't worth that money. I mean, it easily replaces over 1k worth of hardware. But many ppl are already pissed by steinberg's prime focus on a broader market, and this kind of looks like that with added bonus for us with multi machine setups that we suddenly have to pay more than double the usual for an upgrade.
 
OP
Ben

Ben

VSL Support
It's 65€. If you want to upgrade an additional VEP license it's 45€
 

Shad0wLandsUK

Senior Member
I don't want to create false hope here...

But I decided to hav a ganders at the System requirements and found a little (sneaky) goodie:

Vienna Ensemble Pro 7 - System Requirements
System Requirements
  • PC Windows 7/8/10 (latest Update, 32/64-bit), Intel Core 2 Duo or AMD Athlon 64 X2
  • macOS 10.10 (latest update), Intel Core 2 Duo
  • 2 GB RAM (4 GB recommended)
  • Working Gigabit connection between master and networked computer(s). Also works on a one-computer setup.
  • ViennaKey (Vienna Symphonic Library USB protection device) or other USB eLicenser (e.g., from Steinberg or Arturia)
  • eLicenser Control Center software (get the latest version from www.eLicenser.net)
Other configurations may work but are not actively supported.

Recommended
  • PC Windows 7/8/10 (latest Update, 64-bit), Intel i5/i7/Xeon
  • macOS 10.12 (or higher), i5/i7/Xeon
  • Fast separate hard drive (7200 rpm or faster)
  • Supported plugin formats tba. ;) <--- NOTICE THIS... Clue perhaps?! :)
  • MAS version requires Digital Performer 8 or higher
  • AAX version requires Pro Tools 10.3.5 or higher
  • 88 key master keyboard
EDIT: For all you Logic users.... could it be DUN DUN DUN.. AU...
 
Last edited:

kitekrazy

Senior Member
For a potential new VE Pro purchaser like me, it is 50 euros less to pre-order.
As it comes with a copy of VE Pro 6, I don't see the risk.
If you slap VE Pro 6 on 2 or 3 machines, once you put 7 on your dongle you are down to one machine. That's the risk. You can't use the previous versions anymore. If you elicenser dies then you have to pay 50% of all lcenses you want to use unless you bought their dongle protection program.

There's a lot of risk now using VSL. I'm ready to turn in my fan club badge.
 

gsilbers

Part of Pulsesetter-Sounds.com
so the fx will now come onboard? those where expensive from what i remember.

also. no AUv3?
 

MartinH.

Senior Member
If you elicenser dies then you have to pay 50% of all lcenses you want to use unless you bought their dongle protection program.

There's a lot of risk now using VSL. I'm ready to turn in my fan club badge.
If it wasn't for their DRM I would be tempted to buy it for the "epic orchestra", but with stuff like this it's an easy pass for me.
 

DANIELE

Active Member
I don't want to create false hope here...

But I decided to hav a ganders at the System requirements and found a little (sneaky) goodie:

Vienna Ensemble Pro 7 - System Requirements
System Requirements
  • PC Windows 7/8/10 (latest Update, 32/64-bit), Intel Core 2 Duo or AMD Athlon 64 X2
  • macOS 10.10 (latest update), Intel Core 2 Duo
  • 2 GB RAM (4 GB recommended)
  • Working Gigabit connection between master and networked computer(s). Also works on a one-computer setup.
  • ViennaKey (Vienna Symphonic Library USB protection device) or other USB eLicenser (e.g., from Steinberg or Arturia)
  • eLicenser Control Center software (get the latest version from www.eLicenser.net)
Other configurations may work but are not actively supported.

Recommended
  • PC Windows 7/8/10 (latest Update, 64-bit), Intel i5/i7/Xeon
  • macOS 10.12 (or higher), i5/i7/Xeon
  • Fast separate hard drive (7200 rpm or faster)
  • Supported plugin formats tba. ;) <--- NOTICE THIS... Clue perhaps?! :)
  • MAS version requires Digital Performer 8 or higher
  • AAX version requires Pro Tools 10.3.5 or higher
  • 88 key master keyboard
EDIT: For all you Logic users.... could it be DUN DUN DUN.. AU...

Wait, so if I buy VEP7 they send me also the ViennaKey to make it works, am I right?
 

Living Fossil

Senior Member
I haven't read everything in this thread, but there is one question:

VE 6 came with 3 licenses.
If i upgrade to version 7 with 2 licenses, will i still be able to use the third license as version 6?
 

DANIELE

Active Member
No they won’t. You purchase it separately. Look for steinberg usb key at amazon.com or similar.
Without a doubt, most certainly not. Vienna Key (or Steinberg, Arturia USB) is required and a separate purchase.
Thanks, so I have to charge it over a possible VEP7 purchase. Before buying this I'd like to know the features, I cannot buy a black box like this. I don't know what are its features and when it will came out!
 
OP
Ben

Ben

VSL Support
I haven't read everything in this thread, but there is one question:

VE 6 came with 3 licenses.
If i upgrade to version 7 with 2 licenses, will i still be able to use the third license as version 6?
yes, but VEPro 6 and 7 are likely not compatible to each other. But still usefull if you dont need the special features of 7 in one instance. they should be able to run side by side I think.
 
Top Bottom