What's new

VEPro 7 now available!

wbacer

Senior Member
I have VEPro7 on two Mac slaves and a third instance on my PC master with is also running the latest version of Cubase 10. Before installing VEPro 7 Cubase hardly ever crashed. Last night it crashed at least a half dozen times when just trying to do a simple midi edit. Anyone else experiencing DAW problems that may be VEPro7 related? One step forward, two steps backward...
 

Wolfie2112

Senior Member
I have VEPro7 on two Mac slaves and a third instance on my PC master with is also running the latest version of Cubase 10. Before installing VEPro 7 Cubase hardly ever crashed. Last night it crashed at least a half dozen times when just trying to do a simple midi edit. Anyone else experiencing DAW problems that may be VEPro7 related? One step forward, two steps backward...
This is why I'm holding off this time until the bugs are sorted out. I immediately upgraded to 6 when it was released, only to discover it deleted all of my DNS settings. VSL reeled the update patch a couple of days later, but I learned my lesson the hard way. Let us know if you get it sorted out.
 

wbacer

Senior Member
This is why I'm holding off this time until the bugs are sorted out. I immediately upgraded to 6 when it was released, only to discover it deleted all of my DNS settings. VSL reeled the update patch a couple of days later, but I learned my lesson the hard way. Let us know if you get it sorted out.
Smart, and as you know, there's the leading edge and for early adopters there's the bleeding edge...
 

Vonk

Member
I installed 7.0.778. I have Kontakt 6 player and Kontakt 5.8.1 full version. They both passed the scan on install, but only Kontakt 6 is showing as an available plug in. I haven't yet checked every other plug-in from the VST folder but most seem to be present. However at the moment I cannot access any of my Kontakt instruments that require Kontakt full version.
I've tried a reinstall and a re-scan, but the result is the same. Any advice on what to try?
 

Dewdman42

Senior Member
For the most part VEP7 has been working for me, but I haven't tried to load all my plugins or really work with it much. I did notice that when the GUI is up it seems to suck a lot of overall CPU, not sure why, I'm interacting with VSL about it now, they don't believe me yet. Might be something I'm doing..

I do not think there is ANY rush for anyone to jump on installing this right away, especially if you're a working pro. wait for stability. There really are not any gotta-have-it new features, its just incremental usability improvements. Worth doing sooner or later, especially if you are not multi-server VEP user. But I'd wait at least a few weeks to install it, you're not really missing that much if you wait honestly. if I were a working professional I would probably wait months or longer to be honest. Might pay for it now to get the early price though!
 

Guy Rowland

Senior Member
I have VEPro7 on two Mac slaves and a third instance on my PC master with is also running the latest version of Cubase 10. Before installing VEPro 7 Cubase hardly ever crashed. Last night it crashed at least a half dozen times when just trying to do a simple midi edit. Anyone else experiencing DAW problems that may be VEPro7 related? One step forward, two steps backward...
No crashes at all here I have to say - problems, but no crashes. I'm Win 10 but all one machine, could be related to network issues? I know there have been some changes there.

I installed 7.0.778. I have Kontakt 6 player and Kontakt 5.8.1 full version. They both passed the scan on install, but only Kontakt 6 is showing as an available plug in. I haven't yet checked every other plug-in from the VST folder but most seem to be present. However at the moment I cannot access any of my Kontakt instruments that require Kontakt full version.
This sounds like a variation on my issue. All I can suggest is to open a ticket and pass the the details and your plugin log - you can find that (if you are windows) by putting %appdata%\VSL\Vienna Ensemble Pro\logs into the Windows search bar, and the file is called pluginscan.txt .
 

Vonk

Member
This sounds like a variation on my issue. All I can suggest is to open a ticket and pass the the details and your plugin log - you can find that (if you are windows) by putting %appdata%\VSL\Vienna Ensemble Pro\logs into the Windows search bar, and the file is called pluginscan.txt .
I think I have resolved this. I inspected the pluginscan.txt and saw that Kontakt 5 (and a good many other items) had been "destroyed". I had an older version of Kontakt in my VST folder as well as Kontakt 5.8.1. When the older version of Kontakt was removed and VEPro 7 re-installed, Kontakt 5 was restored.
 

Sample Fuel

Active Member
I installed 7.0.778. I have Kontakt 6 player and Kontakt 5.8.1 full version. They both passed the scan on install, but only Kontakt 6 is showing as an available plug in. I haven't yet checked every other plug-in from the VST folder but most seem to be present. However at the moment I cannot access any of my Kontakt instruments that require Kontakt full version.
I've tried a reinstall and a re-scan, but the result is the same. Any advice on what to try?

I have this problem occasionally with VE PRO 6....the only work around I have found (as dumb as it sounds) is to make a new folder where your Kontakt plugin resides and then put the Kontakt plugin inside that new folder. Rescan or relaunch VE PRO and you will most likely see the missing plugin. Unfortunately you have to leave it in that new folder. If you take it out and put it back in the old location it will not show up again.
 

Guy Rowland

Senior Member
Huge thanks to VSL - both my issues fixed in the coming build which they kindly forwarded to me to check.

Not only does it now read my UVI Workstation and all the automation windows glitches are fixed, there's a whole new feature which I think is golden - In the Automation Window, it is now possible to drag and drop with modifiers an event, and it copies and auto-increments a parameter as follows:

  • Hold Alt and drag the entry to another entry: assignment copied
  • Hold Alt-Shift and drag the entry to another entry: assignment copied, CC incremented
  • Hold Alt-Cmd (cntrl Windows) and drag the entry to another entry: assignment copied, Channel incremented
This will MASSIVELY speed up my template building. All this in 24 hours and the promise of Wake On Midi to come, outstanding.
 

nas

Active Member
Although things have been off to a rocky start, kudos to VSL for getting on it right away and interacting with everyone here to get things back on track. Also kudos to those of you who took the plunge early and having been weathering a few storms but have kept providing feedback to everyone here and to VSL.

I am confident these issues will be resolved fairly quickly. VSL is a solid company and has delivered on bug fixes and stability issues in the past with VE Pro.
 

Vonk

Member
I have this problem occasionally with VE PRO 6....the only work around I have found (as dumb as it sounds) is to make a new folder where your Kontakt plugin resides and then put the Kontakt plugin inside that new folder. Rescan or relaunch VE PRO and you will most likely see the missing plugin. Unfortunately you have to leave it in that new folder. If you take it out and put it back in the old location it will not show up again.
Yes, this is exactly what I have done after reading the pluginscan log and seeing instances of Kontakt 5 "destroyed". Vepro seems to get Kontakt dll instances confused. Anyway it is a workaround for now.
 

Guy Rowland

Senior Member
yea? That will be kind of major if so...
Indeed - read azateg's posts on the previous page :)

For where I am right now personally, today's new drag and drop automation functionality is as much of a big deal or maybe even bigger. The advantage of the template system I have right now is I also have Disabled mapped to a key, so its quick and easy to tidy up if I decide against something.

As it stands, using both methods in tandem will be fantastic - all the control I currently have, plus in future I won't need to even press that keyswitch when auditioning sounds - just play and it happens. Huge steps forward, and VEP7 transformed from quite-nice-to-have to bloody fantastic. The VE Pro Disabled Template has come of age, revolutionary stuff really.

(Side note - getting ahead of myself with Wake On Midi, but once its there then people starting new templates can use a much easier variation of the method I use to enable everything with one hit. Just put a muted dummy note on the start of every track in a project, then use the visibility agent to unmute that dummy note on every track you actually use. Press play and everything loads. Slick and quick, and all without the fairly tortuous setup needed until now).
 

Dewdman42

Senior Member
They promise that saving is faster over the network because they have implemented some compression into it. I don't use a vep server over network so I can't comment on that. My save and load times on local machine as DAW are about the same. Well load times are the same, I didn't actually compare save times... Well now that I think about it I should find out what they changed related to compression and saving and try to see if it makes any difference.
 

Vonk

Member
I've moved from 5 to 7, so not sure if the "decouple all" feature (manual page 54) is new or not. This for me is brilliant for my template already - clicking "decouple all" reduces my file size from 362mb to 16mb, which means I can go back to using autosave. However I'm unclear as to the distinction between disable and decouple.
Does "disable" empty ram but not file data, while "decouple" means Vepro data is not saved in the cubase file but the instrument remains loaded & active?
 
Top Bottom