What's new

TouchOSC Help with Logic

garyhiebner

Active Member
I'm trying to get TouchOSC working with Logic, and don't seem to be having much luck.

I have setup my iPad as a Controller in the MIDI Controllers in Logic. If I use the Logic iPad template it all works fine.

But I now want to create my own layout in ToucOSC to control CC parameters like CC1, CC11, and CC7, plus to do some articulation changes. So far I'm just trying to get the CC changes right. I have created a layout with some fades that are assigned to CC1, CC7, and CC11. I have added the layout to ToucOSC

But when I move these faders, Logic isn't recognizing any MIDI input from them. I have the correct Host IP, and incoming and outgoing ports setup, but still nothing. Plus the TouchOSC Bridge is running on my Mac.

Does anyone know how this can be? How is the Logic iPad layout working, but not if I create my own and use Control change messages?

I must be missing something out, but can't seem to figure out when it can be. Thanks in advance for any help.
 

OleJoergensen

Senior Member
When you open the Touch osc app on the ipad, you have to “click” the 2 sub menues on the top of the page to connect to the Mac. It is called: OSC: ip adress, Touchosc brige: ip adress. Did you do this?

Also I use touch osc with Osculator because osc seems limited. It is a long time since I set it up, so I don’t remember how and why?
I was inspired by this video....
 
OP
G

garyhiebner

Active Member
Thanks @OleJoergensen, yeah I have connected it to my Mac.

I haven't tried Osculator. Let me give that a go. I see in that you can take OSC messages and convert it to MIDI, so maybe that's where I'm having a problem. Thanks
 
OP
G

garyhiebner

Active Member
Still no luck with Osculator and TouchOSC and Logic. Both the inputs and outputs have been setup fine. But still Logic isn't receiving the input from TouchOSC. Anything else I could be doing wrong.
 

OleJoergensen

Senior Member
Im not sure what it can be.
Maybe try to delete the iPad from Logic. Unplug the ipad, restart Logic, then replug the ipad and wait for Logic asking if you want to “install” the ipad.
 
OP
G

garyhiebner

Active Member
OK, I got it working now. I created a fader for CC1, so its going to Control Change Channel 1, and Number 1. This works fine by controlling CC1. But when I try record when I move the fader on TouchOSC it stops playback in Logic. Any idea what this could be. Is Logic using Channel 1 Number 1 for anything else that is overriding the TouchOSC setting?

Seems to work for Expression when I set it to Ch1, Number 11. Doesnt stop the playback when recording. But Channel 1, Number 1 does.
 
Last edited:

OleJoergensen

Senior Member
I am using an multi-xy with cc 1 and cc 11 which works well.
My setup is:
Enabled. Value
Type: control change
Channel:1
Number: 1
Range 0-127

I do use single faders with other cc, which also works well.
 
Top Bottom