What's new

The White Noise Blast of Death -- I'm losing my mind

Guavadude

New Member
I'm installing the AU 1.1.0 version and Logic doesn't even see it. The link says 1.1.1 version but the download is 1.1.0. Is your version 1.1.1 and it's working in Logic? I wouldn't mind having it installed as well and ten other things also just in case. I can't add latency though.

Ice 9 1.1.0 June 24, 2016 is what is installing. I'm guessing it's 32bit and Logic is ignoring it.
 

Dewdman42

Senior Member
This is what is running in Logic for me:

Screen Shot 2021-09-20 at 2.39.28 PM.jpg

I presume its the latest version that I have posted, its been a while since I installed it.

Did you attempt to reboot your computer after install? LogicPro doesn't see some plugins after you install them until you either reboot or run the following command in the terminal and restart LogicPro:

Code:
killall -9 AudioComponentRegistrar
 

Guavadude

New Member
doh, know better and should have restarted. Usually plugins wake up after install if I just reboot Logic.
Ice9 is working! Thx for the help!
 

Dewdman42

Senior Member
in the future remember that terminal command I mentioned above, that accomplishes the same thing without a reboot. I have it saved as a script that I can just run quickly after I install plugins to make sure LogicPro will see them when I relaunch LogicPro.
 

davidson

Senior Member
I finally bought a separate analogue monitor controller with headphone amp built in, and now I run my UA interface into that to control the volume. No more walking on eggshells every time I boot logic up :)
 

Gingerbread

Active Member
Here ya go: https://www.logicprohelp.com/forum/viewtopic.php?f=1&t=145531&hilit=ice9#p757888

Note: The AU version of this plugin requires a reboot before LogicPro will see it. This is true of many plugins ever since Apple updated something in MacOS... Alternatively you can use the following terminal command to avoid having to reboot.

Code:
killall -9 AudioComponentRegistrar
Just curious, will this plugin work in the latest versions of Mac OS, which now require all plugins to be 64bit?
 

kmaster

Sleepy Member
I have this happen more times than I can count, luckily never wearing headphones. And apparently my Adam speakers have some sort of protection built in thankfully. But each time, my head snaps back so fast I feel like I've had whip lash.

The issue is definitely in the software, Logic for me. So adding another monitor controller after wouldn't make any difference since my RME UFX's volume control is still fully functional.
I am using USB to connect and might should consider getting a Thunderbolt to Firewire converter and trying that. I don't seem to remember it happening when I used to use Firewire, but that was a long time and several Logic updates ago.

Ice 9 AU doesn't work and as I mentioned, it's the entire Logic output that freezes at full blast, so I don't think anything in the DAW will help. I have to reset the audio driver in Logic or power cycle the UFX interface to make the audio blast stop.

But I think I at least found a safety net for anyone using RME interfaces and Totalmix. There's an Output Protector preset for the Auto Level that you can recall in the dynamics effect on the Main Out. The problem is that it has a 3db minimum setting for the headroom. My Software Playback audio channel in Totalmix is usually set to 0db. When using a limiter on a mix, I'm hitting .02 peak so the Auto Level is kicking in and can be heard, which I don't want.

The work around I found is to set the software playback channel to -3.1 dB. Now the software playback won't trigger the Auto Level normally but it will if Logic explodes. There's no latency and since it's below the 3db headroom threshold, there's no sound difference. I hope this helps anyone else but especially me and my tattered nerves.

Here are the settings: engage Auto Level and turn everything to the left, lowest value. Set software playback channel to -3.1

View attachment 57747
Auto level scares me—how can you trust what you’re hearing?

I’d use the Dynamics Preset settings for this, and disable the Auto Level.

::edit:: or the 'Output Protector' Factory Preset, which *does* use Auto Level—that's likely okay, too.
 
Last edited:

marclawsonmusic

Senior Member
I am using Ice9 since I saw this original post a few months ago. It works great. Also on Catalina on a fairly recent version of Logic.
 

Guavadude

New Member
Auto level scares me—how can you trust what you’re hearing?

I’d use the Dynamics Preset settings for this, and disable the Auto Level.

::edit:: or the 'Output Protector' Factory Preset, which *does* use Auto Level—that's likely okay, too.
You can tell when Auto Level is working by seeing the gain reduction in the fader metering.

I am using the Output Protector preset but the problem is that Auto Level has a 3db setting as the lowest headroom threshold. So as I detailed, you have to bring your software playback fader down -3.1db to be below the threshold. Auto Level now only activates when needed and not all the time.

Basically, they should have set the Auto Level up like Ice9 where the threshold can be positive or negative, any value from -12 to +12db, but since it's not you need to adjust to use it. You just have to kick your monitoring gain up 3db from where you normally would set it to compensate for the -3.1db playback fader new position.

Ice9 seems to be working but I still don't think it will work when Logic freaks out because it seems to me like it's a bug at the driver level and not just a plugin audio problem. I have to reset the audio driver in Logic or reboot the RME UFX to make it stop.

I do feel much better now having a software and hardware safety plan in action.
 

Guavadude

New Member
One thing I forgot to mention is if you use an RME interface and Totalmix and are using the Auto Level as output protector on the Mains, be sure to add it to the headphone outputs as well. I have the headroom threshold on the headphones set to 10db but might set it on max protection, need to confirm the best settings.

This does work well. When AL kicks in, it stays on and the gain stays reduced until you reset Logic by inserting a different instrument. You don't have to reboot the interface or Logic completely.
 

Guavadude

New Member
For the headphone outs, I'm now using the same settings on the Auto Level as the Main outs like the image I posted above: Max Gain 0.0, Headroom 3.0, RiseTime 0.1. Just be sure to lower Software playback level feeding the headphone outputs to -3.1 just like the Main Outputs.
 
Top Bottom