What's new

Template - nanoKONTROL Studio in Logic through Kontakt

ABurn

New Member
Hi there,

I've decided to go for nanoKONTROL Studio so I could control expression, dynamics, vibrato and other settings with faders on my instruments so each fader could correspond to these settings: CC1 dynamics, CC11 expression and CC 21 vibrato. Obviously, I chose "assignable" from global settings and wrote scene data from the communication tab at the top


Screenshot 2020-12-07 at 18.03.38.png
Whenever I open up Logic I use this process:

1. Open Kontakt, load up instrument, remove its current CC1 (dynamics) because it is assigned to my keyboard's mod wheel
2. Try to press learn, move my 1st fader which from the korg app is assigned as dynamics and then nothing happens!

I've realised there's a solution to do it in Logic using control surface parameters and learning these commands manually, however, this method is not working for me at all since I am using a routed template:

I basically use 1 Kontakt instance with multiple instruments and route them to Logic as aux tracks. Whenever I am assigning those settings from control surfaces it only affects the 1st track of the instance while the rest remain untouched - when I select them from DAW, keyboard responds except controls of nanoKONTROL

I've also realised if I leave CC1 on my midi keyboard and in DAW select different aux tracks through routing such as 2nd, 3rd other tracks in the same instance, they ARE being affected!

So the problem lies within nanoKONTROL for sure and I really don't understand what I'm doing wrong
 
Last edited:

jbuhler

Senior Member
do you have the Korg plugin installed? It sounds like, no, but just checking.

are you propagating your CCs across all the midi channels in your Kontakt multi?

is the Kong sending midi? If so, on what channel? Is that the same channel you are trying to control?
 
OP
A

ABurn

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #3
As you can see from the screenshot, I use Korg Kontrol Editor to assign CC on highlighted faders so I use those values to have accurate CCs. I also have their drivers installed.

I have to remove sliders from control surfaces because they are automatically assigned for volume within Logic. I can only assign these faders to 1st track of Kontakt's instance - 2nd and 3rd and other tracks don't work.

When I try to to do this for other other tracks within same instance, Logic opens up a window to override these settings because previous instrument already uses that fader, therefore, I cannot use the same fader for multiple aux tracks that come out of the same Kontakt instance.

It's weird since no matter which aux track I select from Logic, my keyboard's modwheel reacts without any problems, I'm only having the issue with this bloody controller.

I can use other controls, seems like nanoKONTROL Studio is integrated with Logic quite well, apart the problem I'm having.
 

jbuhler

Senior Member
First, thing, uninstall the Korg plugin. It allows the nanocontrol to control the mixer and the transit, but gets in the way of using the nanokontrol as a midi controller. By uninstalling the plugin, the nanokontrol will present itself to Logic as a generic midi device. In this case that is what you want. Basically I have found no way to use it simultaneously to control the mixer and midi... It's one or the other, and so either the plugin or no plugin... The other way to toggle is to delete the nanokontrol from control surfaces and that will give you midi control and last until you close Logic.

Once you have opened Logic with the Korg plugin removed, the nanokontrol should behave as if in midi mode, and your assignments on the NanoKonrtrol will then be recognized by Logic and it should map like any midi device.

I haven't used my NanoKontrol in several months, but I was planning to connect it to my new rig tonight and I'll report if it behaves any differently now.
 

jbuhler

Senior Member
Ok, so I just turned on my NanoKontrol, no plugin, and everything works as described. I have it set to send CC1, CC11 and CC21 from the first three sliders. I am using it in USB rather than wireless mode. And I had to reset the NanoKontrol so it was in the assignable mode rather than Logic mode.

Screen Shot 2020-12-07 at 2.51.06 PM.png
 
OP
A

ABurn

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #6
WOW!!! I can't believe it worked! I have to manually adjust each track's dynamics, expression and vibratos but the key here that it totally works! You sir, are a lifesaver! Thank you so much for taking your time to explain this! I've had no idea that manually switching to assignable mode will fix everything!
 

jbuhler

Senior Member
I have seen a YouTube video of someone who managed to get the NanoKontrol into a mixed mode that allowed them to control the transport and the active track's control strip with the first slider while the other sliders were controlling midi. Folks asked him in the comments how he did it but he couldn't remember. But my keyboard handles the transport, and I don't do that much automation with the mixer (and when I do I have another set of longer sliders to handle that work). So basically I just leave the NanoKontrol in assignable mode and leave the Korg plugin uninstalled.
 
OP
A

ABurn

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #8
Perhaps would you know how can i assign back the jog wheel to move forward and backwards? I've managed to remap all other settings manually except that one
 

Alex Fraser

Requires ☕️
I have seen a YouTube video of someone who managed to get the NanoKontrol into a mixed mode that allowed them to control the transport and the active track's control strip with the first slider while the other sliders were controlling midi. Folks asked him in the comments how he did it but he couldn't remember. But my keyboard handles the transport, and I don't do that much automation with the mixer (and when I do I have another set of longer sliders to handle that work). So basically I just leave the NanoKontrol in assignable mode and leave the Korg plugin uninstalled.
All you need to do here is "learn" the controls in Logic:
  • Logic Pro > Control surfaces > Controller Assignments.
  • Open the "expert view" and click "learn mode" (bottom right.)
  • Click the control/fader/knob in Logic you want to assign, followed by the control on the Nano you want to assign it to.
That's it really. You can get clever with the Midi LED settings to enable the transport to light up etc.
 

jbuhler

Senior Member
I don’t think I ever solved that issue. If I recall the jog wheel is tied to the Mackie control surface protocol and doesn’t communicate with midi. Or if it does it can only send CCs and not the keyboard shortcuts you’d need for navigation.
 

jbuhler

Senior Member
All you need to do here is "learn" the controls in Logic:
  • Logic Pro > Control surfaces > Controller Assignments.
  • Open the "expert view" and click "learn mode" (bottom right.)
  • Click the control/fader/knob in Logic you want to assign, followed by the control on the Nano you want to assign it to.
That's it really. You can get clever with the Midi LED settings to enable the transport to light up etc.
This never worked for me. I’m sure it’s something I am doing and I’m missing something basic, but I would go through this process and make the assignments but it wouldn’t take. I’ll try it again and see if I can be more specific about where in the process it breaks down.
 

Alex Fraser

Requires ☕️
This never worked for me. I’m sure it’s something I am doing and I’m missing something basic, but I would go through this process and make the assignments but it wouldn’t take. I’ll try it again and see if I can be more specific about where in the process it breaks down.
You have to be weirdly specific about the order of doing things if I remember. It's a pretty fussy process.
 

jbuhler

Senior Member
All you need to do here is "learn" the controls in Logic:
  • Logic Pro > Control surfaces > Controller Assignments.
  • Open the "expert view" and click "learn mode" (bottom right.)
  • Click the control/fader/knob in Logic you want to assign, followed by the control on the Nano you want to assign it to.
That's it really. You can get clever with the Midi LED settings to enable the transport to light up etc.

Just to be clear: I start with the Korg plugin installed and let the NanoKontrol go into Logic mode. Then I open up the Control Surfaces and find the NanoKontrol. Is that correct? I just want to make sure I'm starting from the correct starting point.
 
OP
A

ABurn

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #14
After reseting nano controller and putting it in assignable mode, I'm only struggling to put the jog wheel back where it was - I've tried taking a screenshot from it's default settings (when nano controller is integrated with Logic) and paste them after assignable mode has been set but had no luck getting jog wheel back...

I've also tried assigning its function in key commands window for moving/rewinding by frames as well as scrubbing forward/backward but jog wheel is still not moving even though nanoKONTROL mappings are LEARNED within key commands window in assignments box at the bottom right... As I'm scrolling, I'm only seeing MIDI in data coming in once custom is selected from display menu up top - next to CPU/RAM, metronome, etc but the playhead is not moving...

Screenshot 2020-12-08 at 19.54.17.png
 

Alex Fraser

Requires ☕️
Just to be clear: I start with the Korg plugin installed and let the NanoKontrol go into Logic mode. Then I open up the Control Surfaces and find the NanoKontrol. Is that correct? I just want to make sure I'm starting from the correct starting point.
No problem.
The example I gave was for the non studio version of the nano, but the posts above lead me to believe it’s the same process.

You don’t need the logic plugin installed. Or for that matter, the Korg driver since Catalina compatibility, but check on that one..

If you see midi data registered in logic when you move controls on the nano, then you’re good to go and in the right mode.
 
OP
A

ABurn

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #16
Hey guys,

MANAGED TO SORT OUT JOG WHEEL AFTER RESETTING THE CONTROLLER!

Had very helpful advice from Spitfire support and they've suggested that in order to get back jog wheel after settings have been reset, you need to set Jog Wheel to Sign Magnitude the Korg Editor app (press jog wheel to the this window show up).

Screen Shot 2020-12-09 at 2.33.23 PM.png

Afterwards within the app, you need to click on global settings in top right corner, choose assignable mode, press write then at the top while app is open press Communication - Write Scene data (you don't need to save files when you want to exit Korg App).

Launch Logic, delete all of the settings attached to the controller from Control Surfaces, press scene and cycle buttons on the controller simultaneously (it will trigger assignable mode) and then manually create Jog Wheel yourself and recreate these settings exactly - I'll attach screenshots to everything here



Screenshot 2020-12-09 at 23.11.20.png


Screenshot 2020-12-09 at 23.11.24.png

I really hope this will help someone who is struggling with a controller that has a jog wheel and wants to put it back to use after it's being set to assignable mode!
 

jbuhler

Senior Member
Hey guys,

MANAGED TO SORT OUT JOG WHEEL AFTER RESETTING THE CONTROLLER!

Had very helpful advice from Spitfire support and they've suggested that in order to get back jog wheel after settings have been reset, you need to set Jog Wheel to Sign Magnitude the Korg Editor app (press jog wheel to the this window show up).

View attachment 40825

Afterwards within the app, you need to click on global settings in top right corner, choose assignable mode, press write then at the top while app is open press Communication - Write Scene data (you don't need to save files when you want to exit Korg App).

Launch Logic, delete all of the settings attached to the controller from Control Surfaces, press scene and cycle buttons on the controller simultaneously (it will trigger assignable mode) and then manually create Jog Wheel yourself and recreate these settings exactly - I'll attach screenshots to everything here



View attachment 40824


View attachment 40826

I really hope this will help someone who is struggling with a controller that has a jog wheel and wants to put it back to use after it's being set to assignable mode!
Thank you! This is great. I'll try setting it up tonight and see if I run into any difficulty following the instructions.

Just to check: Do you have the Korg Plugin installed?
 
OP
A

ABurn

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #18
Thank you! This is great. I'll try setting it up tonight and see if I run into any difficulty following the instructions.

Just to check: Do you have the Korg Plugin installed?

Yes, download newest version for Mac, write data with these settings and you are good to go
 
OP
A

ABurn

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #19
Had another go and this solved everything:

1) Ensure that the Control Surface Plugin is not installed and that you have removed the "nanoKONTROL Studio" entry from Logic's Control Surfaces preferences:

A. Delete the control surface from Control Surfaces - Setup

B. Disable Automatic Installation when Control Surface window is open - this will disable automatically finding control surface that you’ve deleted

C. After deleting the nanoKONTROL Studio information, quit Logic Pro X and delete the following folder: /Applications/KORG/nanoKONTROL Studio Control Surface plug-in

and file:

/Library/Application Support/MIDI Device Plug-ins/nanoKONTROL Studio.bundle

To do that, you need to select the “Go to folder…” option in Finder. Copy the folder address listed above and paste into it. Once Finder shows you the folder, locate the files above and delete them. This completely removes the Control Surface Plug-in from your system or go to your drive manually and look for it if “go to folder” doesn’t work.

2) When Logic isn't running, power the nanoKONTROL Studio in "Assignable" mode, launch KONTROL Editor and transmit the settings that you wish the unit to use to it - write settings from global as well as communication tab at the top

3) Launch Logic (it should no longer automatically add the nanoKONTROL Studio to Control Surfaces) and operate the unit. You should see its incoming MIDI messages in Logic's preferences.

- From there, you can assign any routed aux tracks to any selected CC values

- To make the jog wheel work, go to edit keys - rewind/forward by one frame and learn it

All my settings are completely independent from each other, and this works as I want it to now!
 

jbuhler

Senior Member
Ok. Followed the instructions and I can see that the Korg jogwheel sends midi (CC82 value 1 on right turn, CC82 value 65 on left turn).

You should see its incoming MIDI messages in Logic's preferences.

You mean the midi monitor in the Logic LCD?

- From there, you can assign any routed aux tracks to any selected CC values

Not sure what this means. Are you hard assigning your auxes to the CCs you are not using to control the VI on the NanoKontrol?

- To make the jog wheel work, go to edit keys - rewind/forward by one frame and learn it

For clarity's sake: Logic ProX Menu>Key Commands>Edit to bring up rewind/forward by frame assignments.
 
Top Bottom