What's new

Spitfire's Solo Violin has frequent glitches / clicks. Is there something I can do about this?

Ray

Active Member
Hey, I know it was cheap. But a library with impurities, is, afterall, a useless library.

Can't earn me any money.
 

Mornats

Hobbyist
Is it the virtuoso performance violin? It's probably CPU related. I have to change my buffer from 128 to 256 or more (i7 4790k). That usually sorts the pops and crackles for me.
 
  • Like
Reactions: Ray
OP
Ray

Ray

Active Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #5
Is it the virtuoso performance violin? It's probably CPU related. I have to change my buffer from 128 to 256 or more (i7 4790k). That usually sorts the pops and crackles for me.
Yep, the virtuoso one. Thank you so much, I actually had little hope for this one!
 

ism

Senior Member
Thanks a lot! :)

Time machine only gives you the option to intensify the vibrato with the highest values of cc21. It’s a very nice effect, used sparingly, but non-essential, given the resources it requires. I would generally turn it on only when adding fine crafting to a solo line and during the final render.
 
  • Like
Reactions: Ray

puremusic

Active Member
I'm rather curious is there anyone with a setup that can handle these virtuoso and performance patches at anything less than 256 samples?
 

Pando

Deorbiting
With Reaper, I only have it glitching at <256 when the track is either armed to record, or when the piano roll is open. But when playing back an already recorded track (with piano roll closed), it's not glitching at all even with a 64-sample setting. I'm using a i7-8086K machine with 64GB or RAM.

This is interesting; I don't really know why that is, but my guess is that Reaper may be able to pre-empt the required processing time and compensate for it by sending the MIDI data to the instrument ahead of time.

This is only with the Total Performance Violin and Cello patches on SSoS, no other patches exhibit this glitching issue.

Also, with those patches, a different, but minor issue - the room ambience slider doesn't work properly. The moment you touch it, it collapses to close mic only and no amount of tweaking of this slider will get it back to what it was, until you go to the advanced setting and adjust the mic levels manually.
 
Last edited:
  • Wow
Reactions: Ray

Mornats

Hobbyist
With Reaper, I only have it glitching at <256 when the track is either armed to record, or when the piano roll is open. But when playing back an already recorded track (with piano roll closed), it's not glitching at all even with a 64-sample setting. I'm using a i7-8086K machine with 64GB or RAM.

Oh there's a setting in Reaper that reduces the CPU load when you have the piano roll open. I'll see if I can find it...

Edit: here it is. Preferences > Audio > Buffering

Tick the "allow on tracks with open MIDI editors" box.

1592329325158.png
 
  • Like
Reactions: Ray

Pando

Deorbiting
Oh there's a setting in Reaper that reduces the CPU load when you have the piano roll open. I'll see if I can find it...

Edit: here it is. Preferences > Audio > Buffering

Tick the "allow on tracks with open MIDI editors" box.

Very cool, thank you, I'll try this out later today.
 
OP
Ray

Ray

Active Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #11
With Reaper, I only have it glitching at <256 when the track is either armed to record, or when the piano roll is open. But when playing back an already recorded track (with piano roll closed), it's not glitching at all even with a 64-sample setting. I'm using a i7-8086K machine with 64GB or RAM.

This is interesting; I don't really know why that is, but my guess is that Reaper may be able to pre-empt the required processing time and compensate for it by sending the MIDI data to the instrument ahead of time.

This is only with the Total Performance Violin and Cello patches on SSoS, no other patches exhibit this glitching issue.

Also, with those patches, a different, but minor issue - the room ambience slider doesn't work properly. The moment you touch it, it collapses to close mic only and no amount of tweaking of this slider will get it back to what it was, until you go to the advanced setting and adjust the mic levels manually.
You just offered me indirect help. I also use Reaper and I disarmed the track et voila. (Also, 16 GB of RAM user here)
Thanks a TON!
 

fakemaxwell

Active Member
Yes, Reaper has Anticipative FX processing, it'll pre-process tracks for playback in the background. I usually have to toggle the "allow on tracks with open MIDI editors" depending on the project, if it's lots of SWAM instruments open at once it can slow down real fast.

The other thing that might help with Kontakt instruments is loading more of each sample into RAM, if you're not loading from an SSD already it usually helps with real time input.
 
  • Like
Reactions: Ray
Top Bottom