Spitfire keyswitches -- Arrrgh :)

Discussion in 'SAMPLE Talk' started by DerGeist, Apr 7, 2019.

  1. DerGeist

    DerGeist Active Member

    166
    177
    Oct 21, 2018
    Hi all, I know there is at least one similar thread to this one but honestly, after watching the videos and reading the suggestions I still have no idea how this works. I'm pretty dumb but even I'm starting to think the problem isn't me (it probably is).

    Working with spitfire solo strings. I'm trying to use the piano roll to switch articulations. I'm playing the long articulation in one section and want to switch to another articulation in the next. I honestly can't figure out how to automate this.

    What I'm used to is entering a midi note C0 for example, to switch articulations. This is either not possible or I just don't understand how to do it.

    Help me VICONTROL, you're my only hope.

    In ableton live if that matters.

    DerGeist.
     
  2. Garry

    Garry Senior Member

    996
    950
    Dec 28, 2017
    Switzerland
    Yes, C0 for longs, , C#0 for c.sord, extra in Solo Strings - if you have an NKS keyboard, they're lit in read for you. If not, in Kontakt you can select the red keys on the keyboard, and this will confirm the key switches for you. If your keyboard isn't triggering them, then perhaps your keyboard is transposed upwards, or if you don't have an 88 keyboard, you can't see them without transposing down?
     
  3. jbuhler

    jbuhler Senior Member

    1,645
    2,319
    Jun 19, 2016
    US
    In most DAWs, the SF Solo String keyswitches will start at C-2 rather than C0.
     
  4. Garry

    Garry Senior Member

    996
    950
    Dec 28, 2017
    Switzerland
    Interesting - that's not the case here (using Logic 10.4.4 and SF Solo Strings) - they start at C0 for me.
     
    jbuhler likes this.
  5. jbuhler

    jbuhler Senior Member

    1,645
    2,319
    Jun 19, 2016
    US
    I checked them in Logic as well. Maybe you moved the keyswitches? (I'm fairly certain I didn't.) Keyswitches for most Spitfire libraries start at C-2. I also checked Ableton Live 9, and that's also C-2 for me. So OP should transpose the keyboard down until it's at the very bottom or put the keyswitches in by hand into the piano roll. Or use CC32, which will also send keyswitches.
     
    Garry likes this.
  6. Garry

    Garry Senior Member

    996
    950
    Dec 28, 2017
    Switzerland
    Well, if I did, I couldn't tell you how to do it again! :)

    Anyway, to the OP - it works, you just have to make sure you're on the correct octave (whatever that is for you!).
     
    jbuhler likes this.
  7. SoNowWhat?

    SoNowWhat? realised I can type here

    1,972
    1,587
    Jul 26, 2016
    To the OP, are you seeing the keyswitches on the screen keyboard at bottom of Kontakt? You may need to drop it down a couple of octaves to see them and then if you prefer you can move those keyswitches (drag) to wherever you’d like them to be. I don’t have SF Solo Strings but I have many other SF libraries and as above the keyswitches are usually way down low.
     
  8. OP
    OP
    DerGeist

    DerGeist Active Member

    166
    177
    Oct 21, 2018
    Thanks all. It looks like the keyswitches somehow got turned off. I fixed it by resetting the keyswitch range and entering my keyswitches as required. This is a neat bit of functionality but it feels a bit obscure.
     
    jbuhler likes this.

Share This Page