Slow and laggy UI in Cubase on iMac Pro

Akarin

pragsound.com
Hey all. I need a bit of help as I've tried everything that I can think of. I have an iMac Pro running Cubase 10. Each time I have the UI of a Kontakt VST open and try to play, my UI starts lagging a lot. It plays fine but the transport bar gets all choppy and the mix console refreshes at about 2 frames per second. As soon as I close the Kontakt UI, it plays smoothly. I have 2 external monitors, set to native resolution and so is the one from the iMac.

What else could I try?

Thanks!
 

TintoL

Active Member
Cuabse in windows here costantly slow. You have to restart all the time to refresh. Windows sleep monitor mode does not work with cubase. It pops whenever monitor it wants. Its hell slow and ineficient with resources,. Unstable. You name it. I use it because I am too invested on it with my template.

Honestly, Vsl should take their market completely and create a new vsl sequencer.

I would be fire from my cg sup job if the softwares i am developing were this inconsistant and ineficient.


The slow has a lot to do with your cpu vs task balance. Too many instances, multy threading bad balance... It can be many things. Overall it is like that more than often.
 

colony nofi

Senior Member
Hey all. I need a bit of help as I've tried everything that I can think of. I have an iMac Pro running Cubase 10. Each time I have the UI of a Kontakt VST open and try to play, my UI starts lagging a lot. It plays fine but the transport bar gets all choppy and the mix console refreshes at about 2 frames per second. As soon as I close the Kontakt UI, it plays smoothly. I have 2 external monitors, set to native resolution and so is the one from the iMac.

What else could I try?

Thanks!
Hey mate. What OSX version are you on?
Do you have a cubase project you can create and share that shows this problem that I could test on machines here (ie, try and reproduce the problem)?