1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Question for Bricasti M7 users

Discussion in 'Mixing, Post-Production, and Effects' started by star.keys, Mar 13, 2018.

  1. star.keys

    star.keys Senior Member

    374
    38
    May 7, 2012
    Would appreciate some help from M7 users please....

    I inserted M7 on an "Aux" track in Cubase Pro 9.5 and am also using Exponential Audio plugin on the same Aux track to control the hardware M7. However I am hearing some latency on the Aux reverb track. Can someone please advise how to get rid of this latency?

    Thanks
     
  2. OP
    OP
    star.keys

    star.keys Senior Member

    374
    38
    May 7, 2012
    Just to elaborate the setup, I have added M7 as External FX into Cubase and it is connected to RME UFXII using AES/EBU cables. Then there is a MIDI connection between M7 and RME. I'm using all software instruments hosted on various instrument tracks in Cubase...
     
  3. burp182

    burp182 Senior Member

    122
    38
    Dec 22, 2008
    There isn't any real "latency" in the M7, so I'd suspect your interface/setup as the culprit. However, if you're using the M7 on full wet (as you likely should be in the configuration you've described), there is a slight delay before the onset of reverb in most programs.
    A good test might be to set the M7 to full dry and compare the original track to the return. That will show you the true delay time and you may be able to enter an offset for it if you wish. But it should be a VERY low number if things are operating properly. If you hear a distinct slap, time to go digging.
     
  4. tmhuud

    tmhuud Brown Belt

    568
    219
    Nov 19, 2006
    Hollywood
    Hmmm. No latency here in Logic. Wish I could be of more help but I did have some setup questions with the plug and Exponenential was really fast to respond and incredibly helpful. Perhaps give them a shot?
     
  5. Prockamanisc

    Prockamanisc Senior Member

    491
    190
    Jul 15, 2015
    New Orleans
    Set the delay compensation to 0 on the M7 Plugin. If that doesn't work, then does it have the delay when it's playing back? Or just when you're playing into it?
     
  6. OP
    OP
    star.keys

    star.keys Senior Member

    374
    38
    May 7, 2012

Share This Page