What's new

Question about mixing in audio vs. midi

Dewdman42

Senior Member
Ok thank you. The start times and some of the visual differences are probably moot because I simply edited both files separately to delete the silent parts at the start and also to raise the levels. So they are not consistent with each other in those respects.
roger that. that eliminates that particular concern.

it’s more the midi track plays back differently depending on what is selected, whether I record it’s output or not. Again once again, I do hope I’m explaining the issue clearly enough here!
Alright that eliminates the subject of "bouncing" from the equation.

Its more that when you play it back with the midi track selected, it sounds as you expect it to sound and if you play with some other track selected it does not sound right.

Do I have that right?

A test with PLAY directly in Logic would help to determine if VEP can be eliminated from the problem solving or not.

Anyway, Just checking but you have low latency mode off or on?
 
OP
MarcusMaximus

MarcusMaximus

Active Member
Yes you do have that right. Exactly.

I agree that the non-VEPro test is a must at this point. Tomorrow. I will also check the latency mode setting then but I’m pretty sure it’s off. Will report back my findings. Thanks again.
 

Dewdman42

Senior Member
Last night I did a test both with PLAY in VEP and PLAY in LPX. I am not getting any problem either way, they are all rendering exactly the same audio file. I used real time bouncing through a bus, like you said you did. I can't hear any differences. I'm on PLAY6, I don't know if that matters.

I'm trying to think about why selecting the midi track or selecting the audio track you're recording to would cause different results. The currently selected track is always in LIVE mode... so there could be something related to that, but I didn't get different results like you did...so I'm not sure what to think at this point..
 
OP
MarcusMaximus

MarcusMaximus

Active Member
Just done some more testing myself. No, I don't have low latency mode turned on. Makes no difference if I do.

I'm also getting exactly the same results with Play directly in Logic as I do with it in VEPro on the slave. So that seems to rule VEPro out of the equation. What's very interesting is that I still have a copy of Logic 9 installed so I tried this out there and guess what, it plays the track back perfectly and exactly the same whether I have the midi track that's playing or another track selected! So the problem seems to be exclusive to Logic Pro X and it seems not to occur on your system. Did you try simply playing it back, not bouncing or rendering in any way, with both the midi track and a different track selected? Any difference like that? Again, this only happens with a legato patch, all others play back identically independent of track selection.

I'll look into the live mode thing some more but I'd be interested in what you meant earlier about LPX doing weird things when a track header is selected because that is definitely what seems to be happening on my system.

Just to say that all of this is without using my audio interface, just the built-in output.
 
Last edited:
OP
MarcusMaximus

MarcusMaximus

Active Member
Here are the two short playback files with Play directly in Logic, the first with the midi track selected and the second with the audio track selected. You do hear the difference right? It's not just my imagination playing tricks on me is it?! o_O
 

Attachments

Dewdman42

Senior Member
Weird is a strong term I guess. Logic changes the way cores are utilized in live mode. In live mode input to the selected channel is usually passed through to the instrument channel. So when you have midi track selected then anything you might play on your keyboard or leaks in via IAC would also effect the midi playback. When you have audio track selected then if you have an audio source selected from somewhere that could leak in.

That’s all I can think of at the moment but if you google logicpro live mode you can probably find a lot said about it
 
OP
MarcusMaximus

MarcusMaximus

Active Member
Yes, I have 10.4.4 running under Sierra. There must be something going on with the interaction between whatever demands a legato patch places on playback and how LPX processes the signal differently depending on track selection, live mode etc. Thanks for your explanation and I'll certainly look into live mode and the Demix feature and do some more research to try and understand whatever is happening. I suppose I could just make sure to select all the midi tracks I am trying to render but I can imagine this might cause some problems so a fix would be preferable.

I do appreciate all your help with this. I have posted a couple of enquiries over on Soundsonline and Logic Pro Help because this involves the interaction between Play and Logic specifically so someone might have some insight in one of those camps!
 

Dewdman42

Senior Member
I haven't spent any time with my PLAY libraries yet, I got it on sale but have been entirely consumed by VSL libraries I bought since then. So i'm not sure what PLAY does with legato patches. I thought that was just a matter of overlapping them. Since it seems to be working fine for me (knock on wood) there must be something in Logic doing it, but not sure what right now...since you have sent me your project with its project settings, we should be looking at the same thing, I can't think of anything else right now. When you did the real time bounce, i persume you created a bus and then used that bus as the input for the audio track. Make sure nothing else is sending output to that bus when you do it.
 
OP
MarcusMaximus

MarcusMaximus

Active Member
Or try creating a dummy external midi track with nothing on it and select that during bounce.
Just tried that quickly with playback only. Same problem. Also set inputs and outputs to none on the audio track when that is selected. Ditto.

Yes I did the original bounce the way you describe. The most recent files though were done just bouncing the project as normal. The resulting audio files are what I've uploaded. No difference whatever way I render or even not rendering, just playing back.
 
OP
MarcusMaximus

MarcusMaximus

Active Member
Hey Dewdman42 I think I've just found a solution! Trawling through old threads on various forums after searching with some different phrasings, I came across someone with a similar issue using an EW piano. He sorted it out by setting the Process Buffer Range to medium. Mine was set to large. Changing it to medium made everything play back smoothly no matter which track is selected. When I checked Logic 9, it was at medium. Setting it to large made the problem occur there.

So it was quite simple after all! Much relieved but of course I still have to verify that all works properly in my main project.

Hope someone else finds this helpful if ever they experience something similar.
 

Dewdman42

Senior Member
Intersting. Though I have mine set to large and it seemed ok? I know for me I need it set on large because when I pipe 100 tracks through a single VEP instance, the midi will start dropping notes unless process buffer is set to large...so that is dissapointing to hear.. This seems like a bug that should be filed with Apple..but I'm not sure exactly what to tell them. Saying it "doesn't sound right" will probably not get a response.
 
OP
MarcusMaximus

MarcusMaximus

Active Member
Yeah that was me you replied to over on the Logic forum!

Strange that with it set to large you still didn't get what I'll now call the sync problem. I wonder why?

A little worrying here too because the reason I had mine set to large in the first place was similar to yours. I'll have to see how it performs once I throw the whole project at it! Hope I don't get my hopes dashed..
 
Last edited:
Top Bottom