What's new

Orchestral Template issue with trying tempo change on Logic Pro X

Hi there,

I have this issue after creating my new orchestral template (mostly Kontakt instruments), where all tracks are turned off and frozen and only unfreeze ones I am using. Then when trying to change tempo of the project by dragging the tempo up/down, the DAW interrupts me and starts re-loading all my instruments. After a while all the instruments are loaded and I can resume changing the tempo and all is fine. However if I try to do this again later, the same thing happens again. It's one thing frozen tracks having to refreeze themselves after a tempo change, but this won't even let me change the tempo, it has to re-load everything before I can do that. I thought having a template would speed things up but some of these issues with freezing and turning things off really interrupts my work flow sadly. Any idea why Logic is re-loading all of my instruments when I try to change the project tempo change?

Thanks guys,

Pav
 

VinRice

... i am a robot ...
Well it needs to unfreeze and re-render your tracks at the new tempo obviously and its just preparing for that. Are you saying that it is loading unloaded instruments that have no data on their tracks?
 
OP
pawelmorytko

pawelmorytko

Member
Yeah that's what it's doing, loading tracks that are turned off with the power button and also frozen, that have no midi data or anything. I'm used to having to press play after changing tempo to allow frozen tracks to re-freeze and re-load their midi data but this is re-loading all the tracks into Kontakt
 

clisma

Active Member
This is just a hunch that may prove to be completely off, but try changing the tempo sync button in those Kontakt instances from external to internal. That way the tempo change info doesn’t need to be passed from logic to Kontakt and maybe could prevent the instruments from being reloaded. Worth a try at least.
 
OP
pawelmorytko

pawelmorytko

Member
This is just a hunch that may prove to be completely off, but try changing the tempo sync button in those Kontakt instances from external to internal. That way the tempo change info doesn’t need to be passed from logic to Kontakt and maybe could prevent the instruments from being reloaded. Worth a try at least.
not too sure where to change this, is this in kontakt, the instrument patch inside kontakt or logic?
 

Dewdman42

Senior Member
Please report this to Apple as a bug. I think logicpro should not re-enable disabled tracks to deal with tempo change EVER, but especially if there are not any regions on them. This seems like an oversight to me when they rolled out the track disable feature they forgot to exclude disabled tracks from this tempo change procedure.
 
Top Bottom