Mystery CCs Causing me issues in Playback

Discussion in 'SAMPLE Talk' started by DerGeist, Jun 8, 2019.

  1. OP
    OP
    DerGeist

    DerGeist Active Member

    166
    177
    Oct 21, 2018
    More data! Yardwork soon.

    Spitfire libraries play the first note correctly the very first time I play the file after adding the instrument to the track. When I stop playback and start playback a second time, the note plays about the quarters of the way in. This happens with every spitfire library I own but with no other library. Happens in Kontakt 5 and 6.
     
  2. KMA

    KMA member

    165
    149
    Sep 25, 2017
    I've had similar gremlins when adjusting Kontakt's preload buffer.
    As yet unsolved.
     
  3. OP
    OP
    DerGeist

    DerGeist Active Member

    166
    177
    Oct 21, 2018
    Update 2. Actually worse in Reaper. First note does not play at all. Only seems to be Spitfire Libraries.
     
  4. Denkii

    Denkii Member

    141
    170
    Mar 15, 2019
    Batch re-save.
    Don't play from bar 1.

    Any difference in the behaviour between using a single instance with multirack and seperate instances for each instrument?
     
    rocking.xmas.man likes this.
  5. mistermister

    mistermister New Member

    2
    5
    Jun 9, 2019
    Looking at the MIDI you posted, your DAW is sending all kinds of high-up CCs that Spitfire Instruments use internally to work.

    In Kontakt, have a look in Options in the Engine tab and make sure 'Send MIDI to outside world' isn't turned on. It's usually the 'Script generated' ones that can cause problems, but anything other than 'GUI keyboard' could also result in issues with some libraries if your DAW is set to record it and play it back.

    For your existing project, try going through and removing all the CC-sets that are 103/104/107/etc. (100+)
     

    Attached Files:

    • opt.png
      opt.png
      File size:
      4.6 KB
      Views:
      8
    pottering and rocking.xmas.man like this.
  6. OP
    OP
    DerGeist

    DerGeist Active Member

    166
    177
    Oct 21, 2018
    Thanks all. Looking into it now.
     
  7. OP
    OP
    DerGeist

    DerGeist Active Member

    166
    177
    Oct 21, 2018
    Fantastic! If I create a new midi clip and paste in the notes from my recorded clip it plays just fine. I have no idea where these CCs are coming from. I only really used the mod wheel. Something is sending CCs that I am not aware of.
     
  8. OP
    OP
    DerGeist

    DerGeist Active Member

    166
    177
    Oct 21, 2018
    Edited thread title. Feels unfair to drag Spitfire into my midi CC problems.
     
    sinkd likes this.
  9. Denkii

    Denkii Member

    141
    170
    Mar 15, 2019
    Still a mystery why it didn't happen to you when you used different libraries. Or didn't you use the modwheel there?

    Any of the CCs linked to faders/knobs on your keyboard or are they not even linked to any hardware you have?
     
  10. OP
    OP
    DerGeist

    DerGeist Active Member

    166
    177
    Oct 21, 2018
    Only
    I use the mod wheel and an expression pedal and that is pretty much it. I do have a fair amount of midi gear connected though. I wonder if something is sending CCs that I am not aware of. Maybe Spitfire plugs are the only ones that react to those CCs. Every other plugin just ignored them.
     
  11. mistermister

    mistermister New Member

    2
    5
    Jun 9, 2019
    They've come from Kontakt itself. Quite a few libraries (not just Spitfire, but others, too, such as Audiobro, Embertone, etc.) use internal CCs in their scripting to control subtle things in the instrument. If you have the option 'Send MIDI to outside world' in Kontakt and your DAW is set to record any MIDI coming from Kontakt, these can interfere with the programming. Some libraries are okay with that, but some like Spitfire can be hit and miss.

    I'd just make sure you uncheck 'script generated CC's' in that Options, Handling panel in Kontakt, or make sure your DAW is not set to record outgoing MIDI from plugins like Kontakt.
     
    pottering, Denkii and Carson like this.
  12. OP
    OP
    DerGeist

    DerGeist Active Member

    166
    177
    Oct 21, 2018
    You are a life saver man. I was about to junk this project. I will honour you by not dedicating this project to you :)
     
    rudi likes this.
  13. Carson

    Carson New Member

    38
    19
    Jan 22, 2019
    Thanks mister
     
  14. Denkii

    Denkii Member

    141
    170
    Mar 15, 2019
    Good job!
     
  15. OP
    OP
    DerGeist

    DerGeist Active Member

    166
    177
    Oct 21, 2018
    Sigh. I am back to maybe giving up on spitfire again. This project is a mess of CCs for reasons I am just starting to understand (nothing to do with Spitfire). My choices seem to be blow away all of my automation and re-record the auto (although this seems to just re-create the problem in a number of instances) or replace the instruments with those from another company. Solution 1 I have been fighting with for a few hours and and am still having problems. Solution 2 works immediately with no changes to my project other than loading new instruments. While I like the sound of SSS it is really not feeling worth the effort.

    Again, I realize the problem here is me, it is just that these libraries are not working with my workflow at all.
     
  16. unclecheeks

    unclecheeks Member

    91
    41
    Apr 13, 2018
    If you’re using a lot of external midi gear, it’s quite possible there’s some unintended midi back and forth between Live and your controllers. I would download something like Midi Monitor (mac) or midi ox (win) which will let you spot incoming AND outgoing traffic on all your Midi ports. You might find something is sending midi that shouldn’t.

    If your controllers don’t have controllable leds, then you should disable all track and remote midi outs to them in Live’s preferences.

    Also, and this might no be related to the issue you’re having, but Live can be pretty shit with automation curves. You may have experienced already the pitch bend bug, where if you stop playback during a pitch automation, then restart from section that has no pitch modulation, Live won’t reset the pitch bend. At least V9 does this, they may have fixed in V10. So you have to go in and draw a small “bump” in the automation lane to get it to reset. I think this may also happen with other ccs, not just pitch bend, so something to watch out for with automation.
     
  17. pottering

    pottering New Member

    18
    15
    Apr 7, 2015
    Things you can try:

    - Consolidate the MIDI Clips in each track into a single big Clip, makes it easier to check the MIDI Ctrl envelopes (MIDI CC with envelopes has a colored dot besides it).

    - Try this M4L device that filters CC: http://www.maxforlive.com/library/device/4376/cc-filter

    - The only way I know of filtering specific MIDI CC without M4L is using a external MIDI CC source (usually a controller, but with virtual MIDI cables could be another software) to assign the MIDI CC to MIDI Rack macros or even a MIDI FX device that you then disable. Because MIDI assigned messages are not sent to the track's input anymore, they are "filtered".

    [EDIT: Duh, should have specified, the above is for Ableton Live]
     
    Last edited: Jun 12, 2019 at 6:01 PM
    unclecheeks likes this.
  18. JEPA

    JEPA Senior Member

    811
    483
    Mar 10, 2018
    Germany
    or simply assign SSS in Kontakt to respond to MIDI channel 16 for example, or MIDI channel 13.. any channel that isn't polluted by the ALL CHANNEL MIDI flow from your controllers, as same put your controllers to send out only through MIDI channel 1. Maybe this works? Do all this AFTER you have erased those evil and malicious CCs... ;)
     
  19. Peter Williams

    Peter Williams New Member

    22
    11
    Mar 26, 2018
    This issue, and others like it, have plagued me for a few years. This is why I always render to audio incrementally. There's a lot of cleanup and track combining and deleting involved, but it works. I keep all the midi clips in muted state afterwards.
     

Share This Page