What's new

MIDI file opened in Logic 10.3.1 is different (wrong)

rickdeckard

New Member
Hi, I received a midi file from a composer friend whom i have to collaborate for this particular project.
I also got an mp3 so I know how the music sounds and I have a reference.

Problem is if I open it with Logic the tempo map is wrong...by wrong I mean it's different from the original.

But if I open the same file with other programs (I also work with Reaper and Digital Performer...he made it in Cubase by the way), there the tempo map is perfectly accurate...

Do you have any clue what this could be?

I tried both importing inside an existing new project, or "open with Logic" directly to the midi file, but the result is the same.

Thanks a lot in advance

All the best!
 
OP
R

rickdeckard

New Member
Hi Jay...really??? I didn't know that...I very often write in 3/4.

But anyway no, it's not the case of this particular file.
 

Tatu

Lannister
@rickdeckard how do you import them?

Usually works fine, when I just throw the file from finder to my project or just open the file (instead of importing).

From the manual:

Opening a MIDI file as a new project

  1. Choose File > Open from the Logic menu.
  2. In the window that opens, navigate to the MIDI file on your hard drive and select it.
  3. Click the Open button.
When you open a MIDI file this way, all global project data including tempo and time signatures are included. This may be a good workflow if you are using the MIDI file as a starting point for your project.



Importing a MIDI file into an existing project



You may want to add data from a MIDI file to an existing Logic project. In this case, you can import the MIDI file rather than opening it as a new project.

  1. Open the Logic project.
  2. Choose File > Import from the Logic menu.
  3. In the window that opens, navigate to the MIDI file on your hard drive and select it.
  4. Click the Import button.
In this workflow, all the tracks are imported, but tempo data and time signatures are ignored, preserving the existing global data in your project.



Note: You can also import a MIDI file into a project by dragging the file from the Finder onto the Arrange window.
 
OP
R

rickdeckard

New Member
here's the tempo track in Logic:
l.jpeg

and here's the correct tempo track in DP (that shows up correctly in Sibelius and Reaper as well)
dp.jpeg


weird isn't it?

thanks for your help!
all the best
 
OP
R

rickdeckard

New Member
I don't know...I just opened (or imported in a new empty project) the midi file without touching anything...I thought fps only affected the interaction with a movie file, and at the moment i'm not even using one, i just received the midi file and have to work on that...I am actually working on it as I manually fixed the tempo track myself, but I found it odd anyway...

I just found out something else...here's the tempo list editor window:
l2.jpeg

at bar 8 there IS the right tempo information that's supposed to be there (113.8002) but somehow another wrong one (of 89.2420) is there in the same position...
 

A.G

Active Member
Here is my favorite trick (for opening SMF) which does not load Logic Software Instruments automatically, and all SMF MIDI & Meta data is loaded properly (at least here).

1. Logic is quitted.
2. Hold down the computer "Option" key, right click the SMF in the Finder and choose "Open with Logic".
Keep the "Option" key held down until the full Logic boot.
 
OP
R

rickdeckard

New Member
Thanks Jay.
I tried A.G.'s method but if i hold option when right clicking there's no "open with" option in the menu...

As i said I tried both opening directly and importing and both methods give the same exact result, weird
 

pmcrockett

Senior Member
Not a Logic user, but I may have an explanation. The two conflicting tempo indications in the file look like they occur at exactly the same time. The MIDI standard sorts things by time, but AFAIK when a conflict arises in which two events occur at the same time, it's up to the host program to decide how to sort the data. Logic has apparently sorted them in descending order of tempo, whereas I expect that if you look at the event list in the other DAWs you'll find that the bad tempo event is still there but is sorted in ascending tempo order so it occurs before the correct tempo event.
 
OP
R

rickdeckard

New Member
Not a Logic user, but I may have an explanation. The two conflicting tempo indications in the file look like they occur at exactly the same time. The MIDI standard sorts things by time, but AFAIK when a conflict arises in which two events occur at the same time, it's up to the host program to decide how to sort the data. Logic has apparently sorted them in descending order of tempo, whereas I expect that if you look at the event list in the other DAWs you'll find that the bad tempo event is still there but is sorted in ascending tempo order so it occurs before the correct tempo event.
Dear pmcrockett, thank you very much for taking the time to investigate this and writing here.
It would be a pretty logical explanation actually.
But the Event list in DP shows the correct data, take a look:
dp2.jpeg
 

A.G

Active Member
I tried A.G.'s method but if i hold option when right clicking there's no "open with" option in the menu...
I was posting from a Windows computer today so there is little hint in the steps order your had to find by yourself... You guys are used to get the cherry served on the cake without any effort :rolleyes:.

Here are the correct steps:

1. Right click the Standard MIDI file in the Finder and go to: Open With > Logic Pro X.
2. Hold down the computer "Option" key immediately after step one and do not release it until the full Logic loading.
 

Attachments

Last edited:
Top Bottom