Metagrid for IOS (Updated with LE Commands)

Discussion in 'Your DAW (Digital Audio Workstation)' started by jononotbono, Jan 5, 2017.

  1. Pablocrespo

    Pablocrespo Senior Member

  2. OP
    OP
    jononotbono

    jononotbono Luke Johnson

    Glad to help.

    Im trying to figure out the best way of using MG on my 27 Inch touchscreen and not sure what the best way to do it is. I was thinking of an hdmi to lighting cable and mirroring the iPad on the 27 inch Touchscreen but I have a feeling it won’t be that simple and I don’t want to waste the money. If anyone has any ideas that would be much appreciated.
     
  3. kclements

    kclements composer for media

    Anyone else having trouble getting Metagrid 1.4.6 to work with Logic 10.4? None of the functions of the built in template are working, but the midi note selections I manually set up are being received by Logic - so I know that Metagrid is talking to Logic. And when I select a pre-defined button in metagrid, logic shows a fader event being triggered.

    I tried to delete and re-setup my control surface - but still no luck. I see that it is still using Logic 10.2.4 key commands, but that shouldn't effect something as simple as Play should it?

    Cheers

    EDIT: I figured it out - I needed to select Metasystem - Logic - in for the Input Port
     
    Last edited: May 10, 2018
  4. kclements

    kclements composer for media

    Another question - now that I have my midi notes sending on Ch16 - I ran into a problem where there is no note off event being sent. So the note was hanging the system up, as Metagrid only sends a note on command?

    I think, if I set the note velocity to 0 - is that (kind of the same) as sending a note on and a note off immediately after?
     
  5. gyprock

    gyprock Senior Member

    93
    59
    Dec 16, 2010
    I’ve downloaded and copied metaserver 1.4.6 into my Mac (10.13.4) app folder. Unfortunately it refuses to open i.e. there is no M in the menu app bar (top right). Does anyone have any ideas? I intend to use it with Cubase 9.5.
     
  6. zig

    zig Member

    8
    1
    Dec 14, 2017
    Hi,
    I apologies if this has already been covered. I'm trying to make a command with metagrid to switch between Timecode and barbeats format in my cubase project.
    I found the "ruler display format" but it's toggle every possibility (barbeats, seconds,feetframes...).
    Could someone help me to make this work just with TC and Bar beat?
    Thankyou
     
  7. OP
    OP
    jononotbono

    jononotbono Luke Johnson

    There should be an assignable Cubase command called "Exchange Time Formats" under Key Commands. It will toggle between the two Time Formats you choose.
     
  8. zig

    zig Member

    8
    1
    Dec 14, 2017
    Thanks Jono it work perfectly. Thankyou also for all your very usefull contribition and tutorial.

    Will we have the chance to see expressionmap integrated in metagrid in the future?
     
  9. CDNmusic

    CDNmusic Senior Member

    118
    16
    Jun 3, 2014
    Canada
    Things have gone quite, anybody know if development continues on the faders and other enhancements announced before?
     
  10. Bassious

    Bassious Member

    10
    0
    Feb 2, 2018
    Jono: I have a question regarding setup of metagrid. The video tutorial shows the installation of the xml file to a single generic remote in setup. I did my initial setup to 3 separate generic remotes (original xml, Cubase 9 xml and metasystem macros xml) and was ambling through the learning curve. You have added the PLE and LE presets (many thanks for this mitzvah!)...but how do you install them correctly? A new area for me so Im just trying to be clear.
    Again, thanks for all your efforts and inspiration
     
  11. OP
    OP
    jononotbono

    jononotbono Luke Johnson

    If I am understanding you correctly, you have set up the 3 generic remotes with the 3 XML files provided? Also pointed Metaserver to the Macro XML (Generic Remote 3) when you installed and started up Metaserver for the first time?

    As for my LE commands I gave to MG, they are all listed in the iPad MG App but in order for them to work, in the downloaded files, you have to manually drag the LE and PLE folders to the correct Cubase Preferences folder (whilst Cubase is not open - This is because Cubase builds XML files when running so you should always close Cubase before messing with anything under the hood so to speak) and then the LE commands should work when used on the Touch Screen.

    Hope that helps. I don't actually work for MG by the way! Haha! But I'm always more than happy to help someone if I can.
     
  12. Bassious

    Bassious Member

    10
    0
    Feb 2, 2018
    Beautiful! Thats what i needed.
    Much appreciated.
    Bassious
     
  13. Jeff Tymoschuk

    Jeff Tymoschuk Senior Member

    114
    10
    Aug 14, 2008
    This was on their Facebook page the other day, it all sounds pretty promising:

    "Long time no hear - and that doesn't mean that we stopped working on Metagrid. We really want to take Metagrid to the next level. We have already added tons of new features to the new build like:
    - toggle buttons
    - bidirectional MIDI communication (Metagrid will react to incoming MIDI communication and automatically change views and button states)
    - Dropbox import/export
    - over 3000 new great icons
    - new color selector that will enable you to create any colour for your buttons and/or choose a color from over 100 suggested color themes.
    - new UI for view/button editors
    - Omni Mode - a common viewset available in all apps.
    - application lock for all apps (not only supported DAWs)

    We are still working on Unigrid implementation - a common grid that will enable you to add various objects of different sizes - buttons, faders etc. in one view. This is the most complex task that requires extensive changes in our code.

    As you can see the changes are really extensive - and we have decided that we will be releasing them as Metagrid 2.0. Naturally, you will keep your already existing views. The ETA is not set yet - we really want to release it till the end of this summer.

    We are also working on a new iPhone/iPad app that will be a perfect companion for Metagrid - more info soon.

    We really appreciate your patience and support!"
     
  14. zig

    zig Member

    8
    1
    Dec 14, 2017
    Thanks Jeff it's sound good!

    Another metagrid/cubase question,
    The disable /Enable track command work like a charm with metagrid and cubase.
    I would like also Vepro to receive the same message on the corresponding channel. I look around and found the automation mapping panel in Vepro... work well from my keyboard but nothing from metagrid.
    How to make it work?
     
  15. astrocreep

    astrocreep Member

    7
    1
    Jun 8, 2018
    This looks amazing, will be purchasing shortly. It is particulary great to see something which run's on older ipads!

    Any idea how long you'll manage to keep releasing metagrid to work on IOS 9.3.5? It's very tempting to pick up another old ipad for extra controls.
     
  16. IoannisGutevas

    IoannisGutevas Senior Member

    334
    172
    Dec 17, 2013
    Are there any news on the update of Metagrid to support Studio One 4? Any news on supporting midi faders too?
     
  17. SomeGuy

    SomeGuy Senior Member

    197
    50
    May 16, 2015
    I bought metagrid and haven't even set it up yet and now I hear there is a 2.0 coming. Anyone know if it will be a paid update? I'm guessing it will be a new app and thus I'd need to buy it again. :(
     
  18. MichaelB

    MichaelB Active Member

    25
    17
    Oct 25, 2017
    Installation problem : MetaServer - macOS Sierra 10.12.6

    I've tried to install the server but there is just a popup message : This application has not been developed by an approved developer : Move to trash - Yes - Cancel

    I went into System Preferences - users - Login items - Items will open automatically

    and also

    Security $ Privacy - General - Allow Apps downloaded from - Anywhere

    Any suggestions ?
     
  19. MisteR

    MisteR Senior Member

    127
    83
    Aug 7, 2014
    Did you try right button clicking (or holding control button and clicking) and choosing open from the menu that appears? You’ll get a warning but you can continue then.
     
  20. MichaelB

    MichaelB Active Member

    25
    17
    Oct 25, 2017
    I get a warning sometimes and most of the time no warning, just nothing happens.

    I checked my log files and found this line : amfid MacOS error: -2147409652
    Applicatgion/MetaServer.app/Contents/MacOS/Metaserver signture not valid : -2137409652
    AMFI : code signature validation failed.
    cert[2] : AnchorTrusted = (leaf)[force]> 0
    cert[0]: Revocation = (path)[force]> 1
     

Share This Page