1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Logic Pro X - Controller Data Overload

Discussion in 'Newbie Questions' started by Stillneon, Mar 12, 2018.

  1. Stillneon

    Stillneon Member

    13
    4
    Dec 19, 2014
    Looking for some advice: Using a Korg nanoKontrol Studio Midi Controller and mapped two faders for dynamics and expression for Spitfire libraries. Keep getting an overload situation with thousands of nodes on the controller shapes in the automation lanes. See pic below.

    Is there a way of reducing the amount of data sent or perhaps received in Logic so that the program doesn't error.

    Many thanks Screen Shot 2018-03-12 at 17.40.52.png Screen Shot 2018-03-12 at 17.50.03.png
     
  2. gpax

    gpax Senior Member

    532
    197
    Oct 22, 2013
    Welcome!

    The nanoKontrol is most likely NOT the cause of the alerts, but the symptom of what the alerts are telling you. It may seem the nano is triggering these, but in fact, it is probably only exacerbating how your system is struggling to keep up. Some sample libraries demand a lot from your CPU.

    Your audio buffer sizes may probably be set too low in Logic Pro X, so I would check there first. Sometimes you have to experiment, gradually raising it until you quit having issues:

    https://support.apple.com/en-us/HT203930

    To ask the obvious, how much memory do you have installed? That too can be a factor in handling sample libraries, though you may already be aware of this.

    As for sample libraries like Spitfire in Kontakt, there too you have to optimize Kontakt’s settings to find that sweet spot while you work:

    https://support.native-instruments....-Can-I-Optimize-the-Performance-of-KONTAKT-5-

    It’s about four years old now, but this overview by Impact Soundworks is useful also:

    https://impactsoundworks.com/optimizing-your-kontakt-workflow-part-1/

    As for the nanoKontrol, that kind of data output can easily be smoothed out if you trace back over it with the pencil tool. Sometimes, those points are all being generated because you are not turning the knobs (edit: or sliders) fluidly enough, and with something small like the nanoKontrol, there is only so much you can do, short of trying something else with a bit more of a throw. I don't have the nano, but in its editor software, see if there is a way to adjust the interpolated hardware sensitivity.

    Finally, how many mic positions are you loading with the Spitfire library? Each mic you use loads more into RAM, and increases the load on your CPU, relative to your system specifications.

    Greg
     
    Last edited: Mar 12, 2018
  3. Saxer

    Saxer Senior Member

    3,215
    2,818
    Mar 30, 2008
    Frankfurt/Germany
    Maybe have a look under File / Project Settings / Recording

    There's a check box for "MIDI data reduction". Don't know if that helps but might be worth a try.

    Looking at your CC curve it looks like you made CC overdubs without erasing the previous curve. So you get two overlapping curves which ends up in heavy jumps. Erase the CC data before overdubbing new once.

    A lot of CC data normally don't produce system overload. MIDI work is nothing that stresses any computer of this millennium at all. It's probably the selected instrument that causes CPU overload. Don't know if that's because of too many MIDI data though.
     
    Last edited: Mar 13, 2018
  4. OP
    OP
    Stillneon

    Stillneon Member

    13
    4
    Dec 19, 2014
    Many thanks Greg for the reply and those useful links.

    Buffer size is 512 samples. Audio Interface is Scarlett 18i20. Machine is a late 2015 MacBook Pro i7 with 16GB RAM. Libraries running from T5 SSD. CPU doesn't get above 50% although one thread is constantly pulsing up to about 25%.

    Using the pencil draw there's no problem. With the controller, the slider (within Logic) when playing back is jumping back and forth like there's a conflict. The midi indicator in SCS instance within Kontakt is constantly on even when nothing is playing or moving on the control surface. Two mic positions (C & T).

    I wonder whether I have a rogue midi controller signal from my keyboard as the CPU / Midi activity is still there even after disconnecting the control surface?

    Jonathan
     
  5. OP
    OP
    Stillneon

    Stillneon Member

    13
    4
    Dec 19, 2014
    Thanks Saxer

    The Midi Data Reduction is checked but doesn't seem to make any difference. The jumps may be related to an unwanted controller signal which I've noticed is there all the time...more investigation needed I think..

    I'm also a little unsure of the Track vs Region automation situation. More reading required I guess, as I believe they may have the potential to conflict with one another?

    Jonathan
     

Share This Page