What's new

Logic Pro X and Kontakt 6 on start up

from_theashes

Active Member
Hello everybody,

I‘m using a huge orchestral template in Logic Pro X with over 1000 tracks of Kontakt 6. I have them all inactive and ready to go, so the template loads in an instant and I just activate tracks, that I want to use. But sometimes, when I want to open a project, Logic loads several instances of Kontakt on start up that are not active in that session. This, of cause, takes time and clusters my RAM. I even have „only load plugins needed“ active... but still it loads plugins on tracks, that don’t have midi information on them. What am I doing wrong here?
 

Alex Fraser

Requires ☕️
Are the instances in a stack? There’s a couple of conditions whereby Logic will activate all tracks in a stack upon loading a template, even if no midi is present.
 
OP
from_theashes

from_theashes

Active Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #3
Are the instances in a stack? There’s a couple of conditions whereby Logic will activate all tracks in a stack upon loading a template, even if no midi is present.
Yes, the are all organized in stacks. How can I turn that off?
But it only happens when I have some tracks with midi information. My empty template loads in an instant.
 

jcrosby

Senior Member
Anything you have selected will be enabled. If that template was stored with the top of the stack selected then all instruments in that stack will be enabled on startup. Just select a single instrument not in a stack, or create an empty midi track with no instrument and select that, then resave the template.

If you're using VEP you can't avoid this in terms of selecting a single instrument from a VEP instance. VEP is an "instrument" as far as logic is concerned, saving the template with any one instrument from a VEP instance will enabled that entire VEP instance. (That's a VEP architecture issue, not a Logic issue)...

Same solution... Keep a MIDI track with no instrument, or an empty kontakt in the template, select that only, and re-save the template. All instruments should be 'sleeping' the next time you open the template...
 

jcrosby

Senior Member
Yes, the are all organized in stacks. How can I turn that off?
But it only happens when I have some tracks with midi information. My empty template loads in an instant.
Ah. There's your issue. Logic leaves any track with a MIDI clip on it enabled. It has to for a project to work. If not then how would anything playback when you opened a session the next time you sat down to work on it?

If Logic did't do this, this would require you to manually re-enable every single instrument you had midi on in a session every time you opened it. Depending on the session this would take you far more time than simply waiting a few moments for some instruments to load...


 
Last edited:
OP
from_theashes

from_theashes

Active Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #7
Ah. There's your issue. Logic leaves any track with a MIDI clip on it enabled. It has to for a project to work. If not then how would anything playback when you opened a session the next time you sat down to work on it?

If Logic did't do this, this would require you to manually re-enable every single instrument you had midi on in a session every time you opened it. Depending on the session this would take you far more time than simply waiting a few moments for some instruments to load...


Sure... if Logic would ONLY load the tracks with midi-information on them, there would be no problem... but Logic loads tracks a lot of tracks with NO midi-information on them!! And I don't know why -.-

My solution for now is to disable all tracks with midi and safe the project. Next time I want to work on that project, open it up and reactivate all tracks with midi on them and keep writing.
 

kmaster

Sleepy Member
Sure... if Logic would ONLY load the tracks with midi-information on them, there would be no problem... but Logic loads tracks a lot of tracks with NO midi-information on them!! And I don't know why -.-

My solution for now is to disable all tracks with midi and safe the project. Next time I want to work on that project, open it up and reactivate all tracks with midi on them and keep writing.
Can you post a screenshot?
 

jcrosby

Senior Member
Definitely a good idea to have a looksie as kmaster suggested... I've found this feature to be rock solid on 3 different machines.

Also any chance you have some fancy routing happening in the environment?
 
Top Bottom