What's new

Logic MIDI CC not chasing!

daounandout

New Member
Been pulling my hair out with this for so long now and I wanna fix it once and for all. Any help MUCH appreciated!

- MIDI CC data doesn't chase. If I play the middle of a region where the CC line is flat and has no nodes, it's set at some sort of 'default' value which is incorrect. It only corrects itself when the playline passes a node in the CC automation.

- I also notice that, if I play from before a node, and Logic correctly follows the MIDI CC automation, when I hit stop,Logic seems to flip to that 'default' value, on multiple CCs (I can see this reflected in the plugin the CCs are controlling, for instance Kontakt)

---

I've tried:

- Turning off "Clip Length" on all regions, and it is off by default for the whole project.

- Changing the MIDI channel of the CC data (even though I can't see why this would work... and it didn't).

- MIDI Chase Project Settings are as follows:

Untitled.png

---

Please tell me this isn't unsolvable!

Many thanks,

Jon
 

A.G

Senior Member
Been pulling my hair out with this for so long now and I wanna fix it once and for all. Any help MUCH appreciated!

- MIDI CC data doesn't chase. If I play the middle of a region where the CC line is flat and has no nodes, it's set at some sort of 'default' value which is incorrect. It only corrects itself when the playline passes a node in the CC automation.

- I also notice that, if I play from before a node, and Logic correctly follows the MIDI CC automation, when I hit stop,Logic seems to flip to that 'default' value, on multiple CCs (I can see this reflected in the plugin the CCs are controlling, for instance Kontakt)

---

I've tried:

- Turning off "Clip Length" on all regions, and it is off by default for the whole project.

- Changing the MIDI channel of the CC data (even though I can't see why this would work... and it didn't).

- MIDI Chase Project Settings are as follows:

View attachment 52132

---

Please tell me this isn't unsolvable!

Many thanks,

Jon
Hi,
Fortunately I have tested CC chasing of say 90% of DAWs, and may say that Logic CC chasing is rock. It chases the CC messages twice: on transport Stop and Play. I noted Logic only resets CC1 (Modulation) on transport Stop, but this can be ignored via a check box in the Inspector.

Could you answer the following questions so I can have a clear idea about your issue:

1. Do you use any MIDI FX plugin (Scripter etc). If yes which one?

2. Do you use any Kontakt KSP Multi script?

3. Which Kontakt instrument/library does not respond to Logic CC chasing?

Could you provide a screenshot of the MIDI region CC automation.
 
OP
D

daounandout

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #3
Hi AG, thank you so much for your reply! Yes, it seems rocky indeed!

To answer your questions:

1) I currently have some MIDI-controlled FX (softube modular) running in the project, but not on the channel in question. No MIDI FX in the project currently, however there were some in there previously (on this same channel, not the one I'm having problems with CC chasing on). I had run some scripts to filter incoming MIDI, but all of that is gone now. Not sure if there would be any residual effect of that.

2) Not that I know of, unless that's built into any instruments I'm using. Not using any multis in kontakt, all individual instruments per channel.

3) A big culprit is Spitfire Symphonic Strings in Kontakt. The CC data is on a track stack, being sent to its subordinate tracks (string section). There is no conflicting CC data written on the individual string tracks.

Cheers!

Jon
 

Heinigoldstein

Active Member
Been pulling my hair out with this for so long now and I wanna fix it once and for all. Any help MUCH appreciated!

- MIDI CC data doesn't chase. If I play the middle of a region where the CC line is flat and has no nodes, it's set at some sort of 'default' value which is incorrect. It only corrects itself when the playline passes a node in the CC automation.

- I also notice that, if I play from before a node, and Logic correctly follows the MIDI CC automation, when I hit stop,Logic seems to flip to that 'default' value, on multiple CCs (I can see this reflected in the plugin the CCs are controlling, for instance Kontakt)

---

I've tried:

- Turning off "Clip Length" on all regions, and it is off by default for the whole project.

- Changing the MIDI channel of the CC data (even though I can't see why this would work... and it didn't).

- MIDI Chase Project Settings are as follows:

View attachment 52132

---

Please tell me this isn't unsolvable!

Many thanks,

Jon
I hear you! I‘m struggling with this for a long time and I have no idea, why this happens. It‘s not on every track, not in every project and it has nothing to do with a certain libary either. I‘m actually not even sure, if it‘s only with Kontakt tbh. I‘m really curios if any knows a solution !
 

Martin S

Discount Bassy
I’ve had the exact similar problem years ago with my Logic projects. I somehow managed to fix it, and if I recall correctly, there appeared to be some track CC MIDI data that was related to the Smart Controls pane (not entirely sure about this as it was a long time ago)…

If my memory serves me right, the issue was CC Data (When ’Track’ was selected in the automation pane) overriding the ‘Region’ CC Data, or jumping back to random/mystery default setting as in your video…

Are you sure there isn’t any MIDI CC data in your track, when ‘Track’ is selected in the automation window (as opposed to when ‘Region’ is selected)?
 
Last edited:

A.G

Senior Member
Here's a quick video showing the behaviour I'm seeing.
Fine. I watched the Video and all you say is true.
Logic sends a reset (on Stop) for some CC# definitions - CC1 (Modulation) for example. Sometimes this is a problem for a few 3rd party Instruments.

Select the "Summing" track (where the CC region is) and enable the "No Reset" checkbox in the Instrument track inspector. This option ignores the CC Reset chasing on stop.

no_reset.png
 
Last edited:
OP
D

daounandout

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #9
Hi AG, apologies for my slow reply! Really busy on this project. I've tried what you've said, but it doesn't work, unfortunately. I have exactly the same behaviour, and a reset of some kind is still happening when I stop playback.

I've checked the "No Reset" box, and also turned off "Clip Length" for all regions. No luck. I'm resigned to thinking Logic's MIDI CC handling is just a bit rubbish.

Do you have any other ideas?

I even called Apple Support about this and another glitch. We went through a number of troubleshooting tasks, but their best advice was just that 3rd party plugins can affect the core code of Logic and make it misbehave. Not sure how likely that is, but it seems that's where we're at until Apple can come up with a fix for this.

I'd rather they fix this than bring new features to Logic at this point.
 
Top Bottom