Logic & Kontakt High CPU with only one Instrument

Discussion in 'Your DAW (Digital Audio Workstation)' started by Y34RZ3R0, Apr 11, 2019.

  1. Y34RZ3R0

    Y34RZ3R0 New Member

    9
    3
    Sep 21, 2017
    Literally only have one instrument loaded in my logic session and one of my cores spikes when playing the instrument. This really only happens within Kontakt, specifically spitfire instruments and my CPU overloads (currently testing OA Felt Grand Piano). I am running my samples on a Samsung 850 EVO SSD through USB-C.

    Is my Macbook Pro too shit to run a simple session? Or are my settings incorrect somewhere? I've attached photo's of my specs and settings. Please let me know if there is anything I can do to fix this headache.
     

    Attached Files:

  2. Manaberry

    Manaberry Active Member

    265
    215
    Apr 9, 2018
    Try to turn on the multiprocessor support in Kontakt (set to maximum cores available) and try. Should fix your "one core" spike.
     
  3. OP
    OP
    Y34RZ3R0

    Y34RZ3R0 New Member

    9
    3
    Sep 21, 2017
    Thank you for swift suggestion. That certainly helped a shit load. I was always under the impression that multiprocessor support and logic don't play well. I suppose I will give this a run for a while and see how it plays out.
     
  4. Dewdman42

    Dewdman42 Senior Member

    1,697
    775
    Oct 28, 2016
    Logic sends the currently selected record enabled track into so called “live Mode” and live mode goes through a single core. In playback mode logic spreads the load around more. No idea why they feel they need to do that. Kontakt must be forking it’s own threads Internally in order to spread the load but note that when you are not in live mode you may fare better to turn that kontakt option back off. Try both ways.
     
  5. Manaberry

    Manaberry Active Member

    265
    215
    Apr 9, 2018
    I talk too fast and I was sure missing something about Logic and its workload stuff. (I don't own Logic so I just pointed out what seemed to be wrong to me ^^)
     
  6. Silence-is-Golden

    Silence-is-Golden ^^

    1,314
    679
    Jun 8, 2015
    According to a well informed member kontakt 6 performs much better on osx
     
    kmaster likes this.
  7. babylonwaves

    babylonwaves Senior Member

    878
    546
    May 9, 2015
    Bad idea. If you turn MP support on in Kontakt it will interfere with the MP support in Logic. So, once your project becomes dense and creates a lot of load, you run into new issues. The spikes are less prominent in K6 but in comparison to other hosts (e.g. Cubase), there are still more spikes in Logic.
     
    Dewdman42 likes this.

Share This Page