Logic and Track Delay Issue: Help Needed

Bender-offender

Active Member
I have a number of instrument tracks in Logic 10.4.1 containing patches from Cinematic Studio Strings (only Legatos, no other articulations) not responding to the negative track delay. In the Inspector, under the Track column, I have set the "Delay" amount set to -250ms for CSS Classic Legatos. My issue is when Logic is playing, the tracks which have a negative delay are playing late -- as if the Inspector is completely ignoring the Track Delay.

Am I using the Track Delay incorrectly? I know there is also Region Delay, however, I setup this Logic template to not have to mess with region delay at all.

Is there something else I'm doing incorrectly? Is this a Logic bug?

Thanks for the help!
 

gsilbers

Part of Pulsesetter-Sounds.com
im guessing your track delay is to play CSS better? in the beat?

there is also the sample delay plugin that can be changed to ms and you can change it to 250ms. it will delay the audio though.
 
OP
Bender-offender

Bender-offender

Active Member
im guessing your track delay is to play CSS better? in the beat?

there is also the sample delay plugin that can be changed to ms and you can change it to 250ms. it will delay the audio though.
Thank you for the reply, gsilbers. Yes, I am using Track Delay so that CSS Legatos are on the beat. I primarily use Cubase, which has a track delay slider in the Inspector as well, but I'm using Logic at the moment on a project and thought the Track Delay in Logic's Inspector did the same thing as Cubase's. Is the Track Delay not supposed to be used this way? Is it meant for a different usage?

In Cubase, I normally have a regular CSS patch loaded with all the articulations available. I have Logical Editor presets I made to offset which ever articulation I'm using based on its negative delay as explained in the CSS manual. As you know, in Logic, the Transform Window can move notes as well, but it only does it by ticks and not milliseconds (Cubase gives you the option for either in the Logical Editor). So to work around this in Logic, I just created tracks with Legatos only and hoped to use the Track Delay so that it will always be on the beat regardless of tempo.

Thanks again for the help :)
 
OP
Bender-offender

Bender-offender

Active Member
After trying different things, it seems that I need to click on the track that is having the delay problem to put it in Live Mode, and once I do, the MIDI will play in time and (so far) stay that way. But if I close that project, then reopen it, the same tracks go back to being behind the beat.

Is this meant to happen? Is the Track Delay in the Inspector designed to follow its settings only if that track is in Live Mode? I've tried switching Multithreading in Preferences to Playback Tracks Only and it didn't seem to help.
 

jonathanwright

Senior Member
IIRC I had a similar issue in the past when I tried to apply a delay to a track.

I got around it by applying the delay to the regions instead, which works fine.
 
OP
Bender-offender

Bender-offender

Active Member
Thanks for the replies :)

I was trying to avoid needing to apply Region Delay since you have to do it each time you create a region. I also wanted to avoid it since region delay can change with tempo changes.

I guess I’m stuck with one or the other. Has anyone reported to Apple as a bug?
 

jonnybutter

Active Member
I am having this same problem lately in Logic. I find track delay resets itself to zero often, and it didn't used to do that. Pretty sure not operator error.
 
OP
Bender-offender

Bender-offender

Active Member
I am having this same problem lately in Logic. I find track delay resets itself to zero often, and it didn't used to do that. Pretty sure not operator error.
Dewdman42 had suggested a plugin named "Latency Fixer" by Expert Sleepers which I'm testing out now. If you end up using it as well, I'd be curious to hear your results. :)
 

agobbett

New Member
I know this topic is old, but I have been searching for a solution to this problem. Anyone have any updates on this?
 

jonnybutter

Active Member
I'm no longer having this problem, but I keep Logic upgraded. I think the OP said he was on 10.4.1. I guess if you aren't updating Logic, try that first (as ever).
 

jcrosby

Senior Member
I have a number of instrument tracks in Logic 10.4.1 containing patches from Cinematic Studio Strings (only Legatos, no other articulations) not responding to the negative track delay. In the Inspector, under the Track column, I have set the "Delay" amount set to -250ms for CSS Classic Legatos. My issue is when Logic is playing, the tracks which have a negative delay are playing late -- as if the Inspector is completely ignoring the Track Delay.

Am I using the Track Delay incorrectly? I know there is also Region Delay, however, I setup this Logic template to not have to mess with region delay at all.

Is there something else I'm doing incorrectly? Is this a Logic bug?

Thanks for the help!
I'm using negative delay with Nucleus and it's fine so if this was an issue in 10.4.1 it seems to be fixed now.