What's new

Korg nanokontrol 2 problems (Solved)

ThomasJ.Curran

New Member
So a bit of backstory... I’ve been using the korg nanokontrol 2 for over two years now with no problems until recently. When I first plugged it into my macbook pro it worked straight away with Cubase, I didn’t need to download any additional software. Recently I started using logic due to collaborating with other composers who also use it, as it made sense to be on the same DAW. When I began using logic my nanokontrol wasn’t working, I found out I had to download the korg editor which I did, followed the instructions and got my controller working in logic.
However, since downloading the korg editor, my nanokontrol doesn’t work when I turn on my computer. I have to unplug, and then re plug it in every time I want to use it. This also happens when my macs asleep and I open it back up again. I still have to unplug the nanokontrol and re plug it in every single time!
I‘ve tried uninstalling the korg editor and trying it without, however the problem still persists, even in cubase now. So not sure how to fix it. It’s obviously not a major problem as it still works but it is annoying and disrupts my work flow.
if anyone has any suggestions or experience with this, your help and advice would be most appreciate.
Cheers,
Thomas
 

jbuhler

Senior Member
The Korg Nanokontrol is a bit temperamental with Logic. I don't have the issue you have since I don't use Cubase, and I turn the Nanokontrol on only when I need it, so I don't experience the start up issue. I will say that I never let my computer go to sleep because waking up from sleep causes so many issues. I just sleep the screens.

In any case, for all the supported DAWs except Logic, you put the Nanokontrol into midi mode or into Mackey mode (to control the mixer) for the DAW by using a key combination to set the mode. With Logic you have to install or deinstall (or enable or disenable) the Korg plugin. It's a pain. I have permanently deinstalled the Korg plugin and just run it in midi mode.

Here's a good thread: https://vi-control.net/community/threads/template-nanokontrol-studio-in-logic-through-kontakt.102585 I don't think it addresses your issue but it does have a lot of good information on using the Nanokontrol in Logic.
 

DimensionsTomorrow

Active Member
I had an issue with the Mac/Logic not seeing my NanoKontrol 2. It turns out I had to uninstall the Korg driver and reboot the computer and then the Mac/Logic could see it (with no Korg driver installed). Editor also sees it fine.

I’m not sure if it is the same issue, but I just got mine working yesterday and it was driving me nuts so I figured it was worth a shot.

 
OP
ThomasJ.Curran

ThomasJ.Curran

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #4
The Korg Nanokontrol is a bit temperamental with Logic. I don't have the issue you have since I don't use Cubase, and I turn the Nanokontrol on only when I need it, so I don't experience the start up issue. I will say that I never let my computer go to sleep because waking up from sleep causes so many issues. I just sleep the screens.

In any case, for all the supported DAWs except Logic, you put the Nanokontrol into midi mode or into Mackey mode (to control the mixer) for the DAW by using a key combination to set the mode. With Logic you have to install or deinstall (or enable or disenable) the Korg plugin. It's a pain. I have permanently deinstalled the Korg plugin and just run it in midi mode.

Here's a good thread: https://vi-control.net/community/threads/template-nanokontrol-studio-in-logic-through-kontakt.102585 I don't think it addresses your issue but it does have a lot of good information on using the Nanokontrol in Logic.
thank you, I’ll check out that thread
 
OP
ThomasJ.Curran

ThomasJ.Curran

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #5
I had an issue with the Mac/Logic not seeing my NanoKontrol 2. It turns out I had to uninstall the Korg driver and reboot the computer and then the Mac/Logic could see it (with no Korg driver installed). Editor also sees it fine.

I’m not sure if it is the same issue, but I just got mine working yesterday and it was driving me nuts so I figured it was worth a shot.

Thanks, I’ll give it a try. Are the drivers from it automatically installed when you first use it? Because I’ve never installed a driver for it
 

DimensionsTomorrow

Active Member
I don’t think so. There is a driver on the Korg site for the NK2, but apparently it doesn’t work well with Logic. My Mac didn’t even recognize the NK2 at all until I ran that uninstaller and then it worked perfectly.
 

jbuhler

Senior Member
I find the Nanokontrol works best without the Kong plugin and without installing any driver so Logic thinks it’s just a generic midi device. You do need the editor if you want to change the assignments on the Nanokontrol itself. That’s never caused me any issues though.
 

gh0stwrit3r

I love paper
I will create a detailed instruction video about how to set it up on a Mac with Logic Pro (I'm on Catalina). I'm currently using the sliders for dynamics, expression, vibrato and mic settings.
I use the buttons for play, stop, record etc.., just for what they were ment to do I guess.

Should be online this Thursday. I will post it here in the Gear section.
 
OP
ThomasJ.Curran

ThomasJ.Curran

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #9
I've fixed the main issue, I reset the preferences in logic and it seemed to work (when I first installed Logic I think it was trying to auto map the nanokontrol to its own settings, I got rid of that). Now it works on both logic and cubase without having to unplug it all the time.
 
OP
ThomasJ.Curran

ThomasJ.Curran

New Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #10
I will create a detailed instruction video about how to set it up on a Mac with Logic Pro (I'm on Catalina). I'm currently using the sliders for dynamics, expression, vibrato and mic settings.
I use the buttons for play, stop, record etc.., just for what they were ment to do I guess.

Should be online this Thursday. I will post it here in the Gear section.
That would be really helpful for all of us newbies to logic, thank you! It took a long time to get the nano working in logic properly
 
Top Bottom