Kontakt only receives midi channel 1 when in VEP Pro

Discussion in 'SAMPLE Talk' started by mbagalacomposer, Feb 7, 2015.

  1. Past week I've been giving VEP Pro a shoot on my rig, overall it seems like its going to be an incredibly useful but for one glaring issue.

    When I load up Kontakt in VEP Pro, no matter what midi channel I use Kontakt receives one.

    I've tried it in both Logic X and Cubase 7 and have had the same results, not sure if I'm just missing something glaring here or if this is a known issue.

    I'm running a early 2012 27 in i7 iMac w/ VEP on the same system as my DAW.
     
  2. vrocko

    vrocko Active Member

    266
    32
    Dec 22, 2010
    Orange County, CA
  3. OP
    OP
    mbagalacomposer

    mbagalacomposer Member

    Thanks! Helpful overall, but still no mas with Logic. I did figure it out with Cubase, but as we know the two programs work very differently.

    Still kind of stumped, I'm wondering if it has something to do with the way I'm setting up the multi-instruments in environment but I should just be able to create a multi-instrument and link it to the instrument track?

    Totally stumped on this one.
     
  4. vrocko

    vrocko Active Member

    266
    32
    Dec 22, 2010
    Orange County, CA
    I am in the middle of switching to Cubase from Logic and I am not at my studio so I will try my best to remember how I do it.

    1- Creata a software instrument track and set it to midi ch1
    2- Add an instance of Vepro(multi out 16xstereo)
    3- Create as many midi tracks as needed for that instance I believe the shortcut is control/return, this will create tracks with the next midi ch.
    4- if you need indivudual outputs go into the environment and click the plus sign on the softwate instrument track for as many outputs as you need.

    -Instead of midi tracks you can use Aux tracks by going into the mixer and clicking the + symbol on the instrument track for as many midi channels you need, then select those tracks in the mixer, then in the options section of the mixer choose 'create tracks for selected channel strips". Those aux tracks will then appear in the main page and act as your midi tracks.

    Let me know if this gets you going.
     
  5. ceam

    ceam New Member

    17
    1
    Jan 27, 2009
    Make Sure your Instrument track with VEP is set to channel ALL instead of channel 1
     
    musicalweather likes this.
  6. sinkd

    sinkd Senior Member

    751
    129
    Dec 4, 2005
    Western North Carolina
    If Logic X still requires the multiport layer you should be able to download it from Vienna in your user area. EastWest Lurker is an authority on this setup, if you want to search some of his posts.

    DS
     
  7. EastWest Lurker

    EastWest Lurker Senior Member

    Email me andI will send you a VE Pro v0frame with Kontakt setup properly using the Factory library and a Logic Pro project properly set up to connect to it.

    [email protected]
     
  8. Phil81

    Phil81 New Member

    5
    0
    Jan 29, 2019
    Since this post is from years ago, I'm not sure how much I'd be contributing to it but here it goes...

    1. Open an instance of Kontakt;
    2. Load an instrument;
    3. Go to that instrument's main panel (where you see the name of the patch) and select MIDI [Ch] input to Port A [From Host]. Then match which midi channel you assigned that instrument on VEP Pro to receive data from with Kontakt. So let's say you want to send MIDI data on Channel 2, then in Kontakt, choose Port A [From Host] 2. Done.

    I hope this sheds a light albeit way late in the game. hehe.
     

Share This Page