What's new

Kontakt/Cubase bug with randomization scripts

enCiphered

Active Member
I have problems using randomization in kontakt within cubase.
All libraries which allow randomization will never load true random results, always the same samples appear. I have made a video to showcase the issue with haunted spaces:

http://cipheryourdream.com/misc/haunted_bug.webm

This issue does not affect the the standalone version of kontakt, only the vst instrument within cubase. Has anyone experienced the same bug?
I´m using the latest kontakt 5, cubase pro 9 version on a windows 10, 64bit machine.
 

EvilDragon

KSP Wizard
Well that's weird, because there's no functional difference between how a script is executed in standalone, vs how it's executed in a host...
 
OP
enCiphered

enCiphered

Active Member
Yes, its really strange. I don´t know if I should contact NI or Steinberg support.
 
OP
enCiphered

enCiphered

Active Member
Are you able to reproduce the behaviour with a simple script using the random() KSP command?
Unfortunately not, I don´t have a clue how to do that. Any help appreciated!
I´ve already contacted NI but they suggest to contact the developer of the library in the video, even though I told them that it affects ANY library from any developer with randomizing function.

By the way, after extensive testing I found out that I have the same problem with the stand alone version of kontakt, so it´s not only a vst plugin issue.
 

soniccouture

Active Member
He has contacted us. We've looked at this many times, and can't reproduce it... standalone or in Cubase. No other users have reported such strange behaviour. No idea what's happening on his system.

I can provide a short script to test any Kontakt instrument is handling random correctly. This should message a random between 0 and 100 each time you press the button.

cheers
Dan
Soniccouture

Code:
on init
declare ui_switch $Test
end on

on ui_control ($Test)
message(random(0,100))
end on
 
Top Bottom