What's new

Komplete Kontrol -- won't load Kontakt.

Headlands

Active Member
Komplete won't load Kontakt or libraries that it shows -- says "Could not load Plug-in". I did what's outlined here to try to fix the problem (deleting that file in the Mac Library, and re-scanning in Kpmplete Control) -- no dice, same issue.

I can use the preview on my SS8 Mk 2 and hear the preview sound, but when I try to load the sound/patch up, on-screen it says "Could not load Plug-in".

What does one need to do in order to actually use Kontakt in KK? Everything works fine in Komplete, Reaktor, etc., in Cubase (i.e. all the libraries load up perfectly, and the NI instruments themselves load up perfectly as well).
 
Last edited:

C-Wave

Senior Member
Komplete won't load Kontakt or libraries that it shows -- says "Could not load Plug-in". I did what's outlined here to try to fix the problem (deleting that file in the Mac Library, and re-scanning in Kpmplete Control) -- no dice, same issue.

I can use the preview on my SS8 Mk 2 and hear the preview sound, but when I try to load the sound/patch up, on-screen it says "Could not load Plug-in".

What does one need to do in order to actually use Kontakt in KK? Everything works fine in Komplete, Reaktor, etc., in Cubase (i.e. all the libraries load up perfectly, and the NI instruments themselves load up perfectly as well).
do you have more than one instance of kontakt installed.. like 5.x and 6?
 
Last edited:
OP
H

Headlands

Active Member
Thanks guys. @EvilDragon, I tried that and still have the same issue with Kontakt in KK.

@C-Wave, I only have one instance.

NI support hasn't gotten back to me yet -- any other suggestions?
 

j_kranz

Active Member
Have you moved the Kontakt VST out of it's original location? Also, is the VST the latest version (5.8.1 if you are on K5 still)?
 

Dan Burton

New Member
I'm also having the same issue with the previews working for some Kontakt libraries but when loading I also will get the "Could not load Plug-in" error message. I read earlier in this thread @C-Wave mentioned having multiple instances of Kontakt. I still have my 5.6.6 installed and I installed 6.03 along with it. If I uninstall 5.6 and just leave my 6 should this fix the problem? My older Kontakt libraries that ran in 5 open with KK but my new libraries for 6 are the ones I'm having issues with.

Also is the default location for the vst the PF/NI/VST 64 folder? I saw mentioned if the location were changed it could cause problems too. The vst file name is just Kontakt.dll whereas my version 5 is called Kontakt 5.dll. Just trying to cover all grounds to fix my KK issue. Thank you for the help!
 

C-Wave

Senior Member
I'm also having the same issue with the previews working for some Kontakt libraries but when loading I also will get the "Could not load Plug-in" error message. I read earlier in this thread @C-Wave mentioned having multiple instances of Kontakt. I still have my 5.6.6 installed and I installed 6.03 along with it. If I uninstall 5.6 and just leave my 6 should this fix the problem? My older Kontakt libraries that ran in 5 open with KK but my new libraries for 6 are the ones I'm having issues with.

Also is the default location for the vst the PF/NI/VST 64 folder? I saw mentioned if the location were changed it could cause problems too. The vst file name is just Kontakt.dll whereas my version 5 is called Kontakt 5.dll. Just trying to cover all grounds to fix my KK issue. Thank you for the help!
I saw my name there so here is what I remember I did:
1. Don't uninstall Kontakt 5. Simply remove kontakt5.dll from the VSTPlugins folder (64-bit and 32-bit) or wherever you put the Kontakt5.dll file, and put it (them) in a safe place, just in case. Keep Kontakt.dll
2. Check this option in the Komplete Kontrol Preferences tab (attached).
 

Attachments

Hi!
Which DAW did you use?
I have perhaps the solution of your problem. I think you did the last update of Komplete Kontrol. This update has replace the old DLL of the plugin by a new. So if you use a different path for your plug ins, think to replace your "old" dll by the new dll of komplete kontrol (vst or au). Maybe it will solve this.o_O
I think your problem comes with Komplete Kontrol not Kontakt.
 

Dan Burton

New Member
So I believe I've got it all working. There was an issue with the install in Native Access apparently. My Kontakt 6 was working fine standalone and in Ableton but wasn't with KK. After re-installing now everything is working fine without any errors. I've still got 5.6.6 installed too which isn't causing any issues. Thanks for the help everyone. Now I'm going to probably start buying some pre-made NKS Libraries for those that don't come up in KK. Also I've got to figure out why some of my custom .nicnt libraries in Kontakt keep disappearing upon restarting after I loaded them.
 
Top Bottom