KKontrol 49mk II (sustain) pedal activation

j_kranz

Active Member
Try turning off/on the keyboard with the pedal plugged in... it should do a polarity/connection check upon startup so maybe that will jog it. If still no dice, contact NI... could be a bad unit.
 
Try turning off/on the keyboard with the pedal plugged in... it should do a polarity/connection check upon startup so maybe that will jog it. If still no dice, contact NI... could be a bad unit.
What you suggest is indeed the instruction....I tried it several times on both ports as well.

NI support it shall be
 

j_kranz

Active Member
Of course make sure all updates have been installed as well... but yeah sounds like it could be a bad connection.
 

HeliaVox

Active Member
On the MKII you can control the polarity within Komplete Kontrol software itself. Fiddle around with the settings. On the MKI, you have to use the Controller Editor to do the same.
Be aware, though, that I have 4 different type foot controllers hanging around the studio and I could only get 1 of them working with my S88MKI. It is the compact "square" kind.
I attached a picture so you can see what I'm talking about.
Yamaha is not the brand I have. I got some Italian generic foot pedal from Guitar Center 20 years ago for 10 bucks.
 

Attachments

the end result was not something I would have had the patience to find out, but NI support did help to find the correct settings.

I am very happy with the MKII 49 but the pedal thing was a bit cumbersome. Other manufactures seem to have constructed that more conveniently.