Importing an uncompressed audio file into Vegas Pro

AoA

New Member
Hi,

I recently composed a song and rendered it to a .wav-file. Once I open this file I hear maximum volume, but if I import this file into Vegas Pro or Audacity I'm forced to lower the volume in order to avoid clipping. Why is that? Isn't it possible to just keep the quality as though I'd just open it?

Sorry for being a beginner, I'm looking forward to your answers. :)
 

pderbidge

Senior Member
Vegas will show an audio file hitting the red zone before 0db but it doesn't mean it's clipping. Look at the actual numbers. Is your audio actual hitting above 0db? If not, then you're fine.
Also, one thing I don't like about Vegas is that by default it adds an eq and compressor to the audio track. I always delete these effects if they aren't needed.
 
OP
AoA

AoA

New Member
Vegas will show an audio file hitting the red zone before 0db but it doesn't mean it's clipping. Look at the actual numbers. Is your audio actual hitting above 0db? If not, then you're fine.
Also, one thing I don't like about Vegas is that by default it adds an eq and compressor to the audio track. I always delete these effects if they aren't needed.
The audio hits above 0db and starts to clip. I need to lower the volume, thereby making it significantly quieter than the original wav in order to attain the previous quality.
How can I deactivate the EQ und compressor?
 

pderbidge

Senior Member
The audio hits above 0db and starts to clip. I need to lower the volume, thereby making it significantly quieter than the original wav in order to attain the previous quality.
How can I deactivate the EQ und compressor?
It's in the fx chain. Sorry, I'm traveling all week away from my studio but there should be some tutorials on YouTube about how to access the effects. I'm hoping that once you disable the effects that should help. Technically, as long as you're hitting the same db in Vegas as what you mastered at then the Volume levels should be identical.
 

pderbidge

Senior Member
Hi,

I recently composed a song and rendered it to a .wav-file. Once I open this file I hear maximum volume, but if I import this file into Vegas Pro or Audacity I'm forced to lower the volume in order to avoid clipping. Why is that? Isn't it possible to just keep the quality as though I'd just open it?

Sorry for being a beginner, I'm looking forward to your answers. :)
Hey AoA, I just got back from traveling so perhaps I can be of more help now. Let me ask a couple of questions and please don't be offended if they are basic questions that seem obvious but I find it's good to start with the basics.

Here we go:
1. What DAW did you compose your song in?
2. What is your audio interface?
3. Are you using ASIO drivers in your DAW?
4. Before you rendered your final mix were you hitting below 0db on the Master?
5. What Audio device and drivers are you using when mixing in Vegas or Audacity?

I think that should do it.
Also, here is a quick video on adding FX as well as FX chains that should answer your question about how to delete them as well.

 
OP
AoA

AoA

New Member
Hey AoA, I just got back from traveling so perhaps I can be of more help now. Let me ask a couple of questions and please don't be offended if they are basic questions that seem obvious but I find it's good to start with the basics.

Here we go:
1. What DAW did you compose your song in?
2. What is your audio interface?
3. Are you using ASIO drivers in your DAW?
4. Before you rendered your final mix were you hitting below 0db on the Master?
5. What Audio device and drivers are you using when mixing in Vegas or Audacity?

I think that should do it.
Also, here is a quick video on adding FX as well as FX chains that should answer your question about how to delete them as well.

No, I don't feel offended because I'm a beginner.
1. I composed my song in FL Studio 12
2. I use the onboard sound of my Z97 Gaming 7 mainboard
3. Yeah, it's called FL Studio ASIO
4. It's partly higher than 0db. That may be the problem. But there's no distortion whatsoever after having the song rendered to wav. Is there no possibility to keep this quality?
5. I use an audio device while mixing?
 

John Judd

Member
Make sure in FL Studio that you are rendering to 16bit/44.1 or 48 WAV.

Silly question, but: You do have a limiter on your master bus in FL Studio, correct?

Lastly, if you are using Ozone or FF make sure to have the True Peak (intersample detection) ON. This should prevent anything from clipping. I don’t have Vegas, but I do use Movie Studio Platinum (the baby version of Vegas). I’ve had tracks that didn’t peak above OdB give clipping warnings in Movie Studio Platinum

EDIT: and yes, kill any native effects sitting in the signal chain inside of Vegas.
 
Last edited:
OP
AoA

AoA

New Member
Make sure in FL Studio that you are rendering to 16bit/44.1 or 48 WAV.

Silly question, but: You do have a limiter on your master bus in FL Studio, correct?

Lastly, if you are using Ozone or FF make sure to have the True Peak (intersample detection) ON. This should prevent anything from clipping. I don’t have Vegas, but I do use Movie Studio Platinum (the baby version of Vegas). I’ve had tracks that didn’t peak above OdB give clipping warnings in Movie Studio Platinum

EDIT: and yes, kill any native effects sitting in the signal chain inside of Vegas.
Interestingly, if I render it to 16bit, the wav has the same clipping as if I would import the 32bit wave into Vegas Pro. I do have a limiter :D. I don't use Ozone or FF.
 

John Judd

Member
If your limiter is the FL Limiter or Maximus, it won’t save you from intersample peaking....which could cause the Vegas meters to clip. If it’s another limiter, I can’t speak to that.

Make sure your limiter in FL is at least set to -0.2dB. I wouldn’t let it go to 0.0.

You could bring ExpressFX Dynamics into the Vegas session, set it to infinity:1 ratio, set the threshold to -.1dB with a fast attack. That might save you, although it would be altering the original audio in a potentially bad way.
 
Last edited:
Hi,

I'd rather use the ASIO4ALL driver than the FL Studio ASIO. FL Studio ASIO applies a hard clip to the real time playback so it won't distort but when you render, it will. You can deactivate that hard clip though in the audio settings. This is a quote from the FL's manual:

Hard-clip output at 0dB (otherwise limiting will be applied) - When selected the audio will distort when it goes over 0 dB. When deselected a limiter will be applied to prevent distortion. NOTE: With limiting applied you can no longer hear clipping distortion from FL Studio's main output. This means you will need to pay attention to your peak meters (make sure the Master does not go over 0 dB), otherwise your rendered tracks will sound distorted even tho your live audio doesn't. Traps for young players! All this happens external to FL Studio, so the switch has no effect on the internal processing, it's all post-FL Studio audio handling.
Regards,
Peter
 

pderbidge

Senior Member
I always try to mix where my peaks are only hitting between -6 and -3 db. I then render that file to wav 24 bit and I import that stereo file back into my DAW as a new session and focus on Mastering the file aiming for no higher than -1db. I rarely use a limiter during the mix and only during mastering. This is not a hard and fast rule but a good one to follow for a beginner. There are many tricks to getting your song to sound commercially loud without pushing the Volume or using a limiter everytime. I highly recommend watching all the free mix with master courses you can on YouTube. I could also link you to a few others as well. Most of these guys have paid programs to sign up for but you can still learn quite a bit just from their free content.

If the soundcard being used in Vegas is different than the one you're using in FL studio then your volume is going to sound different but that is an illusion. What you need to pay attention to are the meters and not your ears in this case. If you are hitting above zero and your system sounds fine then perhaps some people with your exact setup may not hear any clipping either but people with a different set up will. This is why mastering to -1db is the wisest approach.

About meters: Different meters can mean different things when you see it hitting zero. I would recommend using the same meter in Fl studio and in Vegas on your master. Try downloading the Free Youlean loudness meter and use that to gauge loudness in both programs. At the very least learn what different types of meters are out there and how they work.