What's new

Huge MIDI Input delay when adding plug-in in Logic

mikefrommontreal

Active Member
Hi, I was wondering if anyone had any suggestions for me.

I recently purchased the WAVES Abbey Road TG Mastering plug in, which sounds great (especially for $29), but when I add it to the Stereo Out in Logic, I get a massive delay when trying to record MIDI data via my keyboard.
Now I know, I know. It's a mastering plug in. Why do I even have it on while I'm entering MIDI note data anyway. I guess it's just part of my workflow to sometimes have it on while I'm entering certain passages.

Anyway, what contributes to this delay, and what can I do to solve it? Would adding more RAM address this issue, or does one have nothing to do with the other?

Thanks,
 

kmaster

Now in LA: let's get coffee!
It’s a mastering plugin, so it’s going to have a good bit of look-ahead to do what it needs to do. This look-ahead is latency. If you mouse over the plugin instance you will see how much latency it is adding.

Only way to really deal with it is to not use it the way you’re using it and reserve its use for the mixing stage. Even bypassing the plugin but keeping it instantiated won’t do anything - otherwise how could you automate it on and off and have your audio keep sync?

Sorry!
 

jonnybutter

Active Member
That's easy!

Just assign a key command to enable/disable low latency monitoring. You can also right click into the tool bar and enable the icon. That way you can enable low latency monitoring, play your midi performance and disable low latency monitoring afterwards.

https://support.apple.com/en-us/HT207527

RTFM ;)
+1! Without the low latency feature and its key command, I would never get anything done in Logic. I use it so much that the ink (or whatever it is) on the key is worn off.

Either that or don't put anything good on your 2 bus :notworthy:
 

jonnybutter

Active Member
Yes. I don't know how they could do that, but it would be great if they could fix that large drawback. I scribble down the extant volume value (if I'm nearing the end of a mix) and then use my Behringer X Touch fader. It's a pain, but kind of automatic too.
 
OP
mikefrommontreal

mikefrommontreal

Active Member
It’s a mastering plugin, so it’s going to have a good bit of look-ahead to do what it needs to do. This look-ahead is latency. If you mouse over the plugin instance you will see how much latency it is adding.

Only way to really deal with it is to not use it the way you’re using it and reserve its use for the mixing stage. Even bypassing the plugin but keeping it instantiated won’t do anything - otherwise how could you automate it on and off and have your audio keep sync?

Sorry!
Ah, that makes sense. I guess I just didn't make the connection because my other previous mastering plugin (Izotope something or other) didn't create that delay. Thank you.
 
OP
mikefrommontreal

mikefrommontreal

Active Member
That's easy!

Just assign a key command to enable/disable low latency monitoring. You can also right click into the tool bar and enable the icon. That way you can enable low latency monitoring, play your midi performance and disable low latency monitoring afterwards.

https://support.apple.com/en-us/HT207527

RTFM ;)
Haha, fair enough. I didn't think to look it up because I wasn't exactly sure what I was looking for.

Incidentally in looking for a solution I had stumbled upon the Low Latency button, but then it made my reverb bus's orange which required me to add low latency protection to my sends on each track, which is not ideal workflow wise, which is what prompted me to write here.
 
Top Bottom