What's new

Horrible kontakt5 problems -- instrument banks, loading

wpc982

Active Member
Just learned three horrible things about Kontakt 5.5: (EDIT: work-around posted below in comments for the first two)

that K5.5 ignores midi CCs sent to instruments in an instrument bank
that K5.5 ignores pitchbend sent to instruments in an instrument bank
that anything saved in K5.5 can not be loaded by 5.4 or earlier.

What can you do to get around this? I dread going back to the hundreds-of-tracks sequencer days where you had to move tiny chunks of musical material to a different track for a different articulation.
 
Last edited:

EvilDragon

KSP Wizard
that anything saved in K5.5 can not be loaded by 5.4 or earlier.

This is not new at all. Kontakt was never forwards compatible.


In any case, are you saying that ALL your instrument banks were resaved/created in K5.5? Because if not, you can revert back to 5.4.3 and load them in there.
 
OP
W

wpc982

Active Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #3
My lack of information: I had thought that was based on major release only, version 4 to version 5 for instance. Causes quite a bit of heartache when you discover a bug in the latest sub-version and can't roll back and use your latest weeks' worth of work.
 
OP
W

wpc982

Active Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #4
It's number 1 & 2 that have me writing in fora rather than music, can't decide how to proceed ... having invested a great deal of time in making instrument s and banks to suit ... two options so far, I guess, roll back and make the instruments and the instruments and banks all over again, or put all the work done on a shelf for later and go back to no-bank work.
 

EvilDragon

KSP Wizard
Uninstall Kontakt 5, reinstall it from the disk, then apply 5.4.3 update. Not 5.5 or 5.5.1.

Your DAW projects might stop working, but I assume since you mention instrument banks, you're using them in a live setup, rather than a DAW project?
 
OP
W

wpc982

Active Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #6
Thanks for the idea: I did exactly that, then found out to my displeasure that all the instruments I had carefully set up to work with the banks (very minor changes, but saved in K5.5) would no longer load at all. I'll probably permanently roll back to 5.4, do all the work all over again; but am waiting to hear from Kontakt support some clue about whether the CC/pitch bend bug is likely to be fixed any time very soon.

All my work is done in midi sequences, nothing played live at all; I tend to work on projects for weeks and months at a time, so getting the appropriate set up for all the instruments (articulations) needed is a big piece of preparation.
 

EvilDragon

KSP Wizard
OK, I have a workaround for you. This seems to be happening only to .NKB files, for some reason. If you load your bank/s in a Kontakt instance, then save them as a multi (.NKM), they will work just fine after you reload the multi! Try it!

It's still a bug, granted, and I've reported it to NI's bug tracker last week (it was reported on NI forums first).
 

Tonberry

New Member
ED's avatar is misleading, leaving an impression that he wants to eat your corpse rather than be of any assistance when in reality he's the most helpful guy around :)
 
OP
W

wpc982

Active Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #12
Update on this little problem: if you alter anything in a bank (like modifying one of the programs in it) EVEN if it is in a multi and EVEN if you save the multi .... the behaviour goes back to bad: Kontakt ignores pitch wheel and midi controllers for all instruments in the bank. You must not only save, but actually reload the whole multi to get things working again. Heads up!
 
Top Bottom