What's new

Help with my new Cubase 10+VEPro template

MrLinssi

A glorified bedroom musician.
So I've been designing my new template and I've run into a wall-that wall being VEPro getting incredible sluggish in Cubase to the point of being unusable. Since I only have one machine (i7-6850k with 64GB of RAM) my initial plan was to throw all of HWO inside VEPro to save loading times every time I switch projects. The problem is, now that I've done that VEPro gets incredible sluggish once I connect the instances (I have 4) inside Cubase. Am I doing something wrong or isn't my PC just powerful enough? My CPU usage is around 40% and I still got plenty of RAM left...I remember reading that having lots of audio outs in VEPro increases GUI lag, so I limited those to 100 outs (for the percussion) but it didn't really help.
 

GuitarG

Active Member
Not sure why that could be.
I was reading the manual just yesterday and realized they suggest switching off asio guard for your Vienna ensemble pro plugins in Cubase (in the plugin manager)
Maybe worth a try?
 
Last edited:
OP
MrLinssi

MrLinssi

A glorified bedroom musician.
Not sure why that could be.
I was reading the manual just yesterday and realized they suggest switching off asio guard for you Vienna ensemble pro plugins in Cubase (in the plugin manager)
Maybe worth a try?
Yes! That seems to be the culprit. Why do I remember that they fixed it? It's still laggy, but very much usable, thank you. My other goal was to try to minimize the saving times with larger disabled templates by hosting most of it inside VEPro. That isn't obviously happening, but could I achieve a similar effect with disabled tracks inside VEPro?
 

Guy Rowland

Senior Member
For fabulous save time improvements, work decoupled.

FWIW, on my rig ASIOguard is fine set to Low, but it gets bad on Medium or High. The general feeling is that this will never be fixed, with both VSL and Steinberg viewing the problem as the other company's. Set to low though, its general performance is pretty much the same as Low was back in the days before AG, so nothing really lost imo.
 

shomynik

Active Member
Definitely try changing AG settings. I get long interrupts on mid but find the low settings bearable and of course beneficial for asio load.

But yesterday I indeed encountered for the first time a very odd VEP behavior on one of my slaves which could be described as sluggish - long hangs, process-times, pauses... And I noticed some discrepancies in RAM usage reports - total RAM used was 70%, but VEP usage was around 56GB which is less than half of my total of 128GB. Turns out that VEP RAM usage was wrong (too low), there was some corruption happening, and simple reset set the things straight.

My point is, maybe you should check your RAM if it's working properly by using some memory diagnostics. If you haven't already, you should disable win defender or just disable scanning of the sample drives. Also, reinstalling your software might help.

Otherwise, that really should not be happening, your system is powerful enough. I'm having hundreds of audio channels streaming between vep and cubase (limit set to 300), and the only thing that is influencing is Cubase asio load. VEP is behaving great on all systems, master and 2 slaves regardless of the number of audio streams.
 

shomynik

Active Member
Yes! That seems to be the culprit. Why do I remember that they fixed it? It's still laggy, but very much usable, thank you. My other goal was to try to minimize the saving times with larger disabled templates by hosting most of it inside VEPro. That isn't obviously happening, but could I achieve a similar effect with disabled tracks inside VEPro?
Oh... great to hear that it was simple as that! :thumbsup:

I'm really hoping for the VEP 7 to wortk better with AG.

Regarding the disabled tracks, I'm suspecting that such a hi track count template/project would be hell in terms of saving times. I'm barely tolerating my 5-8sec saving time in decoupled mode every 20mins.
 
Last edited:
OP
MrLinssi

MrLinssi

A glorified bedroom musician.
Oh... great to hear that it was simple as that! :thumbsup:
...It wasn't actually...I'm an idiot and forgot to connect the perc instance. And as soon as I did it was a total lag festival. Dunno, something feels a bit off with this. Definitely trying to reinstall and play around with ASIO Guard. I've already excluded my sample drives from Defender.
 

GuitarG

Active Member
Just to make it clear, you can set the audio guard to off, low/mid/high in the vst preferences but you can also turn it off on a plugin-by-plugin basis in the plugin manager in the lower info pane.
Was chatting to somebody at Vienna two days ago and he confirmed that with C10 they still recommend switching it off for Vienna Ensemble Pro Plugins.
Suppose every system is different and what works for me might not be the same for you.
Also chatting with somebody at Steinberg last week as I had some performance problems with my template in C10 which is a C9 template imported into C10.
He said C10 got some changes to the internal structure so I don’t know if you’re using anything to do with C9 in C10 (templates/preferences/etc) but that might also cause a problem.
 

shomynik

Active Member
...It wasn't actually...I'm an idiot and forgot to connect the perc instance. And as soon as I did it was a total lag festival. Dunno, something feels a bit off with this. Definitely trying to reinstall and play around with ASIO Guard. I've already excluded my sample drives from Defender.
And until you connect it, VEP is working properly on it's own?

Could you explain lag behaviour moire in detail?
 
OP
MrLinssi

MrLinssi

A glorified bedroom musician.
@GuitarG Yeah, I did that. And I actually started working on the template when I was still on 9 and then imported into 10...maybe I should start a fresh template in 10?

@shomynik On it's own VEPro is just fine and dandy. When connected (especially when connecting the fourth instance) the whole thing is very unresponsive, if I select a track inside VEPro it takes +10 seconds, or even more. It might now even raise the instance.

Anyways, thanks for the help so far guys, I'll try again in a few hours with your suggestions in mind. Will report back!
 

GuitarG

Active Member
@GuitarG Yeah, I did that. And I actually started working on the template when I was still on 9 and then imported into 10...maybe I should start a fresh template in 10?

@shomynik On it's own VEPro is just fine and dandy. When connected (especially when connecting the fourth instance) the whole thing is very unresponsive, if I select a track inside VEPro it takes +10 seconds, or even more. It might now even raise the instance.

Anyways, thanks for the help so far guys, I'll try again in a few hours with your suggestions in mind. Will report back!
Just for your info, I didn’t want to redo my 1100-track C9 template so I tried importing it in C10, delete all plugins, load the plugins again, saved it as a template within C10 and now it seems much more stable. Initially also copied my C9 preferences to C10 folder but they told me that’s also not a good idea.
Good luck!
 

shomynik

Active Member
@GuitarG Yeah, I did that. And I actually started working on the template when I was still on 9 and then imported into 10...maybe I should start a fresh template in 10?

@shomynik On it's own VEPro is just fine and dandy. When connected (especially when connecting the fourth instance) the whole thing is very unresponsive, if I select a track inside VEPro it takes +10 seconds, or even more. It might now even raise the instance.

Anyways, thanks for the help so far guys, I'll try again in a few hours with your suggestions in mind. Will report back!
Yeah, that is exactly a behavior I was experiencing yesterday but along with the Cubase being unresponsive at the same time with VEP looked like being the culprit.

I would try loading the same samples in Cubase only (load Kontakt multis). In my case a reset took care of it, but it seems you gonna have to do more troubleshooting.

Btw, I'm using a C9.5 template in C10, and I'm getting the same performance now.
 

InLight-Tone

Senior Member
Get rid of VEP in lieu of a disabled track template and save yourself boatloads of stress and unnecessary confusion...
 
OP
MrLinssi

MrLinssi

A glorified bedroom musician.
Get rid of VEP in lieu of a disabled track template and save yourself boatloads of stress and unnecessary confusion...
Not an option if I can help it. I've used a disabled template for years and in the end the painfully long save times and loading up HWO every time I switched a project are the reasons why I'm now setting up VEPro template.
 

jneebz

Senior Member
Get rid of VEP in lieu of a disabled track template and save yourself boatloads of stress and unnecessary confusion...
...IF you have an SSD system drive to cover those save times...;)

I think I’m headed toward losing VEP myself...did my last couple projects without it and it was actually really smooth. Only 200-250 tracks though.
 

InLight-Tone

Senior Member
...IF you have an SSD system drive to cover those save times...;)

I think I’m headed toward losing VEP myself...did my last couple projects without it and it was actually really smooth. Only 200-250 tracks though.
I'm using an m2 drive for project saving and with no tracks enabled + 12 sends and 1300+ tracks my save times are around 3 seconds. I first just start sketching with a few instruments to get the meat of the track down. Later I do the layering and orchestrating, most of my cues come in around 30-40 tracks. Save times near the end are around 10 seconds, but I can live with that for the simplicity of the whole rig...YMMV.
 

Guy Rowland

Senior Member
Get rid of VEP in lieu of a disabled track template and save yourself boatloads of stress and unnecessary confusion...
Wow - for Cubase users, I'd strongly advise the opposite. Cubase Disabled Tracks have been a nightmare with bugs. Also performance is about 50% worse than VE Pro. I think Reaper users have a it much better though.
 
OP
MrLinssi

MrLinssi

A glorified bedroom musician.
Ok...did some more testing. If I lower the thread count from 3 to 2, or even better, to 1, the interface is really smooth. The problem is, for some reason one of my CPU cores has a total fit and the usage is slammed to 100%=My instance with Hollywood Brass crackles like there's no tomorrow. If I increase the thread count, then the CPU usage gets a bit lower, but the interface becomes totally unresponsive. Damn.
 
OP
MrLinssi

MrLinssi

A glorified bedroom musician.
Worth updating Play perhaps?
I did when 6.0.9 came out...except it didn't update the plugin version (don't ask me why, I have no idea). It turns out that almost every articulation had a convolution reverb on despite me saving a multi WITHOUT any reverb (that annoying bug). So I think those numerous reverbs were a part of the problem. One of my cores is STILL doing much more work compared to the others, but the GUI in VEPro is stable and there is no crackling, so I got that going for me at least.
 
Top Bottom