What's new

Help: Trouble adding external instrument/synth in LPX

Mike Marino

Senior Member
Hey all,

Trying to get my Moog Sub Phatty to work within Logic (10.4.8; 10.14.6 Mojave). Here are the steps I've taken thus far:

(Pic 1)
* Create external MIDI track, assigning its audio input to Input 7 (which is the input in my interface where the audio from the Moog is plugged in).
* MIDI Destination is listed as Teensy MIDI - 1 (I'll come back to this in a second....because there used to be another option).
* Audio output set as Output 1+2 (stereo out)

(Pic 2)
I then create the corresponding audio track:
* Create audio track -> audio input 7 (like above, this is the channel the Moog is plugged into in the interface), output 1+2 (stereo out)
* I've checked the box "I want to hear my instrument as I play and record"

In the Main Window, with the MIDI track selected, when I press record and play the synth I hear the notes being played and the MIDI is captured. However, when I play the MIDI back there is no audio being sent to the audio track.

Where have I gone wrong???

I pulled up an old project file where I used the external synth. And it still worked. When I opened the External Instrument info box it read: MIDI Destination: MISSING: Moog Sub Phatty (Pic 3)

I tried saving the MIDI instrument track and its corresponding audio track as a preset in the Logic library. I opened a new session, loaded up those presets....and I'm faced with the same problem as above.

I tried moving the MIDI config files (both the hidden and non-hidden) and that didn't seem to do anything. I've updated the firmware on the synth; no differing result.

What gives? I fear I've missed something completely obvious!

Thanks,
Mike
 

Attachments

  • Pic 1.jpg
    Pic 1.jpg
    64.2 KB · Views: 6
  • Pic 2.jpg
    Pic 2.jpg
    86.8 KB · Views: 6
  • Pic 3.jpg
    Pic 3.jpg
    16.2 KB · Views: 7
OP
Mike Marino

Mike Marino

Senior Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #2
Here's the list of what I've done thus far tonight:

* Reset all factory settings of the synth
* Reinstall of last firmware update for the synth
* Reinstall of latest firmware update for the synth
* Redefined the following MIDI parameters in the synth:
- MIDI in/out (CH. 1 on both)
- MIDI Input/Output Select (USB only on both)
- MIDI Merge USB (ON)
- MIDI Merge DIN (OFF)
- MIDI CC Resolution (Standard)
- Local Control (ON)
- MIDI Output Filter (keyboard, modwheel, pitch bend)

I then, in Logic, created an External Instrument track assigning:
- Audio Input (Input 7); this is the input the 1/4" instrument cable is plugged into, from the synth to the interface.
- Teensy MIDI - Ch. 1
*This is where I THINK the problem is. I think there's supposed to be a MIDI Destination option that says Moog Sub Phatty....as it used to a year and a half ago...but it's no longer even showing up as an option. The synth DOES show up properly in the Audio MIDI Setup and does appear to be sending signal out of CH. 1 according to MIDI Monitor app. So the fact that Logic's NOT seeing this the same way that the Audio MIDI Setup sees it is a bit strange, no? There are pictures in earlier post of all of this as well.
- Audio Output: Output 1+2 (stereo out)

After all of that I'm left in the same place:
* I can hear the synth inside of Logic; the level meter is moving on my external instrument track.
* I can record the MIDI performance with all of the proper CC information.
* Upon playback of that same MIDI performance there is no audio playing back; level meter is not moving anywhere.

If I make a corresponding Audio Track (assigning it the same Audio Input (Input 7) and Audio Output (Output 1+2 stereo out) I'm left in a similar situation:
* I can hear the synth in Logic; the level meter is moving in the audio track.
* I can record the audio performance of the synth.
* Playback of the audio recorded performance happens correctly....but I'm locked out of the MIDI side of things.

I have also tried:
* Using different inputs on the interface
* Connecting the USB to other ports on the computer and USB hub
* Swapping out USB-to-MIDI cables

I'm stumped!!!
 

Ashermusic

Senior Member
Very odd, Mike. The only hardware keyboard I have attached is my Vivo S7 and it shows up and plays as expect with the External Instrument, no addition audio track necessary.
 
Top Bottom