Help needed on template causing overload

Garry

Senior Member
Would greatly appreciate help with this:

My machine is an iMac (Retina 5k, 27", 2017); 4.2GHz, i7, 32Gb. Despite being a a fairly new and high spec machine, I'm struggling to run a template of <100 tracks.

I set up my template in Logic as follows: 4 track stacks (strings, woods, brass, pianos). I have each of these 4 stacks saved as a user patch, which I add to the template one at a time. Each track is a single instance of Kontakt (no multis) or SWAM. After loading each user patch, I freeze each individual track, before loading the next patch.

By the time I get to adding the 4th user patch to the template, my computer slows to a crawl, such that it will barely register mouse movements, and my only option is to hard reset the machine. So I haven't even managed to save the template, let alone use it!

Is there anything I'm doing wrong here? I'm not running a slave/VEPro setup, but even with 1 computer, I would have thought I should be able to comfortably run <100 tracks, no?

Any tips on how to optimise?

Many thanks for any help.
 

gsilbers

Part of Pulsesetter-Sounds.com
Would greatly appreciate help with this:

My machine is an iMac (Retina 5k, 27", 2017); 4.2GHz, i7, 32Gb. Despite being a a fairly new and high spec machine, I'm struggling to run a template of <100 tracks.

I set up my template in Logic as follows: 4 track stacks (strings, woods, brass, pianos). I have each of these 4 stacks saved as a user patch, which I add to the template one at a time. Each track is a single instance of Kontakt (no multis) or SWAM. After loading each user patch, I freeze each individual track, before loading the next patch.

By the time I get to adding the 4th user patch to the template, my computer slows to a crawl, such that it will barely register mouse movements, and my only option is to hard reset the machine. So I haven't even managed to save the template, let alone use it!

Is there anything I'm doing wrong here? I'm not running a slave/VEPro setup, but even with 1 computer, I would have thought I should be able to comfortably run <100 tracks, no?

Any tips on how to optimise?

Many thanks for any help.

how much memory are the instruments taking? (in the activity monitor)
 
OP
Garry

Garry

Senior Member
Do you mean the activity monitor in Logic or on the Mac? I'll reply to both...

Just loaded the first patch (Strings: about 30 tracks) and second patch (brass: about 40 tracks). First patch raised about 20% on 1/8 cores in the audio meter; 2nd patch raised to about 40-50% on 1 core. On the Apple activity monitor, CPU% went up to a max of around 160% as the patches were loading, and then dropped back to around 5-20% thereafter.

I then tried to add the 3rd patch (pianos: <20 tracks), and it crashed. Apple activity monitor was around 120%, and 5/8 cores were maxed out on the Audio meter in Logic. Had to restart the machine. I'll try again now, but will post this first, as it'll probably crash, and then I lose this text.
 
OP
Garry

Garry

Senior Member
Loaded the 3rd patch, and Apple Activity monitor rose to max of around 80%. Initially, the Audio meter in Logic showed little activity, then a brief spike on 5/8 cores, which slowed the machine for a few seconds. Then 30 seconds later, all 8 cores spiked to 100% max, and I had to hard reboot.

I'm wondering if it's something about the Pianos patch - I'm going to try loading this first and then last...
 
OP
Garry

Garry

Senior Member
Nope it's not the Piano patch: loading this patch first, on it's own, caused the Apple activity monitor to reach a max of 125% CPU, and then quickly return to between 5-20%

My audio settings are as follows:

I/O buffer: 256
Processing threads: 8
Process buffer range: medium
Multithreading: Playback tracks
Summing: High precision (64 bit)
ReWire behaviour: off

Will now see if I can load the 4 patches again, and watch what happens to the monitors...
 
OP
Garry

Garry

Senior Member
Was able to load the 4 patches this time; CPU went to 194% on loading the 4th, but then quickly settled back down. I thought it had worked, as there was barely a flicker on the Audio meters in Logic, but then about 30 seconds after loading the 4th patch, there was a spike on 5/8 cores, and again, it crashed the machine.

So, I'm overloading the Audio meters (no activity at all on the I/O). What does this mean, and is there a way to prevent it. Are my settings correct? Are there other things I should be doing (eg purge each track - I don't know how to do this, or if it would help). Anything else?

Please Help!!
 
OP
Garry

Garry

Senior Member
!!!

Also tried setting multithreading to 'Playback and Live Tracks' and process buffer range to large... no effect. Still crashes!

Surely <100 tracks can't be all a $3000 machine can handle??!!
 

TheKRock

Member
I had similar issues with the same imac earlier this year after I just bought it - after a few days on with apple help (lots of back and forth) the tech had me set my prefs as such and have had zero issues since:
I/O buffer: 512
Processing threads: automatic
Processing buffer range: large
Multithreading: playback and live tracks
summing and rewire same as you have yours set
 
OP
Garry

Garry

Senior Member
Thanks for the suggestion. I tried setting processing threads to automatic and I/O buffer to 512 to replicate your setup, but still the same problem.

I'm wondering if it's my use of summed track stacks: that is, it's not so much the number of total tracks, but that I'm adding between 20-40 tracks all at once. I notice the problem about 20 seconds after I add the third stack (whatever stack that happens to be). It seems it's busy processing the tracks, and then I dump too many all at once and it overloads the system?

Do other people use tracks in their template in this way? I had thought it might be a good way to use them, as I could add in/drop out large numbers of tracks quickly, to keep the total at any one time down (since I'm not using a slave), but perhaps this was the wrong approach, and if I add them fewer at a time, it will help?
 

TheKRock

Member
I use multiple track stacks for each instrument for dif articulations and have no problems...let me check on other prefs and see what else I did to possible fix this issue
 

gsilbers

Part of Pulsesetter-Sounds.com
Thanks for the suggestion. I tried setting processing threads to automatic and I/O buffer to 512 to replicate your setup, but still the same problem.

I'm wondering if it's my use of summed track stacks: that is, it's not so much the number of total tracks, but that I'm adding between 20-40 tracks all at once. I notice the problem about 20 seconds after I add the third stack (whatever stack that happens to be). It seems it's busy processing the tracks, and then I dump too many all at once and it overloads the system?

Do other people use tracks in their template in this way? I had thought it might be a good way to use them, as I could add in/drop out large numbers of tracks quickly, to keep the total at any one time down (since I'm not using a slave), but perhaps this was the wrong approach, and if I add them fewer at a time, it will help?

its a recent computer so i couldnt tell.

you didnt mentioned the amount of ram memory in the activity monitor (utilities). sometimes getting to the limit (32gb) will cause issues. if its so, maybe try select in konakt "update sample pool". that way you dont load all the instrument in ram.

have you tried off loading the sample libraries into VEP in your same computer? that way all of the your sample instruments are all in logic.
 
OP
Garry

Garry

Senior Member
FIXED!! :) Thank you both for your very helpful suggestions.

I think the suggestion regarding purging the samples was key. Whilst I couldn't use the 'update sample pool', since I don't have any midi notes written on any of the tracks yet, as this is just a template (that's how I understand this to work: you play in your midi notes, and then updating the sample pool drops unused samples - hope that's right?), however, I did go through each track and hit 'purge all samples' (that was very laborious before I realised there's a global purge!). As you recommended, I watched the RAM: before purging, it was going up into >20Gb after loading just 2 of the patches (around 40 tracks), but after purging with all tracks loaded it's working fine, and is at 14Gb of RAM used.

In case it's helpful to others, I also found this website very useful, and used a few tricks from there such as CPU overload protection and clearing out the database (which I don't use anyway).

I'm a bit concerned that this was necessary with the specs of the machine I'm using - hope it doesn't indicate some hardware issue or something that will come back and bite me later... But for now, I have a fully working template. Yeah!

VI-Control forum does it again! I love this place! :)

Thank you, thank you, thank you!