What's new

FL Studio and Vienna Ensemble Pro: This is how you do it

kimarnesen

Senior Member
After one year of trying different ways to make this work, giving up and learning other daws, reading the same questions from the last 8 years by other people on forums about how to make VEP work with FL Studio, there is finally a solution!

It has probably been there all the time, but no one has had a solution, at least not online, even not their staff, until now, thanks to Paul at VSL and the FL Studio guys who have been in touch. So if you are like me, trying to figure this out, this post is for you.

Issue:
The problem was that the sound was either very distorted or FL totally unresponsive unless you changed the buffers to "none" inside the VEP wrapper window. But using 0 buffers won't work in the long run because of crazy CPU usage and how FL Studio handles latency.

Solution:
1. Open the Vienna Ensemble Pro (64Bit) plugin in FL Studio. (And of course, have the VEP Server opened on the computer or slave)

2. Set buffers to "none". VEP should now be ready to work but as you can see the CPU meter is at 9 already. If you don't do this first, FL Studio will most likely become unresponsive when doing the next step.

Skjermbilde 2019-02-14 kl. 20.37.09.png



3. Open the wrapper settings. Select the port for this specific instance (the same port number as you use for your VEP instance).
Skjermbilde 2019-02-14 kl. 20.25.04.png



4. Choose "Processing". If you want more than one output (the same output numbers as in your VEP instance) select them here. I just click "Auto map outputs" and all outputs are selected.

Skjermbilde 2019-02-14 kl. 20.27.41.png



5. Select "Use fixed size buffers" (click "yes" if you get a warning) AND select "Process maximum size buffers" in the More dropdown menu. This is the crucial part of the CPU issue.

Skjermbilde 2019-02-14 kl. 20.29.00.png




6. Go back and select "1 buffer" and you will now see that the CPU meter says 2, and there are no more distortion or freezing when you play. I use 1 buffer (low latency) but based on your resources you can choose 2-4. "None" will still use quite a lot of CPU but could work for smaller projects.

Skjermbilde 2019-02-14 kl. 20.34.54.png

You can save this as a preset so you only have to do this once. The only thing you need to change is the port number. So the next instance will be port number 2.

So with the next instance, the CPU meter will show 4, then 6, then 8 and so on. Much better than 9 per instance! And since you can only have 16 midi channels coming from one VEP instance with FL Studio, you will quickly need to have quite a few instances.
 
Last edited:
OP
kimarnesen

kimarnesen

Senior Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #2
And if you wonder what to do next, this is how you set up each instrument within that instance:

1. Add what's called a "Midi out" plugin (there are many ways of opening a plugin in FL Studio). You can click the + icon:

Skjermbilde 2019-02-14 kl. 21.02.50.png

2. Open up to 16 of those (depending on how many midi channels you want from that VEP instance) and in each one, select the port number and channel number. I've just renamed these to piano, guitar , and harp for the sake of this tutorial.

Skjermbilde 2019-02-14 kl. 21.01.36.png

3. If you did the step with "auto map outputs" correctly, each of these now has their own track in the mixer as well. (That is if you have set it up correctly in VEP and there are many tutorials for that and it's not unique for FL Studio).
 
OP
kimarnesen

kimarnesen

Senior Member
Thread starter
  • Thread Starter
  • Thread Starter
  • #3
How to use a midi-controller with VEP in FL Studio:

This was also impossible to find information on online, but by trying every possible knob I figured it out.

1. Add "midi outs" as mentioned above for each instrument. I've renamed them to Violin, Viola, and Cello for the sake of this tutorial. Make sure the midi and port channels corresponds with the midi channels in the VEP instance, as explained above.
Skjermbilde 2019-02-14 kl. 21.02.50.png



2. In the "midi out" plugin right click on one of the knobs and select "configure" or just click on that small gear icon next to it. In here, enter the name of the CC, then the CC number, and click "accept." Do this for as many CCs you want, like expression, vibrato, etc.
Skjermbilde 2019-02-14 kl. 22.10.13.png




3. The next you need to do is to link or learn to your midi control. Right click on the knobs again and choose "link to controller". Make sure "Omni" is selected and "Remove conflicts" are unselected before doing anything else. Now touch the fader you want to use for this CC. This window will now close by itself, and the fader is now controlling this. Repeat for every controller (dynamics, expression, vibrato, etc).
Skjermbilde 2019-02-14 kl. 21.58.45.png

You will see that these knobs are now also moving as you move your faders.


5. For the next instruments you need to repeat this, but since we chose "Omni" you don't have to do #4 again.

What caused so much trouble was that if you don't select "omni", the fader will be stuck to that specific instrument. So when I repeated all the steps above with "omni" unselected" for the Viola, the fader would now get stuck on the viola, and not work on the violin anymore! So it was really frustrating and this is the crucial part of making this work.
 

bfreepro

Infinite Musical Possibilites
Do you have any issues when exporting an FL Studio Project that includes instruments from VEP? I got it all set up properly (HUGE thanks for this tutorial here), but now my projects freeze when exporting.
 

x-dfo

Active Member
I set everything up, and it works great - until it comes time to export and a simple 3 track test has stuttering at the beginning and then it trips over itself randomly. What's strange is I've always had problems exporting on FL studio with the first beat often being delayed or wonky.
 

bfreepro

Infinite Musical Possibilites
I set everything up, and it works great - until it comes time to export and a simple 3 track test has stuttering at the beginning and then it trips over itself randomly. What's strange is I've always had problems exporting on FL studio with the first beat often being delayed or wonky.
I still haven’t been able to export a track using FL and VEP. It just exports digital glitchy noise or freezes.
 

x-dfo

Active Member
I still haven’t been able to export a track using FL and VEP. It just exports digital glitchy noise or freezes.
I had glitchy noise until I followed the guide above, everything is fine when I just hit play and let it roll but exporting is no bueno.
 

andrewg

New Member
When using VEP Audio Input plugin I get glitches and noise after rendering, even if "process max size buffers" is unticked. Any ideas to make it work?
 

x-dfo

Active Member
When using VEP Audio Input plugin I get glitches and noise after rendering, even if "process max size buffers" is unticked. Any ideas to make it work?
try playing with the number of buffers in the vep plugin settings, try reticking every buffer size option as well, sometimes that worked for me
 

andrewg

New Member
try playing with the number of buffers in the vep plugin settings, try reticking every buffer size option as well, sometimes that worked for me

Nothing... Could someone try to reproduce this annoying thing to understand if it works for someone? Steps to reproduce:
1. Create a new project. Add a sytrus track with some notes and route it to a mixer track 2 for instance.
2. Unlink the mixer track with sytrus from the master and route it to the mixer track 1.
3. Call a VEP plugin from the channel rack.
4. Turn on the "Use fixed size buffers" (without "process max size buffers" at this point) in the wrapper settings.
5. Connect that plugin to the server with a new VEP instance, give some name.
6. Go to the mixer insert 1 and call a VEP Audio Input plugin
7. Assign it to created VEP instance (It will connect to an audio input 1/2 by default)
8. Go to the VEP Audio Engine and create a new input (Ctrl+I)
9. Select Input 1/2 from drop-down inputs list
10. Now if you hit Play you'll hear audio dropouts obviously as the "Process max size buffers" is unticked but it needs to be unticked before rendering. So try to render the file and check if you'll get a clean result.
 
Last edited:
VEP and FL just don't work together at the moment, unfortunately. You can get them to 'work' like above, but your renders will be full of glitches, bad MIDI timing, etc.

No real fix for it because it's a mixture of how FL handles audio buffers differently from most DAWs, and how it handles MIDI messaging.
 

heryanmau

New Member
Some time ago, my action drum sounded click, distorted and glicth when it was at a tempo below 130 bpm. But I managed to fix it by activating 'Align Tick Lengths' in the audio settings.

May be useful

Align tick lengths.png
 
Thanks for the solution, but why FL? VEP is like a hardcore solution, like stuff for aficionados, and FL Studio is a bit too focused on EDM?

I get that some of us won't give up until we solve all hardware and software issues on our setups, but that indeed might be a case of switching DAWs. If you went to the point of having two computers and VEP setup... Some of FL stuff is available as standalone VSTs if you need those.
 

Geoff Moore

bleeps and bloops
Thanks for the solution, but why FL? VEP is like a hardcore solution, like stuff for aficionados, and FL Studio is a bit too focused on EDM?

Not to be contrary, but FL Studio is amazing for orchestral workflow IMO, very easy to map controls, automate everything, create instrument splits and do complex routing with 3rd party midi tools in the included Patcher for keysplits, velocity splits etc etc etc. Also Patcher, layers, project bones are incredible for avoiding one huge template and keeping things more flexible and modular. Such a fun, inspiring tool to work with for any musical genre once you learn it. It comes with some EDM-focused plugins but you don't need to use them. I've never tried to use it with VEP though.
 
Top Bottom