EXS24 Missing Samples (Still) - Third-party Instruments

tonewheel

New Member
Hi all.

The EXS24 is not finding most of the samples for most of my third-party instruments. These are sounds that I have incorporated into Logic over many years, such as the Useful Noise instruments, Piano Attack and Dark Skies etc. All of these are commercial libraries that included EXS24 patches.

I've successfully migrated several generations of Mac Pros and versions of Logic, but now with Logic Pro 10 (all versions), I find that many of these instrument presets have problems finding the actual samples. (Not all instruments, but most.)

Judging by the many search results I found, this has been an issue for some time, but it would pop up for slightly different reasons, depending on the OS and where EXS/Logic expected to find sample data.

I have tried all the possible solutions I could find here and elsewhere (e.g., re-indexing Spotlight, making sure to put user instruments in the ~/Music/Audio Music Apps/Sampler Instruments folder. I've put the aliases of the instruments and samples folders in there, I've put the original folders in there, I've put just the Instruments presets in there and left the samples in their original location on an external drive. No luck.

Apple's own documentation gives conflicting info about the file hierarchy for user samples...

If I let Spotlight fully re-index, some of the instruments will then find their samples, but not all of them. And often when I run into a patch that can't find its samples, all the subsequent patches I try to load have the same problem. It's as if Spotlight is being buggy (I'm assuming it's Spotlight related, since it is what the EXS uses to find/reference sample locations.)

My samples are currently stored on SSD drives connected via Blackmagic Multidock.

Anyone successfully migrate samples and/or successfully configure third-party instruments stored on an external drive? If I can't get this to work, EXS24 is essentially useless as a sampler for third-party/user sounds. I was really hoping to get back into using the EXS for custom sounds and move away from Kontakt...

Thanks for any help!

John Krogh
Mac Pro Late 2013
3.5 GHz 6-Core Intel Xeon E5
64 GB 1866 MHz DDR3
OS 10.12.4
 

FredW

Member
Have you tried Instrument Manager by Chicken Systems? I tried the free version some time ago when I had a similar problem and it seemed to fix those broken links to the samples.
 
OP
T

tonewheel

New Member
No, I haven't yet, but I'm downloading now.

Thanks for the suggestion. I used Translator years ago and had generally good luck.