What's new

Embertone Releases: Walker 1955 Steinway 'D'

gfd

New Member
Ran the instrument in Studio One. With one exception, which I'll mention shortly, Walker preformed quite well, with DFD set to 240 and 1/2 pedal set to ECO. The memory usage is 6.62GB. Unless I do what I noted below, the CPU usage is moderate, at about 5 to 10%.

Exception: if I sit on the sustain pedal and input notes without releasing, the CPU usage will slowly, but inexorably, increase. What I did was probably not going to happen in normal use. However, I do believe the library has an issue releasing samples when the sustain pedal is engaged.

I am in communication with Embertone about this. They have been quite helpful so far (I looked into DFD, based on their advice) amongst other things. I am going to run the library in Reaper to see if I get the same result. I'll let you guys know what happens.

If/when I get this sorted, I will advise Embertone and this forum. You guys have been great.

Thanks,
Graham
 

VladK

Active Member
Concert D supports silent key and damper resonance (depressing sustain pedal after the key is released generates sound to mimic felts that did not completely mute the string yet), but sympathetic resonance is not implemented (play a silent key, do not release it, and playing staccato afterwards causes the 'open' string to vibrate).
"Sustain-Damper Sympathetic Resonance" term is incorrect and misleading: damper resonance is different from sympathetic resonance.
Can somebody confirm this?
 
Last edited:

rojarvi

Dismembered member
Howdy,

Breathing some new life to this thread as I recently bought Walker D and finally yesterday had some more time to test it. Few weeks back in my initial very short tests I found things are OK if I just have a single or max two mic positions running simultaenously, got some clicks but nothing serious. Was very much concentrated on how it sounds and played few seconds here and there and adjusted settings... Really enjoyed the generic sound and having multiple microphone positions to mix seemed like a great option to get some different character out of the instrument. So, had my expectations very high and was certain this is in my Top 3 pianos when I get to use it more extensively. Just so great sounding instrument.

But... Yesterday I finally had time to play more with it and started playing longer classical pieces. Had Hammer + Room loaded up with 18 layers (in Cubase) and started to play a classical piece with normal sustain pedal operation, you know, press and release in about every bar. And oh the horror when after a minute of playing things went totally ballistic. CPU meter was screaming at full 100% and could not hear anything but a buzzing sound. When I stopped playing the buzzing stopped and CPU meter slowly dropped back to low levels.

Repeated the same few times and started to fiddle around with the settings to see if there's something I could do. Dropped layers to 12, made sure half-pedalling was at Eco mode, unloaded some sample options like Staccato I was not using etc. Still the same. Removed the Hammer mic and played with just one mic position - still the same. I noticed @gfd mentioned his test of "sitting on sustain pedal" making the CPU load build up until things go nuclear. In my test I would say that you don't even have to keep the sustan pedal pressed down for an extended period to get the same effect! I cannot even play a normal classical piece with a single mic position if I operate the sustain pedal in normal manner. CPU meter keeps creeping up and finally as it hits 100% it's game over.

In Kontakt you can find the setting of "CPU overload protection" where it starts to kill off voices when CPU load is high. Using that option things do improve but are still not perfect - and I'm not sure if this is the way a Kontakt instrument is supposed to work: building up CPU load to such levels that Kontakt decides to go into damage control mode and start chopping heads off.

Is this something others besides me and @gfd have experienced? Anyone else have this even if you periodically release the sustain pedal? Is there any workaround for it? I didn't read through all this 40+ page thread and even if I had done it there must be comments based on older versions, which may not be valid anymore. I would think the computer I'm using is supposed to handle a single piano instrument, it's Core i7-6950x, 10 cores, running at 4.0 GHz in turbo, 64GB RAM, samples on SSD, RME Fireface 800 interface with no problems with other instruments. I also disabled Cubase multi-processing as it is really a broken feature causing nothing but trouble in live playing.

Really frustrated as this is sound-wise a truly great instrument but if I cannot play a single piece with it without stopping every minute for things to cool down it's not much of use to me. :emoji_fearful:
 

SupremeFist

Senior Member
Have you tried raising the max voice count to 512 and/or increasing buffer? If that doesn't help there may be Windows-specific settings to look at. (No problems when playing one mic at 33 velocities with heavy pedalling on my old system which was a lowly dual i5 Mac.)
 

rojarvi

Dismembered member
Yeah, I tried with 2000 max voice count - no effect and Kontakt reports only like 100-200 voices running. It could be Windows-only thing but I've done pretty much all latency etc tunings available (C states, hyper-threading etc.). To me it seems like there is some kind of pedaling bug in Walker which keeps cumulating CPU load over time.

Good point about Mac - I also have a i5 Mac Mini available to test this on if I go through the trouble of installing it there. Maybe worth a shot even if it wouldn't be possible to start using all the other stuff on that tiny Mac. Thanks!
 

CGR

Pianist, Composer & Arranger
Yeah, I tried with 2000 max voice count - no effect and Kontakt reports only like 100-200 voices running. It could be Windows-only thing but I've done pretty much all latency etc tunings available (C states, hyper-threading etc.). To me it seems like there is some kind of pedaling bug in Walker which keeps cumulating CPU load over time.

Good point about Mac - I also have a i5 Mac Mini available to test this on if I go through the trouble of installing it there. Maybe worth a shot even if it wouldn't be possible to start using all the other stuff on that tiny Mac. Thanks!
Sorry to hear of your problems - that's very frustrating. From what I've read in various forums, it seems that the Walker D behaves better on Mac computers. I run the full 36 velocity patch with 2 mic sets (Hammer & Room) in Logic X Pro on an old 2009/2010 Mac Pro 2.8Ghz Quad core with 20GB ram without any problems or drop outs, and that is with dense playing & pedalling.
 
Last edited:

gfd

New Member
Not sure how to work around other than to use less damper pedal (good luck!). Embertone say they are working on it. We'll see. They don't seem to engage their customers on forums. I don't blame them. They get flamed a lot. I won't use the library again until it is fixed. Too bad...I love the sound of that piano.
 

OleJoergensen

Senior Member
2 years later....

I forgot about the advices given here and now reread part of this thread and tried what @sin(x) suggested, thank you!:
Switch the source playback mode of all "rel" groups from DFD to Sampler(in Kontakt)
and it works great.

I really like the sound of walker piano, such a nice tone.
Here an easy arrangement of "A child is born" made for my piano students.
Close (-11)+ hammer(-4)+ room (0) mics. Little compression and E.Q.
 
Last edited:

LostintheBardo

New Member
I've downloaded the full version just now (still downloading all the mic positions) and I've got that issue where it isn't showing in the kontakt library menu and I have to go through the file system and then it is in demo mode. The nicnt file is name correctly. Really hope I don't have to redownload everything to get around this...

From quickly jamming on it, I think I'm in love already.
 

SGordB

Active Member
I've downloaded the full version just now (still downloading all the mic positions) and I've got that issue where it isn't showing in the kontakt library menu and I have to go through the file system and then it is in demo mode. The nicnt file is name correctly. Really hope I don't have to redownload everything to get around this...

From quickly jamming on it, I think I'm in love already.
I think all you need to do is "add a serial" for the Walker D inside Native Access and then use "add library" to point it to where you've already installed the lib.
 
Hi.

For the last few days, I've been trying to find a solution regarding CPU spikes when playing a few specific instruments in Kontakt (especially those which benefit from a sustain pedal...;)
I wanted to avoid the option of changing the sampler playback source from DFD to Sampler, as this will eat up my precious ram. To my surprise, it was changing the multithread option in Kontakt from off to 8 cores – both in standalone and in my DAW – which made it possible to play more than three notes with the sustain pedal engaged on two of my favorite pianos – the Walker 1955 and 1985 Passionate Grand.
This solution seems to reduce the CPU usage quite drastically, especially in Logic, when playing the mentioned heavy CPU-hitters in the standalone application.

Earlier, I searched and read a lot about whether I should keep the "Multiprocessor support" option in Kontakt turned off when I instantiate the plug-in in Logic or if it would be more efficient CPU-wise to turn it on.
My impression is that the overall recommendation is to leave it off if you got "Processor Threads" set to automatic (or specified number of cores/threads) in the Logic preferences panel.

For me, and in terms of glitches, dropouts, and CPU spikes, the solution indicates that Logic and Kontakt will benefit from «sharing the load.»
I have no idea if this will ease the CPU load for others affected by the same issue, but I thought it was worth posting on relevant threads/forums.

I've tested this on my iMac 2012 running OS 10.14.6 (Mojave), Logic 10.5.1, and Kontakt 6.7.1.
 
Top Bottom