Cubase wont receive key modifiers (ctrl/shift etc) just after playback. Anyone else ave this issue?

composerlarkin

New Member
Hey all,

I have this issue since updating to cubase 9.5, whereby, after stopping playback, or just after fast forward/rewind, Cubase won't listen to or receive keyboard modifiers. Goes back to normal after about half a second.

For instance, if I record something and want to hit ctrl+z straight after recording (e.g. I made a mistake) it will only input "z" no ctrl. This is ok sometimes, but other times it gets frustrating, especially when trying to copy midi notes (just pushes c instead of ctrl+c)

It seems to happen during the midi chase event just after stopping, or locating to a new place on the timeline. I have a large 900+ track template, so the midi chase is long. The delay doesn't bother me too much, but the lack of modifiers does.

Anyone else with large scoring templates have this issue? I built this template in 8/8.5, so perhaps I need to re-build in 9.5 to get rid of some bugs. It's just going to be a huge job.
 

Havoc911

Member
Hey all,

I have this issue since updating to cubase 9.5, whereby, after stopping playback, or just after fast forward/rewind, Cubase won't listen to or receive keyboard modifiers. Goes back to normal after about half a second.
Yes, this is due to the auto-save. Ctrl+Z is usually the only one that used to cause me problems as just "Z" will size the selected track to large. You can adjust how often Cubase auto-saves, but I'm too paranoid to set it any longer than 15 minutes. I've switched to a touch screen and I'm no longer using the keyboard for most of these functions, so it's not an issue anymore.

There is an "undo zoom" key command if you accidentally get z (zoom track exclusive) instead of ctrl+z. You could also unassign the zoom track exclusive command.
 
OP
C

composerlarkin

New Member
Hi Havoc,

Thanks for the tip! Though I have noticed that it occurs more regularly than during auto-save. But, switching to touch-screen, or using shortcuts without the modifiers does speed things up in the general sense.

That said, I seem to have solved the problem another way. By disabling unused midi channels.

This significantly reduces the lag as a result of MIDI chase with high midi channel counts. The other way is to disable "chase not limited to part boundaries" in preferences, but that runs the risk of inconsistent mixes and CC values. By simply disabling everything one keeps midi chase in tact for required channels, and significantly reduces lag on large templates. Now if I undo after doing a take, Cubase does what it's supposed to.