What's new

Cubase: Way to prevent key editor from jumping back to start of part when selecting a part?

gohrev

Newbie Composer
It drives me nuts, I'd like for the key editor to show the part where the vertical line ("play line"?) is currently at, rather than taking me back to the very start of the midi part.

Wondering if anyone knows a trick to prevent this from happening? :) TIA.
 

IFM

Senior Member
Look in: Edit - Preferences - Transport.. un check the "return to start position on stop" box.
I don’t think that’s the same issue as I feel the OP’s pain and I don’t have that checked either.
Edit: plus it’s not returning The play line to the beginning of the part, just the display. You have to hit play to get it to scroll to the play head. Annoying.
 

JamieLang

Active Member
The only way mine shows the beginning of a part is if I select a part/chunk that the "play line" isn't currently in at all. If I open the editor for a part that the playhead is currently anywhere within the boundaries of, it opens to wherever the playhead is.

10.5.20 Win10.1903
 
OP
gohrev

gohrev

Newbie Composer
Thread starter
  • Thread Starter
  • Thread Starter
  • #5
Correct @IFM
@JamieLang you'll find that the key editor will jump to the beginning of a midi part when you select a different part or instrument. And that is precisely the thing that bugs me.

A workaround - although cumbersome - for now, is to double-click a midi part and then press "F" twice. It will take you to the playhead. But this is far from ideal.
 

Markus Kohlprath

Active Member
I know this problem very well and got somehow used to it. I just press play for a short time then it jumps automatically to the play line. I haven't found another solution until now.
 

YaniDee

Senior Member
The only way mine shows the beginning of a part is if I select a part/chunk that the "play line" isn't currently in at all. If I open the editor for a part that the playhead is currently anywhere within the boundaries of, it opens to wherever the playhead is.
I cant even recreate that..whatever part I click on opens with the "playhead" in the same place shown in the project. I doubt this makes a difference, but I'm using Cubase 11 on Win 7.
 

ilja

New Member
This situation drives me nuts as well. Double f is one option or selecting the part and pressing enter solves the problem as well but as mentioned it’s less than ideal.
 

Grizzlymv

Senior Member
Same here. I thought I messed up something in my setting but wasn't able to figure out which one. Glad to see that I'm not crazy and not alone. ;). Thanks for the double f tip. Not what I'd like as a final solution but a good workaround in the meantime. Hopefully they addressed this in Cubase 11.
 

ilja

New Member
Same here. I thought I messed up something in my setting but wasn't able to figure out which one. Glad to see that I'm not crazy and not alone. ;). Thanks for the double f tip. Not what I'd like as a final solution but a good workaround in the meantime. Hopefully they addressed this in Cubase 11.
I’m on Cubase 11, so I’m afraid they didn’t:(
 

Giscard Rasquin

Active Member
On 11 as well and it’s quite annoying yes. I just hit the space bar twice to start and stop playback. It’s pretty much an automatic action now when I open an editor. Would be nice to see it solved though.
 

gordony

New Member
My workaround - set up a single key command to toggle show/hide the lower zone (I used the full stop key on my keyboard). This makes it very quick to open & close the lower zone.
Select a midi part, open it in the lower zone to edit. When done close lower zone with the key command. Then select 2nd midi part and open it - the part is correctly aligned with the play cursor (the midi editor doesn't jump to the start of the midi part).
 
Last edited:
Top Bottom