What's new

Cubase - Insane GUI Lag. Help!

Guffy

Senior Member
This is a problem that i've had for some time now, and i can't seem to fix it.
I've googled my ass off to no avail.

This is a project with no instruments, audio tracks or FX.
VEP isn't connected. It's pure midi data.
At the laggiest part in the video, there's 17 different midi tracks being triggered, and most of them has from 1 to max 4 types of CC data written in them (Vel, Mod, exp, pitch or cc16).

I have a GTX 1080, and i'm running cubase in 3440x1440p.

I've already tried:
- Reinstalling Cubase (had this issue in Cubase 9.0.4 and it's no better in v9.5)
- Reinstalling Audio interface drivers + software.
- Reinstalling GPU drivers (Also tried rolling back to earlier versions)
- I must have tried to check/uncheck every single option in the cubase preferences by now.
- Disabled all kinds of stuff like Windows Defender.
- Cleaned up PC with CCleaner etc.

I'm out of ideas now.

It's extremely frustrating to work like this.
If it can't handle 17 midi tracks not connected to any instruments, how is it gonna perform with twice that amount?

Anyway.
Do i really have to switch DAW, or is there something i can do to reduce that horrible lag?

Thanks.

Edit: Higher res vid: https://www.dropbox.com/s/q4t7959wywf0i2w/Desktop 2018.06.25 - 16.25.21.02.mp4?dl=0
 

benatural

Active Member
Try this:

Go into GeForce control panel, turn default graphics settings to Performance. Go to custom application settings in the control panel, find Cubase, and turn off/downall settings to either "off" or "performance mode".

You'll notice a huge difference.
 

Karma

Spitfire Audio
I have the exact same issue, with the difference being that I'm using an R9 390 as my GPU. Done tons of research and I'm still unable to get anywhere sadly.
 

zolhof

Active Member
I had this issue when 9.0 was released, the piano roll was particularly laggy, but it went away with an update.

I'm using a GTX 1070 with the latest driver and couldn't reproduce your issue with 9.5, nor the visual glitches shown here. I feel for you guys though, dealing with this crap can be really distracting.

I've tried all sorts of worspace configurations (4K and 2K monitors) and couldn't trigger any lag or visual glitches.

Use DDU to perform a clean driver installation (safe mode option) and remove all the bundled crap like 3D Vision, Physx, HD Audio Driver and Geforce Experience when you reinstall.

If you are using a TV or Monitor with onboard audio, make sure to disable it > Device Manager > System Devices > High Definition Audio Controller (right click, disable). Even if you turn it off in the NVIDIA Control Panel (setup digital audio) somehow the driver will creep back in and can mess with your main audio interface. Disabling the controller at the Device Manager is the only way to be sure.

Here are my NCP options, they are pretty much stock:


benatural's tip could help, the only drawback to using Maximum Performance is a bit higher power consumption and heat.

edit: When you contact Steinberg support, send them your DxDiag, it will be easier to troubleshoot. Start > run > dxdiag > Save All Information. Good luck!
 
Last edited:
OP
Guffy

Guffy

Senior Member
Tried your suggestions, but there's no improvement unfortunately.
Thanks for your input though!
 

Will Blackburn

Active Member
same lag issue here in the audio editor. i've never had the problem before (using same graphics card) until upgrading from 8.5 to 9.5.

0.20 here

 

pisskeule

New Member
Guys, I would strongly suggest that you stay away from high performance graphics boards like the 1080. Their drivers ( nvidia ) are shite, and they are being prioritised by Windows, taking away real time performance from other system processes.
I dumped my Geforce in favour of a AMD FirePro w5100, and that basically sorted out all my issue regarding DPC latency. In fact, the swap brought it down to 7-20 in LatencyMon.

Just make sure you're taking a mid range card, that's more than enough for anything Cubase.
 

Scott Moran

New Member
This may not be any help at all, but I had the same kind of issue in Ableton and it was the monitor refresh rate. I had to turn it down from 144hz to 60hz.
 
OP
Guffy

Guffy

Senior Member
Guys, I would strongly suggest that you stay away from high performance graphics boards like the 1080. Their drivers ( nvidia ) are shite, and they are being prioritised by Windows, taking away real time performance from other system processes.
I dumped my Geforce in favour of a AMD FirePro w5100, and that basically sorted out all my issue regarding DPC latency. In fact, the swap brought it down to 7-20 in LatencyMon.

Just make sure you're taking a mid range card, that's more than enough for anything Cubase.
Interesting.
There are people using nvidia cards without these issues though..
I've sold my 1080, and right now i put an older 560Ti in it's place, but it's just as bad. I suspect my 1st gen scarlett 6i6 might be the culprit here since i notice some improvement if i switch to other audio drivers temporarily installed to check. Changes to graphic settings has made zero difference.

This may not be any help at all, but I had the same kind of issue in Ableton and it was the monitor refresh rate. I had to turn it down from 144hz to 60hz.
Mine has always been 60
 

pisskeule

New Member
It's the bloody drivers. I suppose its because of NVIDIA's edge in technology, they're way ahead and hence probably don't need to optimise drivers as much as AMD.
 
OP
Guffy

Guffy

Senior Member
It's the bloody drivers. I suppose its because of NVIDIA's edge in technology, they're way ahead and hence probably don't need to optimise drivers as much as AMD.
I can't be the only person in here using a Nvidia GTX series card though?
Yet i seem to be in the minority here with this issue.
 

MarcusD

Active Member
Make sure you turn off G-Sync in the Nvida Control Pannel. Had the same laggy issue in C10. Seems to have solved it (at least for me)
 

jpb007.uk

Member
It seems that since updating to Nuendo 10.0.20 that I have the same glitchy / sticky graphics issues.
I have two GForce GTX1060's (driving 4 screens of three 4k and one 2k) and have managed to tweak the settings to improve things, but graphics latency seems to be the cause. Most noticeably when hitting the space bar (playback) and watch a now very glitchy cursor move across the screen. It used to be smooth, but now it seems to stick every 2 or 3 pixels. Also when hitting the space bar (to stop playback) again it takes a good minute or so for the cursor to stop moving and Nuendo to become responsive again.

I'm going to try a Radeon AMD WX7100 to see if this fixes it. I've noticed many users reporting that the old AMD FirePro W GFX cards are good for this and also the mid-range Radeon WX cards.

So fingers crossed.
 

jpb007.uk

Member
It seems that since updating to Nuendo 10.0.20 that I have the same glitchy / sticky graphics issues.
I have two GForce GTX1060's (driving 4 screens of three 4k and one 2k) and have managed to tweak the settings to improve things, but graphics latency seems to be the cause. Most noticeably when hitting the space bar (playback) and watch a now very glitchy cursor move across the screen. It used to be smooth, but now it seems to stick every 2 or 3 pixels. Also when hitting the space bar (to stop playback) again it takes a good minute or so for the cursor to stop moving and Nuendo to become responsive again.

I'm going to try a Radeon AMD WX7100 to see if this fixes it. I've noticed many users reporting that the old AMD FirePro W GFX cards are good for this and also the mid-range Radeon WX cards.

So fingers crossed.
So a quick update (2 days later):
I swapped the 2 GeForce GTX1060 Turbo cards for a new Radeon AMD WX7100, and wow the change is amazing. Here are the initial findings (5 Pros and 1 possible con):
1) All graphics, windows animation including scrolling and max/minimizing are so much smoother
2) In Nuendo 10, everything is smooth now. No more jittering cursors, or pausing when I open an editor, and the Nuendo graphics are so much more detailed with finer resolution
3) Rendering in Premiere Pro is about 5 times faster, and again no more jittering video playback
4) The new Radeon WX7100 takes a single slot on my motherboard, freeing up 3 more slots. The GTX1060's require 2 slots each. So I can now do away with the external thunderbolt expansion box and bring my 2 UAD Octos internally, yay!! :)
5) The new WX7100 fan is quieter than the GTX1060s, despite various reviews complaining that the fan is fairly noisy (I guess it depends which GFX cards you're comparing to).

I've had one crash so far where all 4 screens went a sort of grey misty colour and the PC froze. I don't know if this is down to the Radeon card or the latest Windows update though.

For info: My PC-workstation is running Windows10, with dual CPU (2696v3), 128GB RAM, and 4 displays (x3 4k and x1 2k).

So, I'll keep the new Radeon card installed for a week and see how things go, but early signs are that the GeForce GTX1060's were not up to the job, despite their spec being overkill for anything I do on my PC.
 
Top Bottom