What's new

Cubase 10

Rob Elliott

Senior Member
I'm on v8.0. I know it's not 8.5 but I think they're close, and on Win7. I just opened a few projects after the upgade this morning with no issues so far. Hopefully there won't be any.
Good to know. Just discovered ONE big issue (from steiny issues site). THe new HiDPI is ONLY compatible with W10. Are you seeing the benefits on W7?
 

Guy Rowland

Senior Member
This should have been fixed with C10. I have been testing it for months without any issues. Can you provide a repro please?
This is good news, VERY good news. I can't install til the weekend. Steinberg claimed it was fixed in 9.5.41, but people suffering from the bug found no change. If 10 works reliably, I will be cartwheeling.

In your experience, does it open old archives cleanly or do you need to make fresh ones from within 10?
 

richardt4520

Active Member
Good to know. Just discovered ONE big issue (from steiny issues site). THe new HiDPI is ONLY compatible with W10. Are you seeing the benefits on W7?
I haven't spent a lot of time with it just yet and had to leave for a couple of hours. I will be finding out in a bit though. Fingers crossed!
 

kavinsky

misty orchard in the middle of Czechoslovakia
This should have been fixed with C10. I have been testing it for months without any issues. Can you provide a repro please?
yes please let us know if it really works now! importing from the old track archives that is
and the main thing is that it should be tested inside a CPU and RAM heavy project. in the blank project it works fine sometimes
also its supposedly only a windows issue
 
Last edited:

SomeGuy

Active Member
Would love more info on these custom macros you are using. They sound very helpful indeed! This is one really great feature of Cubase! Need to remember to utilize them more!
Ok had more chance to play with it now. On the whole, it's a pretty good update, worth it in my opinion and there's some really welcomed refreshments and new features that I love. However I'm going to focus purely on the negatives. Which TBH, not many.

ADD TRACK:
  • Does not allow new tracks to be sent to an FX channel. It only sends the direct output. Which is fine if you want to create 4 audio channels (or what ever) to be sent to a group, but if you want to create sends for those channels too, you can't do so from this window. I just use Macros, but I can see this being slightly annoying for some people.
  • Lets say you want to record 5 microphones on different inputs. You'd have to create 1 channel each time and select the input. Be much easier if you had a check box to let you choose what input each channel is using.
DRAG 'N' DROP:

  • Can't select bunch of channels then drag and drop a group or FX channel to automatically rout them. This would be ace. For now, still much quicker to use a Macro function.
TRACK PRESETS:
  • Still don't remember group tracks or FX channels if you decided to save x-amount Violins + their Groups and FX. Only way around this, use a custom macro. Then save and recall the individual channel input chain for the group or FX and load it. Not exactly a ball-ache, but it is if you're not particularly organised with saving your own presets or using Macros.
  • Quick Controls do get saved and recalled. However, if you're using 1 instrument with multiple outputs set-up. You will not be able to assign quick controls to EACH individual output. You only get 1 quick control on the master instrument channel. However you can rout any plugins to this from the outputs, but you are limited with the number of slot controls.
  • When selecting any track preset, there's no way to turn off the pre-load preview. Still annoying when working with sample library track presets.
EXPRESSION MAPS

  • Was hoping for improvement on this. Still none. Would be much better if they added MIDI input selection to create the switches, instead of typing out values.
MIXER

  • Like the new buttons for bypassing sections of the mixer. The only thing I don't like is you have to click and hold for them to activate.
  • Snap Shot doesn't include automation.
MEDIA BAY

  • Still needs a complete re-work to make it more functional and user friendly. The performance is still just "OK".
 

EgM

Game music!
Are there other online vendors that sell the update from 9.5 Pro to 10 Pro?

Steinberg's CAD$ exchange rate is ridiculous!
 

madfloyd

Active Member
Speaking of vendors, I'm trying to upgrade and am at an impasse. I log into MySteinberg just fine but when I go to their 'shop' to purchase the upgrade, it seems to want a different log-in - for which I don't seem to know the password (and their 'forgot password' doesn't send me the promised email to reset it). Is the double log-in normal?
 

Daniel James

Senior Member
Man being able to just see the UI of plugins really inspires me to try new ideas out. Also a side effect of the new "Use Video Follows Edit" means that now I can just click on a clip to move my transport bar to where I want it. No more fast forward and rewinding...just click the clip in the arrangement then hit play :)

Screen Shot 2018-11-15 at 11.42.15 AM.png
 

kimgaboury

New Member
In version 10 (Pro) we can now load multiple movie files in the same project, which I don't think we could before. Can anyone confirm that this is a new feature?
 
Last edited:

Mihkel Zilmer

Senior Member
I log into MySteinberg just fine but when I go to their 'shop' to purchase the upgrade, it seems to want a different log-in - for which I don't seem to know the password (and their 'forgot password' doesn't send me the promised email to reset it). Is the double log-in normal?
Yes, the shop and the site have two different accounts, it's always been like that. Years back I bought Cubase from a music shop, and created a MySteinberg account to register it. Later, when I wanted to upgrade it came as quite a surprise to me that I didn't even have a shop account..
 

Michael Antrum

Only the good die young....
I've been travelling all this week, though amazingly one of the hotels did not have the most terrible internet in the world, and when I got up this morning it had downloaded.

Looking forward to investigating MPE, as I have a Roli Seaboard Rise with me and am greatly anticipating some finger trembling a bit later on. The snapshots are lifted from Studio One.

Going to have a play with it in tonight's (different) hotel, which does have probably the most crap internet in the hemisphere.
 

greggybud

Member
yes please let us know if it really works now! importing from the old track archives that is
and the main thing is that it should be tested inside a CPU and RAM heavy project. in the blank project it works fine sometimes
also its supposedly only a windows issue
The only way is to try random track archive scenarios over a period of time. It was (hopefully) fixed months ago for C10, and since that time I and other beta testers haven't been able to find any bugs. From the start this seems to be intermittent so it was or is difficult to examine. If anyone can do a step-by-step repro of consistent issue, please post it.

Also when you say "old track archives" please state the version originally saved if you remember. Also "cpu and RAM" heavy projects give an idea of processing load and CPU.
 

greggybud

Member
This is good news, VERY good news. I can't install til the weekend. Steinberg claimed it was fixed in 9.5.41, but people suffering from the bug found no change. If 10 works reliably, I will be cartwheeling.

In your experience, does it open old archives cleanly or do you need to make fresh ones from within 10?
Is there a thread where users on 9.5.41 are still experiencing problems?

I tested with both fresh C10, exporting then importing, and imported old track archives saved in 9.0 and 9.5 into C10.

If there is a bug remaining, I hope anyone can list a repro. It may very well depend on size or load.
 

kavinsky

misty orchard in the middle of Czechoslovakia
From the start this seems to be intermittent so it was or is difficult to examine. If anyone can do a step-by-step repro of consistent issue, please post it.
Also when you say "old track archives" please state the version originally saved if you remember. Also "cpu and RAM" heavy projects give an idea of processing load and CPU.
I'm getting this problem 99% of the time in my projects.
"Old track archives" meant 8.5 primarily in my case. But when I got 9.5.41 I tried saving new projects and was able to get the same issues.
"CPU/RAM heavy" is when my RME Fireface UC buffer is at max and if I turn the ASIO guard down there are pops and clicks. So pretty much bottlenecked.
RAM is usually around 25-35 gb
I wonder if I send you the kontakt nkms without samples would it work?
Let me try it and I'll definitely get back to you? Just PMd you for details
 

antoniopandrade

Active Member
Just a quick chime in with my first thoughts.

GUI is incredibly snappy (Win10). I was stuck in 8.5, even on a PC, because 9 and 9.5 had noticeably slower GUI performance but Cubase 10 seems to fix this. In fact, the GUI response is the snappiest I've ever experience in any version of Cubase to date (started using it in version 7).

I'm not a fan of the UI design changes but I managed to get it looking pretty close to 8.5 so I'm not complaining too much. Enjoying the tiny progress bars when you switch to secondary tools on right click. Haven't tried audio align yet but the new hit-point detection is already LOADS better than the previous version (I record a lot of guitars, so this is a big deal for me).

I'm on a 14-core i9 and have had my hyper-threading turned off because of the MMCSS issues in Win10 but Steinberg claims to have circumvented that limitation. Haven't tested this yet but excited to see if it helps with performance. Otherwise, CPU performance seems pretty much exactly the same.

The GUI lag is an absolute game changer for me. Using this version of Cubase finally feels snappy and fast, even in my 1700 track template. Seems like Steinberg put in a lot of work behind the scenes and focused on usability versus features, which I can really appreciate. But that's just my initial impression, will update if anything else changes.
 

Illico

Samuel Le Tonquèze
In version 10 we can now load multiple movie files in the same project, which I don't think we could before. Can anyone confirm that this is a new feature?
I'm in Cubase Artist 10, only one Video file supported...but my thumbnail issue was solved.
 
Top Bottom