What's new

Cubase 10.0.20-Forgotten midi ports

MrLinssi

A glorified bedroom musician.
Apparently this issue (a midi track forgets it's correct port after the instrument track is disabled/enabled) was fixed in the latest Cubase update. The problem is still there in my template (which I created in 10.0.15), which is a shame since with multis I could reduce the disgusting amount of Engine/Kontakt instances I already have. Does anyone have any idea if there is a way to fix this? I really don't feel like starting my massive template from the beginning...

And yep, already contacted Steinberg support a week ago, still waiting...
 

zolhof

Active Member
Did you try to reconnect ports and resave the project? If I just open an older template version, say 10.0.15, the issue is still there. I had to manually reconnect all midi sends ports for a ridiculous number of tracks and save the template under 10.0.20 in order to work. Cubase remembers all connections now (knock on wood).
 
OP
MrLinssi

MrLinssi

A glorified bedroom musician.
Did you try to reconnect ports and resave the project? If I just open an older template version, say 10.0.15, the issue is still there. I had to manually reconnect all midi sends ports for a ridiculous number of tracks and save the template under 10.0.20 in order to work. Cubase remembers all connections now (knock on wood).
Seems to work for me, did a test with a few midi tracks connected to an instrument track. Disabled, enabled, reconnected the ports and saved as a new version. Opened the new project, enabled the instrument track and the ports were connected. Luckily most of my tracks are inside VEPro now so doing this shouldn't be a major hassle...provided that it works properly after I've made the needed corrections!
 

Sample Fuel

Active Member
Seems to work for me, did a test with a few midi tracks connected to an instrument track. Disabled, enabled, reconnected the ports and saved as a new version. Opened the new project, enabled the instrument track and the ports were connected. Luckily most of my tracks are inside VEPro now so doing this shouldn't be a major hassle...provided that it works properly after I've made the needed corrections!
Try a slightly bigger test. With one instance in a blank I remember it appeared ok. I think it was when I used several different ones and disabled say the 3rd one in the middle out of say 5 different ones. Then add some new ones above it, close resave, open and try it. If all the works than maybe it is good to go now.
 

zolhof

Active Member
We have three identical 9900k Windows 10 rigs (1809 build) running a couple of thousand midi tracks each. Once I reconnected the ports and resaved the projects, all machines remembered the ports (also midi sends, which was our biggest issue). We wouldn't get much work done otherwise haha. It's worth noting that each rig has a slave running the latest version of VEPro. I also tested it on my home rig, a FX8350, and have no issues.

Steinberg just released 10.0.30 with ARA 2 support and I updated one of the studio rigs. It loaded the 10.0.20 template just fine. @Sample Fuel while at it, I did try adding new instances of VEPro, random instrument tracks, rack tracks with random midi all over the template... I went crazy for 20 minutes enabling and disabling stuff, and Cubase had no problem remembering the connections. Seems fixed for me.
 

Sample Fuel

Active Member
We have three identical 9900k Windows 10 rigs (1809 build) running a couple of thousand midi tracks each. Once I reconnected the ports and resaved the projects, all machines remembered the ports (also midi sends, which was our biggest issue). We wouldn't get much work done otherwise haha. It's worth noting that each rig has a slave running the latest version of VEPro. I also tested it on my home rig, a FX8350, and have no issues.

Steinberg just released 10.0.30 with ARA 2 support and I updated one of the studio rigs. It loaded the 10.0.20 template just fine. @Sample Fuel while at it, I did try adding new instances of VEPro, random instrument tracks, rack tracks with random midi all over the template... I went crazy for 20 minutes enabling and disabling stuff, and Cubase had no problem remembering the connections. Seems fixed for me.

Great to know....Thanks for letting us know.
 

resonate

Member
unfortunately Cubase 10.0.30 still does not recall track quick controls assignments. When you disable a track and save and close the project, the parameters are not recalled when enabling the track after re-loading. Upon re-enabling, the quick controls are empty. If you then disable the track and re-enable, the default quick controls will load, even when it _looks_ like it loaded the saved set of controls (the right names are there, but they control the default set of controls)

Even simply assigning the quick controls and simply disabling and re-enabling the track without closing and re-opening the project, forgets the assigned controls.

Steps to reproduce: (This is on a Mac, OS X Sierra)

1. Insert an instrument track
2. assign some quick controls to a vi (filter cutoff, midi cc, etc)
3. check if its working
4. disable and re-enable the track
5. the track now shows the assigned quick controls, but the default quick control set is loaded, not what you chose.
 
Last edited:

samphony

Senior Member
On MacOS 10.14.4 if i have midi tracks assigned to vep ports and disable/enable a midi track it resets to midi port 1
 

resonate

Member
Ok, so it looks like we need another campaign with Steinberg to fix all the bindings to the disabled/enabled tracks...
 
OP
MrLinssi

MrLinssi

A glorified bedroom musician.
Small update: It doesn't work for me anymore, or to be more precise, it's a bit random now. For some instances the midi ports stay connected, for some they don't. Yay, I love surprises. Anyways, I contacted Steinberg and when they finally answered they told me that their team is going to fix this in the next update. Fingers crossed.
 
Top Bottom