CPU not good enough?

Discussion in 'PC/Mac Builders, Mods, Peripherals - New' started by Uiroo, Dec 29, 2018.

  1. Uiroo

    Uiroo New Member

    39
    42
    Nov 6, 2018
    Hey guys,

    so black firday and christmas sales are (almost) over and i've got a lot of new stuff, especially spitfire.
    But the new spitfire stuff that i downloaded absolutely destroys my CPU.
    I've downloaded BDT and Solo Strings from spitfire, and one note at a time is enough to get that crackling cpu-overload noise, which i find really strange. With solo strings it's so bad, it's literally unusable right now.

    So my pc is:
    Intel(R) Core(TM) i7-6700 CPU @ 3.40Ghz
    32 RAM
    64 bit
    Cubase
    Samples are stored on internal Samsung MZ-76E1T0B/EU 860 EVO

    I did batch resaving, tried enabling multiprocessor support, experimented with the instrument preload buffer size. Doesn't help.

    I don't know much about CPU's, I don't have an idea how good my CPU is compared with what's the standard for this kind of stuff. I plan to go for 64 RAM, put i assume this won't change this particular problem.
    The reason i'm so surprised, in case anyone wonders, is that I already used many sample instruments at the same time as you can see here, and it worked just fine.
    I thought this had put the CPU to the test.


    The my question is: Is it really the CPU? Do i need to buy a better one, or is there anything i can do or do wrong?
     
  2. Jimmy Hellfire

    Jimmy Hellfire Senior Member

    1,719
    2,486
    Jun 28, 2015
    Austria
    I really doubt it. I used to run SF samples on an older and weaker quad core i7 than that. IMO upgrading to 64 GB should be a way higher priority than getting another CPU in this case.

    So changing DFD preload buffer size didn't help at all? How about the buffer size of your audio interface, what's that set to? Does (de)activating Cubase ASIO guard make any difference?

    It's good idea to download and run https://resplendence.com/latencymon. Perhaps it reveals something.
     
    Uiroo likes this.
  3. ism

    ism Senior Member

    1,144
    1,588
    Dec 14, 2016
    There's a time machine feature on the spitfire virtuosic violin that is extremely processor intensive. It's worth turning it off by default if you're on an older processor (there's a box to disable it right on the interface) and only enabling when it you're specifically using the vibrato stretching it implements. (It's a very cool feature when you need it though, but it;s not something that you need very often).

    I doubt this is what's causing your problem, but it's the something to eliminate in your search for the culprit.
     
    Uiroo likes this.
  4. jbuhler

    jbuhler Senior Member

    1,640
    2,316
    Jun 19, 2016
    US
    The Total Performance violin patch in Solo Strings is especially demanding. I don't think it's primarily a CPU thing, though. I do have to increase the sample size for the audio interface and DFD preload buffer in Kontakt when I use the violin if I don't want to get pops and clicks. In my case, I think a better audio interface might handle it more deftly. I could work the violin at 512 samples before I changed back to an older audio interface because I liked the controls better. Now I have to work at 1024 samples for the Total Performance violin patch. With BDT I don't have any notable issues, whatever the settings.
    Edited to add: this is with the Time Machine setting on. I haven't tried turning it off, as per @ism.
     
    Uiroo likes this.
  5. OP
    OP
    Uiroo

    Uiroo New Member

    39
    42
    Nov 6, 2018
    I'm so embarassed. Just increased the sample size in universal control from 256 to 512 and it works like a charm.

    Sorry guys. :rolleyes:

    edit: but the time machine setting really makes a difference
     
    Last edited: Dec 29, 2018
    ism and jbuhler like this.

Share This Page