What's new

Controller Assignments CC "hardwire" in Logic Pro X

Marko Dvojkovic

New Member
Hi!
I have noticed that when you learn a parameter to a hardware controller that corresponds to a cc number for example in the Controller Assignments window (with the easy "learn" process), that cc becomes unusable for anything else. When wiggling it, it doesn't show in the MIDI monitor input.
I would like to map Logic's Sculpture synth to my MIDI controller (Komplete Kontrol S88 mk1) but this behaviour makes anything else in my template unusable since I of course use various cc's for various controls of a lot of different instruments on other tracks.
I'm pretty sure it has to do something with the options on the right as can be seen in the attached screenshot, but I have no clue and the section in Control Surfaces manual for this window is hardly intelligible to me and it's hard to find some relevant info for this.
I would really like to use and play Sculpture and it has to be played clicking and dragging with mouse can't do it really, so I really appreciate any help on this.
Thank you!
Screen Shot 2019-06-26 at 13.49.44.png
 

Gaffable

New Member
You can get around this problem by using Logic's Automation Quick Access feature and/or by assigning your external controllers to Logic's Smart Controls.

Automation Quick Access
This feature allows you to use a single hardware controller to automate the currently active automation parameter. A short explanatory video can be found here. The relevant instructions in the Logic user manual can be viewed here.

Smart Controls
Instead of assigning your S88’s controllers to specific parameters in Sculpture, I suggest that you assign the controllers to twelve of Logic’s Smart Controls. This will allow you to use the S88’s controllers for any software instrument in Logic, not just Sculpture. The Logic user manual instructions for Smart Controls can be found here. To access Smart Controls, load a software instrument into a channel strip and then press B on the keyboard. By default, four Smart Controls are displayed for Sculpture but you can change that by:
(i) Clicking on the Inspector button in the top left corner of the Smart Controls panel; then
(ii) In the drop-down panel, just below the inspector button, click on the heading “Automatic Smart Controls” and select any of the templates in the list that end in the number 12.

A third solution - MidiPipe

In addition to Automatic Quick Access and Smart Controls, another way to get around the problem you have described is to duplicate the stream of MIDI data from your S88 using the program MidiPipe. The first stream could be assigned to Sculpture and the second to a different software instrument.
 
Last edited:
OP
M

Marko Dvojkovic

New Member
Hi Gaffable, thank you for your reply!
I know about automation quick access and smart controls but automation quick access doesn't seem convenient for this need because it would require constant assigning and reassigning and smart controls has if I'm not mistaken a maximum of 24 knobs on a panel, that's better than giving up on setting this up but yeah Sculpture has a lot more controls than that. Midi Pipe looks interesting, will try it, I hope it's not too complicated to set up
 

Gaffable

New Member
I was intrigued by your comment that it's possible to have up to 24 knobs in a Smart Controls panel. I did some research and it turns out that it's true. You need to select the "Modern Black 2 Tab" template from the Factory Layouts sub-folder. This will give you 12 knobs and 12 buttons on the Controls tab and 12 knobs and 12 buttons on the Sends tab.
 
OP
M

Marko Dvojkovic

New Member
Yes, 48, 2 tabs with 12 knobs and 12 buttons each. But I just tried it and found that the same problem occurs with smart controls, the cc corresponding to the hardware control that I assign to smart control doesn't work anymore :/. So Midi Pipe is my last hope xD
 

Alex Fraser

Senior Member
There's one more slightly "hacky" solution that may work depending on what other control surfaces are set up in your studio. Logic Pro X > Control Surfaces > Bypass Control Surfaces will disable your smart control assignments and release your controllers normal midi output. Turn it back on to switch back to Smart Controls. Thorough it'll probably play havoc with your KK..

The other option is to pickup a cheap controller like a Korg Nano and have it permanently wired to Smart Controls.
 
OP
M

Marko Dvojkovic

New Member
There's one more slightly "hacky" solution that may work depending on what other control surfaces are set up in your studio. Logic Pro X > Control Surfaces > Bypass Control Surfaces will disable your smart control assignments and release your controllers normal midi output. Turn it back on to switch back to Smart Controls. Thorough it'll probably play havoc with your KK..

The other option is to pickup a cheap controller like a Korg Nano and have it permanently wired to Smart Controls.
Komplete Kontrol is the only control surface that I am using. Hm, I am a little afraid to try that xD, but I guess it's worth a try. Thank you for the advice!
 
Top Bottom