Changing velocity range of multiple zones

Hi there,
Playing around with the new logic sampler and loving it. I'm trying to make a little library out of a multi-mic'd drum kit, and am having trouble figuring out how to adjust multiple zone's velocity ranges. For this example, I have a snare drum with a close mic, bottom mic, overheads and room. Obviously I want all of those samples to trigger from the same key, but I can't seem to get it to adjust the velocity ranges in which they trigger to be all 0 - 127 without having to do each one individually. Is there anyway to just select all those zones and adjust them all at once?

Thanks!
 

charlieclouser

Senior Member
Samples within the same group can not overlap (occupy the same key+velocity range), so each mic position's samples will need to be in separate groups. That's one thing.

To adjust multiple Zones within the same Group in the visible Map area, you can lasoo to select them (by dragging starting in an empty area of the Map window area), and then drag the upper or lower handles on the selected Zones to edit their velocity ranges - or you can use the Zone List editor. Select the Zones you wish to edit and double-click the numerical value for the velocity you want to edit and type in a new value.

Of course, if the Zones you want to edit are all in different Groups, then you must use the Zones List as described above. In the Groups column at the left select the Groups that contain the Zones you want to edit, then use the technique above to select and edit the Zones. The Zone List can display Zones from multiple Groups if they are selected in the column at the left.
 
Hey @charlieclouser

Thanks for that! I'm wondering if this might be a bug in the new logic then - I have all the samples in different groups, but still in the zone list editor it won't let me edit any of them, let alone them as a group. If I go to the mapping editor, it lets me do it, but only one at a time. See this video below to see what I mean :

Link : Velocity Range

Or am I missing a step somewhere maybe?

Thanks!

Pete.



Samples within the same group can not overlap (occupy the same key+velocity range), so each mic position's samples will need to be in separate groups. That's one thing.

To adjust multiple Zones within the same Group in the visible Map area, you can lasoo to select them (by dragging starting in an empty area of the Map window area), and then drag the upper or lower handles on the selected Zones to edit their velocity ranges - or you can use the Zone List editor. Select the Zones you wish to edit and double-click the numerical value for the velocity you want to edit and type in a new value.

Of course, if the Zones you want to edit are all in different Groups, then you must use the Zones List as described above. In the Groups column at the left select the Groups that contain the Zones you want to edit, then use the technique above to select and edit the Zones. The Zone List can display Zones from multiple Groups if they are selected in the column at the left.
 

charlieclouser

Senior Member
I have had some similar weirdness when trying to edit velocity ranges numerically in the Zone List. Sometimes saving the Instrument and switching to another, then going back to the original, cured it - but not always. In EXS Editor the Zone List allowed for very predictable numerical editing, much like working a spreadsheet or something, and it seems that Sampler is a little wonky in this area.

I've just sort of chalked these up to teething pains with the 10.5.0 version that will hopefully be fixed in a 10.5.1 update, which I'm sure will appear to address more significant problems that some are having.

There are a few toggles in the Sampler menus for "let zones overlap" and other new features that I'm not entirely sure what they do yet.

But I bet this problem is just a bug, not a feature.
 
Hey @charlieclouser,

Yeah I'm with you on that. I figured I'd just map the key command to 'remap velocities' in the Sampler to something so I could do it that way, but alas, that one doesn't have a key command available to it yet (mind you, nor does 'rename zone' which is annoying to say the least, but I'm working up a few things with Keyboard Maestro that is at least renaming zones and moving around them a bit which helps).

Here's hoping 10.5.1 sorts out some of these more niche issues!

Thanks for taking a look,

Pete.
 

charlieclouser

Senior Member
In the Zones menu inside Sampler, try turning "Protect Unselected Zones in Zone List" to OFF.

When set to ON, this toggle appears to cause what you're experiencing - numerical edits made in the Zone List will revert back to their previous value when you release the mouse or hit Enter after typing a new value - IF that new value would cause an overlap or conflict with other Zones that were not selected for editing. See if that does it.
 

charlieclouser

Senior Member
There are a few small weird things that are annoying, no doubt, but I must say that I'm impressed that I spent two days building Sampler Instruments from things I liked in the Spitfire PianoBook collection and I had not a single crash or other work-stopping or Instrument-wrecking issue, other than the small teething pains and my unfamiliarity with the new features.

I did that mostly as a way to get to know Sampler without touching my existing EXS library since I'm not 100% confident that I can go back to v10.4.8 and EXS and load Instruments that have been edited in Sampler with no issues. It appears to work, but how the heck can EXS load Sampler Instruments and completely ignore all the new parameters without exploding? Fingers crossed that it really is as safe as it seems.

I did notice a few things:

- EXS would let you have Zones with overlapping velocity / key ranges within the same Group, but Sampler does not. No way, no how. None of the toggles in the Zones menu have settings which allow this.

I did some testing, and what happens is that upon importing an EXS Instrument that's set up like that, Sampler will create new Groups containing the Zones that formerly overlapped.

I understand that preventing overlapping Zones within the same Group will make things less confusing for new users, but what effect this will have on Instruments that have both overlapping Zones and round-robin Group arrays will possibly be confusing even to more experienced users. So far, everything is sounding correct, but what appears to happen is:

When you have an EXS Instrument that uses overlapping zones and round-robin arrays, upon import into Sampler all overlapping Zones are separated into new Groups, and everything sounds correct. But now your round-robin array has doubled in size, so you effectively have two arrays working simultaneously. Everything is fine... until you encounter a situation where one array advances to the next RR but another array does not. This can happen in a variety of ways (usually while editing), and when it does what was formerly samples 1+2 layered, RR-ing with samples 3+4 layered, will now play as samples 1+4 layered, RR-ing with samples 2+3 layered. It's not the biggest disaster in history, but it may cause results that sound slightly different in Sampler than they did in EXS - however it seems this is only while you're editing for the first time and messing around with Group RR array assignments. Once you save and re-load the Instrument the arrays all reset and samples play in the correct order.

To test this, I made an Instrument in EXS with four samples of me saying the numbers 1 through 4, with one RR Group containing sample 1 at velocities 1-127 and sample 2 at velocities 64-127, then another RR Group containing sample 3 at velocities 1-127 and sample 4 at velocities 64-127 - all of them on the same key range. Play softly and you hear samples 1 and 3 alternating; play hard and you hear samples 1+2 layered, alternating with samples 3+4 layered. It all works as expected, using only two Groups in a single 2-way RR array.

When that Instrument is imported into Sampler, two new Groups are created to hold the two highest-velocity samples (whose velocity ranges overlap with the two lower-velocity samples) and at first it sounds as expected, but when you inspect the Round Robin assignments in Groups View, you see that the lower velocity samples are in the two original Groups, and their values for "RR Cycle" are "B.1 (rr1)" and "B.2 (rr2)" as expected. But in that column the values for "RR Cycle" for the two newly-created Groups are somehow set to "Move to new Cycle" - which is not supposed to be an actual value that can be selected, it's supposed to act as a command to move Groups around the RR arrays. So, somehow a command is being stored as a parameter value! This seems.... not right. Everything works as expected until you need to start editing the RR arrays, and then you'll have to manipulate the assignments so you have the Groups for the two low-velocity Zones set to "A.1 (rr1)" and "A.2 (rr2)" and the Groups for the two high-velocity Zones set to "D.1 (rr1)" and "D.2 (rr2)" or similar. Then things do work as expected.

But during the process it is entirely possible (quite easy, actually) to scramble things up so that on hard velocities you now hear samples 1+4 layered, alternating with samples 2+3 layered, as described above. Upon changing to a different Instrument and re-loading the original, the RR array resets itself and behaves as expected, but dang if it won't be confusing during the initial editing process.

Not loving this change at all... but as long as it doesn't break any of my old EXS Instruments I guess I'll live. Of course, once you're forced into putting overlapping Zones into separate Groups, you do get the additional control offered by separate Groups.

- The ancient problem of RR arrays not advancing to the next Group until all sustaining notes have been released is still there - at least it's no worse than before but dang it would have been nice if this had changed so that RR Groups would advance on note-on instead of waiting for all notes to be released, so the behavior would be as it is in Kontakt and other samplers.

- I wish there was a way to have "Optimize Sample Gain" in the Sample Editor pane default to OFF. This feature analyzes the level of the selected Sample and edits the Zone Level parameter to achieve -12dbLUFS. If you have created an Instrument without using the "Optimized" drag-n-drop method then the Zone Levels will default to +6.00db (instead of 0db, which is a little annoying), but when you select a Zone and view it in the waveform view at the bottom, and look at the menu, "Optimize Sample Gain" is switched ON, but hasn't done anything yet. If you toggle it off and then back on again, Sampler will edit the Zone Level parameter after analyzing the sample. So it's safe... ish. It won't change things unless you expressly tell it to, but it would be more clear if the toggle defaulted to the off state when it has not been used yet, since it currently appears that it HAS changed the Zone Level when it hasn't.... yet.

Sure, it's really great to have this option, but often I really REALLY want precise manual control over Zone Levels, with no chance of Sampler trying to help - and the fact that the menu toggle appears to be ON when it hasn't done anything to the Zone Levels is confusing.

- AutoMap seems to work amazingly well, even its Pitch Analysis mode seems much more accurate than that in Redmatica KeyMap (even setting fine-tune parameter values in the Zone List to accurately re-tune every sample, which is amazing), but it always centers the root key in the middle of the auto-created Zones. For me, best practice is to have the root key at or near the upper limit of each Zone, to avoid having any samples transposed upwards by a large amount. I really wish there was some user control over this behavior - like a preference called "Root Key Placement in Auto-Mapped Zones" that would let you select how many semitones from the upper limit of each Zone the root key would be located, perhaps with a checkbox for "Centered" that overrides the numerical parameter.

This way, you could leave the checkbox for "Centered" turned on and the behavior would remain as it is currently, but turning that checkbox off would enable a numerical field called "Set Upper Zone Limit XXX semitones from root key when Auto-Mapping", with the upper extreme value being "Upper Zone Limit equals Root Key" and lower values would effectively move the Upper Zone Limit up the keyboard by semitones. As it currently stands, if you want root keys to not be centered, you've got to do some serious manual editing.

(continued next post)
 

charlieclouser

Senior Member
(continued from previous post)

- It is frustrating that when editing Sample start / loop points in the bottom pane, you can't use the arrow keys to navigate between Zones. Sure, you can use the "Select Zone of Last Played Key" to select Zones via MIDI, but when you're editing Zones in Keyboard View you can quickly flip through the Zones using the arrow keys and the Sample display at the bottom will quickly update to show the waveform of the sample in each Zone as they're selected in turn. As soon you drag the start/end/loop handles in the bottom pane, the Keyboard View is no longer the "hot" area, and the arrow keys stop working, forcing you to manually click on a Zone in the Keyboard View area to select a different Zone. What a huge hassle! Since the arrow keys are not used when editing the Sample handles they should remain active to navigate through the Zones that are visible in the Keyboard View.

Alternatively, it might be nice if the arrow keys did have some effect when editing a Sample in the bottom pane, such as jumping whatever handle was last clicked to the next/previous zero-crossing or transient, allowing you to click once on whichever of the handles you wanted to edit and then use arrow keys to make changes without trying to manually drag those handles with the mouse.

- In the EXS Editor, if a Group was selected in the Groups List at the left side of the Zones View, you could hit Return to enter name-editing mode for the selected Group, which made it quick to select, rename, and copy/paste Group names. This is no longer the case with Sampler. Yes, you can still use the arrow keys to navigate through Groups, but in order to edit the name of a Group you must double-click with the mouse. A small hassle, but a step backwards for sure.

- There does seem to be some graphics weirdness with the Group mute / solo buttons. They are behaving as expected for the most part, but there seems to be a graphic glitch where, after using the solo buttons, some of the mute buttons will appear to be enabled even when they are not. Since the mute buttons appear to be turned on when a different Group is solo-enabled, this seems to be simply that the graphic of the other Group's mute buttons is not reverted to appearing off when solo is released. Small, but confusing. Could be pilot error but I doubt it.

Overall, I'm very impressed with Sampler. Editing the start/end/loop points for samples in the lower pane is very quick, and AutoMap and the new drag-n-drop import options are also a massive time-saver and very welcome. With a couple minor tweaks to enhance the speed at which power users could operate, I'd have very little to complain about.
 
Hey @charlieclouser

Yeah all great thoughts - this 'Protect Unselected Zones in Zone List' option doesn't seem to let me add in velocity ranges via the Zone Editor still though - very odd! Must be a bug!

I'll submit a report and see if they patch it up, along with your other great suggestions in this thread, in an upcoming update.


In the Zones menu inside Sampler, try turning "Protect Unselected Zones in Zone List" to OFF.

When set to ON, this toggle appears to cause what you're experiencing - numerical edits made in the Zone List will revert back to their previous value when you release the mouse or hit Enter after typing a new value - IF that new value would cause an overlap or conflict with other Zones that were not selected for editing. See if that does it.
 
Hmm - it seems to be not actually selecting the multiple zones, even though it tells me multiple zones selected. I've made a crude video here - but as you can see, it seems to just select the 'Hat' zone, as its at the bottom of the range in the mapping editor maybe? So then if you enter anything numerically in any of the Zone's in the Zone Editor, the only value that changes is the 'Hat' zone. So yeah, it seems to not actually be selecting everything.

Link for crude vid : https://www.dropbox.com/s/rincobffhja2bqf/StrangeVelocityRange.mp4?dl=0

Very strange!


Hey @charlieclouser

Yeah all great thoughts - this 'Protect Unselected Zones in Zone List' option doesn't seem to let me add in velocity ranges via the Zone Editor still though - very odd! Must be a bug!

I'll submit a report and see if they patch it up, along with your other great suggestions in this thread, in an upcoming update.
 

charlieclouser

Senior Member
Yes, that appears to be a bug for sure, related more to Zone selection than Zone editing. It's as if the yellow highlighting that's supposed to indicate what's selected is not accurately reflecting what actually IS selected, in addition to some fault in the Zone selection mechanism. And that's worse than if just the Zone selection were broken but the yellow highlighting was accurate, because then at least you'd have a visual confirmation that what you think is being selected is not, if fact, selected.

This appears to be similar to some of the graphic weirdness that I'm seeing, like the Group Mute buttons remaining illuminated even when the Group is not muted, etc.

I'm glad these problems seem relatively minor however - for the most part I'm pleasantly surprised at how well Sampler is working so far. The fact that it appears I can go back and forth between EXS on v10.4.8 and Sampler on v10.5 without wrecking my whole EXS library is pretty amazing - although I did do a .zip archive of my whole Instruments folder before launching v10.5 just in case.
 
Hmm it is something specific with the velocity ranges - for instance if you want to change the Mixer in Group List view, you can double click on one entry and edit it and it follows for all - so it seems like in that instance it is selecting everything. I wonder if there is some hidden option somewhere in there I'm over looking. Oh well in the meantime I'm using keyboard maestro to automate bits of it, but its a bit dull!
 

tomorrowstops

Active Member
Well, there you have it folks, @charlieclouser is now officially the ‘Sampler Ninja’ :laugh:

I still haven’t dug in myself (trying to stay focused on finishing my current project), but I’m excited to see what the new Sampler is all about!