5.6 announced

Soundhound

Senior Member
Anybody getting midi timeouts in Logic Pro X when dealing with Kontakt, or is it just me and my excellent VI karma?
 

Rob Elliott

Senior Member
Ok - now I am in a corner. Just picked up a library that NEEDS 5.6!!!!! I am on PC (all putters and slaves) - W7 - anyone running this config ok? Just so many - this isnt' working - that's worse kinda comments here - scares the bageebers out of me to update.
 

gpax

Senior Member
Ok - now I am in a corner. Just picked up a library that NEEDS 5.6!!!!! I am on PC (all putters and slaves) - W7 - anyone running this config ok? Just so many - this isnt' working - that's worse kinda comments here - scares the bageebers out of me to update.
I've been dreading this inevitable post.
 

Rob Elliott

Senior Member
Of course we always have choices but when you just know the 'new' library is the right thing for the project and you almost dare not update - hate that feeling of constraint. I could just update that one puter (of the 4 I use) - BUT, if there were issues with only that one puter and Kontakt (running in VEPRO 5.x) I'd be up a creek. Really love to hear from the W7 folks in VEPRO 5.x that all is fine (I know there are the GUI issues which are not deal breakers) - just crashes, MAJOR features missing, etc. (The purge thing is not a deal breaker.)
 

robh

Senior Member
Of course we always have choices but when you just know the 'new' library is the right thing for the project and you almost dare not update - hate that feeling of constraint. I could just update that one puter (of the 4 I use) - BUT, if there were issues with only that one puter and Kontakt (running in VEPRO 5.x) I'd be up a creek. Really love to hear from the W7 folks in VEPRO 5.x that all is fine (I know there are the GUI issues which are not deal breakers) - just crashes, MAJOR features missing, etc. (The purge thing is not a deal breaker.)
Are you not able to rename the 5.5 dll? Isn't that a trick you can use in windows to keep both versions?
 

Jdiggity1

Senior Member
Moderator
Instead of running the Kontakt installer, you can extract the contents and find the relevant files within (.dll and .exe).
Save those files to the appropriate directory and rename them.
Guess it's mostly a "developer's trick".
 

Rob Elliott

Senior Member
Instead of running the Kontakt installer, you can extract the contents and find the relevant files within (.dll and .exe).
Save those files to the appropriate directory and rename them.
Guess it's mostly a "developer's trick".
hmmm - not sure I understand. RENAME the 'new' (provided I can 'find' that :) ) .dll as "beta 5.6" or something like that and open Kontakt from that renamed one? What does the .exe file to do with it as well? Thanks for letting me know.
 

dannymc

Senior Member
Jesus they really need to sort out this Kontakt update fast and bring out a replacement without all the radical overhauls. it was too much to do in one update nobody can find their way around it now.
 

Jdiggity1

Senior Member
Moderator
hmmm - not sure I understand. RENAME the 'new' (provided I can 'find' that :) ) .dll as "beta 5.6" or something like that and open Kontakt from that renamed one? What does the .exe file to do with it as well? Thanks for letting me know.
The .exe is for standalone. The dll is for vst (plugin).
You can rename whichever you like. But adding a "5.6" to the new dll makes sense.
The files are 'hidden' within the "OFFLINE" folder.
 

Rob Elliott

Senior Member
The .exe is for standalone. The dll is for vst (plugin).
You can rename whichever you like. But adding a "5.6" to the new dll makes sense.
The files are 'hidden' within the "OFFLINE" folder.
ok sounds good. and how can I download just that .dll
 

jtnyc

Senior Member
I'm getting CPU spikes in my DAW that was not present prior to 5.6, anyone experienced the same thing ?
Yes. Very slow loading times and cpu spikes and disk spikes that register in Kontakt, but not on my Logic cpu meters. With just NI's The Grandeur loaded I get spikes with notes dropping out. I'm gonna looking into reverting back to 5.5.
 

Guy Rowland

Senior Member
Rob - in all seriousness, how much do you REALLY need that new library? Just put in on the shelf for a few weeks / months til NI get their act together.
 

Baron Greuner

Senior Member
Ok - now I am in a corner. Just picked up a library that NEEDS 5.6!!!!! I am on PC (all putters and slaves) - W7 - anyone running this config ok? Just so many - this isnt' working - that's worse kinda comments here - scares the bageebers out of me to update.
That wasn't a cello library by any chance Rob?
 

Rob Elliott

Senior Member
Yea Guy - I have decided to shelf it and just get a cellist in here (I didn't have the budget for any live players but really no choice at this point.) Yes Baron -- cello :unsure:
 
OP
Lindon

Lindon

VST/AU Developer
Waiting is probably the best idea, when a developer(library) says it needs 5.6 there's a good chance it/they mean it's using some part of the new KSP functionality, so renaming some dll isnt going to work in any case...
 

EvilDragon

KSP Wizard
so renaming some dll isnt going to work in any case...
Yes, it will work. I've been using Kontakt like that for years now. Everything works! I have versions back to 5.0.0, 5.1.0 and so on, and up to 5.6.1. More for development purposes if a client asks for a particular version, but loading libraries works just fine. So you can have 5.1.0 installed and 5.6 as well, if a library requires 5.6, you just load the 5.6 renamed DLL and off you go. Because KSP functionality is all a part of the executable/DLL. That's why renaming just works. :)
 

Rob Elliott

Senior Member
Waiting is probably the best idea, when a developer(library) says it needs 5.6 there's a good chance it/they mean it's using some part of the new KSP functionality, so renaming some dll isnt going to work in any case...
Probably right - I have a couple days before this cue so I might just extracting the .dll - rename it and load up the library in that instance and see how bad it is. Shouldn't take too long to make the experiment. My expectations are low (as it is with Kontakt of late.) Here's to hoping that Falcon (insert competitive samples engine here) gives these guys a reason to get their act together.