Search results

  1. Claud9

    UNHUMAN - Update available - Intro Pricing Extended!

    Just downloaded the update, all works nice and smooth and the new 50 multis are a great addition. Thanks for keeping your libraries constantly updated!
  2. Claud9

    Recommended Omnisphere add-on libraries - POLL ADDED

    I have recently bought Unhuman by String Audio and It's great.
  3. Claud9

    UNHUMAN - Update available - Intro Pricing Extended!

    Just bought it and really liked it. The sample material is really unique and Patches are great. They only use their own samples to create the Patches, I think that's why the sound is so unique and different.
  4. Claud9

    Number of code lines per tab?

    update: I tried to delete a bunch of buttons and Kontakt accepted the on init code. I don't understand what Kontakt don't like honestly also because all those buttons share the same custom image. Is there a limit in the number of buttons, sliders you can declare?
  5. Claud9

    Number of code lines per tab?

    I have a problem with my on init callback. Is around 8400 lines. I have successfully compiled it with sublime text but as soon as I try to load it in Kontakt I have the message that a variable is not declared... but I triple checked and it is. The variable with the error is one of the last in...
  6. Claud9

    Help with error in code line

    Now It looks I have a similar problem if I try to make persistent all the buttons I have in the array... Is something possible or I have to make them all persistent one by one when I declare them? I'm trying with this in the while loop: make_persistent(%groups_layer_1) but is not working...
  7. Claud9

    Help with error in code line

    Thanks for the help. Do you mean like this? Because also this is not working.. same error as before: "statement(s) expected" set_text(%groups_layer_1[$count],group_name[$count])
  8. Claud9

    Help with error in code line

    Hello, I have an array of buttons and I want to name each button with the corresponding group name. I made a while loop but this line is not working... (error: statement(s) expected) set_text(%groups_layer_1[$count],group_name($count)) what is wrong? Thanks in advance for any help!
  9. Claud9

    Help with Knob animation

    The point is that I have zero ideas what a "modulo" is and how it works. The only thing I have found on KSP manual containing the word "modulo" is this: x mod y modulo; returns the remainder of a division e.g. 13 mod 8 returns the value 5 Without an example of code that uses "modulo' for me is...
  10. Claud9

    Wavetable zone waveform

    Ok but so how is possible to do this as is shown in this instrument? If I add an LFO to a parameter my custom knob is not moving, how is possible that in this instrument is moving?
  11. Claud9

    Help with Knob animation

    Thanks for the help. I tried to follow your directions with this code. Now knob 2 seems to do something different from knob 1 but they are still moving at the same speed... Thanks in advance for any new help! on init declare ui_knob $test1 (0,99,1) declare $direction_test1 declare...
  12. Claud9

    Help with Knob animation

    I don't honestly have any idea how to apply your suggestions, I'm completely new to "on listener" and "mod operator"... I have tried to find an example on KSP manual but I can't find anything similar.
  13. Claud9

    Help with Knob animation

    This is an updated version where I'm trying to change the speed of Knob "$test2" using "change_listener_par" but now both Knobs are spinning at the same faster speed. Is there a way to have Knob "$test1' spinning at a different speed than Knob "$test2'? thanks for any help! on init declare...
  14. Claud9

    Help with Knob animation

    Hello everyone, I'm trying to modify a script I found on KSP manual. It's a script that animates a single knob back an forth at a fixed speed. I'm trying to add a second knob and animate it at a different speed so that at the same time they are both moving but at different speed rates. It's the...
  15. Claud9

    Number of code lines per tab?

    Hello, is there a limit in the number of code lines you can write in a script tab? In my instrument, I use only 1 script tab. Thanks in advance for any help
  16. Claud9

    Wavetable zone waveform

    I was meaning if it is possible with a script to see that knob movement we see in instrument edit mode also in our own GUI when we activate an LFO?
  17. Claud9

    Wavetable zone waveform

    and at least seeing the "position" knob moving when I activate the LFO as it is moving when I enter in editing mode?
  18. Claud9

    Wavetable zone waveform

    I was also experimenting with adding an envelope or LFO to the position knob. Is there a way to actually see those position changes reflected in the ui waveform as you see when you manually move the position knob with the ui_control callback?
  19. Claud9

    Wavetable zone waveform

    I tried with longer samples, 3D waveform and bigger and I had to increase the wait time to 200000 in order to make it work properly.
  20. Claud9

    Wavetable zone waveform

    The effect trick worked but I have no idea how to do what you suggested with the lookup array. I have to do a sort of list with all ID's and corresponding groups? Also just to understand, the code as is in the NKI you posted works properly only if Zone ID 0 corresponds to Group 0 and so on...
  21. Claud9

    Wavetable zone waveform

    But why now if I change your samples with mine I don't see any waveform anymore? I noticed that zones are changed to 4 - 5 - 6 - 7. It works only if zones are 0 - 1 - 2 - 3? And it works only with 4 groups/zones? I'm confused what's going on here!:thumbsdown:
  22. Claud9

    Wavetable zone waveform

    adding wait(50000) made it and now It works fine! remain a mystery why on PC K6 is working without!
  23. Claud9

    Wavetable zone waveform

    Load the .NKI and then try to change the group. The waveform should update only if you select the menu item twice. You have this problem only right after loading the instrument, as polypx wrote after you have correctly selected all groups twice then the waveform is loaded correctly the first...
  24. Claud9

    Wavetable zone waveform

    Thanks for sharing, but it's still not working here (pls see attached video). I have tested with both Full version and Player on two different Mac, the problem is always the same: I have to select twice the group in order to see the correct waveform. It's a bug of K6 Mac version?
  25. Claud9

    Wavetable zone waveform

    Thanks for the code. It is supposed to work as it is or I need to add something? I have created a new instrument from scratch - 4 groups and exactly the same zone IDs of your example, but is not working and I have exactly the same problems as before. Also, groups were not playing at all, I had...
  26. Claud9

    Wavetable zone waveform

    I really don't understand Just tested again on a second computer, same problem. I have to load twice the same group/zone with the menu in order to load the correct waveform. On the first attempt, the waveform is not loaded. Have you tried to save and reopen the instrument? When I do so I always...
  27. Claud9

    Wavetable zone waveform

    this is working now when I reload the instrument but is not working in the ui_control callback. I have always to reload twice the group in order to have Kontakt show the correct waveform. is this the correct way to show waveform in the ui_control callback? on init make_perfview...
  28. Claud9

    Wavetable zone waveform

    I have already tried both your suggestions but the problem remains the same: when I reload the saved instrument the waveform does not show up and if I change group/zone with the menu the waveform change only if I select with the menu the group/zone twice, It never changes at the first attempt...
  29. Claud9

    Wavetable zone waveform

    Thanks for the help. Zone ID 1 2 3 4 are the one I can find in the "expert - zone" tab. The script I posted work. I can see the waveforms but is not working properly. First problem: If I save an instrument that shows for example waveform of Zone ID 1 when I reload the instrument the waveform...
  30. Claud9

    Wavetable zone waveform

    Hello, I'm doing some script experiments with the new wavetable functions in K6. Everything is working fine with 1 group/zone But if I try with a 4 group/zones instrument I have some problems showing the correct zone/waveform... This is the code I have in the on init declare ui_wavetable...
  31. Claud9

    CONTINUATA

    I tried to understand the cost of s3 storage but is really a mess. There are too many factors and prices... What could be the cost if I sell a 20GB library for each download?
  32. Claud9

    Question about script update

    So I should have included the script in the "script" folder inside the resource folder before creating the NKR? I think I haven't done that. Also, I have saved the instrument with the "Apply from Editor/Patch" setting...
  33. Claud9

    Question about script update

    Hello everyone, I have modified the script of an instrument I did some time ago. I have saved and overwritten the old .nki file with the new one with the updated script. Why if I open an old Logic Pro project where I used a Kontakt instance with my old Instrument I still have it with the old...
  34. Claud9

    Zone Color [solved]

    Thanks, so simple!
  35. Claud9

    Zone Color [solved]

    Sorry for the question but I tried to get an answer on Kontakt manual but I can't find an answer: why in the mapping editor of my instrument some groups have the zone colored in blue and other groups are colored in red? When I load the sample and create a zone it is always colored in blue, then...
  36. Claud9

    Help with Arpeggiator script

    Hello everyone, I have a simple intrument based on the "factory" Kontakt arpeggiator script. I have added a slider that controls the sample start but I can't make it work together with the arpeggiator. The "sample start" slider works but the arpeggiator is not working. I tried to insert the part...
  37. Claud9

    Question about on note

    Thanks all for the help. Yes, it looks like a "redundant' workaround I agree I will try with another solution that does not involve the "release" value... Sorry for this other question, that is always related to the "On Note" callback: I have a simple instrument with two script tabs, in the...
  38. Claud9

    Question about on note

    I mean the ADSR: for example, if I have the release set at 5kms and after I play a note and hold it I change the release to 0ms this variation is ignored by Kontakt and he still applies the 5kms value when I release the note
  39. Claud9

    Question about on note

    Hello, in Kontakt, if you play and hold a note and after you change the "release" value the change of this parameter is ignored. Is it possible with a script to let Kontakt use the new "release" value? Maybe in the on release callback, I can tell Kontakt in some way to check the new release...
  40. Claud9

    Help with sample start

    Hi thanks for the help. I have a slider that controls the sample start position (from 0s to 6s) I have the sample with 3s of digital silence at the beginning. What I'm trying to do is to set the "release" or maybe better the "volume" to zero when the play cursor is between 0s and 3s than when...
  41. Claud9

    Help with sample start

    I have tried to update the script with this variation but it seems that I still don't get any play position... I simply want that when the play position pass 3s Kontakt set the "release" of my "release knob" and set the release value accordingly. Is it something possible? Thanks in advance for...
  42. Claud9

    Help with sample start

    I need help with this code, I want that when the play cursor passes an X position the "release" is set to its actual knob position. But it is not working... Thanks in advance for any help! $noteID := play_note($EVENT_NOTE,$EVENT_VELOCITY,$sampleStart_4,-1) $cursor_pos :=...
  43. Claud9

    Help how to invert knob value

    Thanks for the help. But if I try to put all together before the play_note is working fine only when I "solo" the layer otherwise none of the layers are working... on note ignore_event ($EVENT_ID) if ($layer1_solo = 1) disallow_group($ALL_GROUPS) $i := $LAYER1_FIRST while ($i<=$LAYER1_LAST)...
  44. Claud9

    Help how to invert knob value

    Thanks you all for the help, I have integrated this script in my two layers instrument but now I have the problem that my "Mute, Solo" script is not working anymore... Any suggestion why? on note {SAMPLE START} ignore_event ($EVENT_ID) disallow_group($ALL_GROUPS) $i := $LAYER1_FIRST while...
  45. Claud9

    Help how to invert knob value

    Yes you are right I have to put the amount of time I have in my script. In my case 5 seconds. Is this correct to do the conversion from seconds to samples in order to put the correct value in Kontakt? (my samples are recorded @ 44100): 44100X5=220500 I use DFD because in sampler mode Kontakt...
  46. Claud9

    Help how to invert knob value

    Thanks a lot, it works! I'm using the Groups of my instrument in DFD mode and in order to make the "sample start" knob works I have to put the "S.Mod" value for each zone to his max. The point is that I have plenty of groups and zones, is there a way to change that value for all groups/zone...
  47. Claud9

    Help how to invert knob value

    Thanks for your help. But if I try to follow your instructions and change from on ui_control $sampleStart to on ui_control abs ($sampleStart - $sampleStartMax) I'm getting a 'Parse Error" in the code...
Top Bottom