1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Negative S. Mod / Sample offset

Discussion in 'KONTAKT: Sampling, Programming & Scripting' started by Stiltzkin, Aug 12, 2017.

  1. Stiltzkin

    Stiltzkin Senior Member

    594
    34
    Nov 1, 2012
    Ireland
    Anyone had any issues with negative sample offsets defaulting to sample start time rather than actually playing back from where they should? S.Mod is set correctly/DFD mode etc and have tried increasing the value, playback just happens from sample start in all cases...

    Additionally, I'm not able to see the actual playback pin in wave editor... Just a few random issues looking to see if anyone else has been having trouble with/solved.
     
  2. EvilDragon

    EvilDragon KSP Wizard

    3,008
    1,289
    May 25, 2010
    Croatia
    If you're using a Constant modulator to modulate startpoint offset, then you gotta hit that Invert button to get into the negative S.Mod offsets (of course, your startpoint has to "dig" into the sample to even be able to have negative offsets possible). I am not sure if negative startpoint offsets would work from KSP.

    EDIT: Just checked. Yes, negative startpoint offset in play_note() doesn't work! So you gotta use the modulator for this.
     
    Maxime Luft, d.healey and Stiltzkin like this.
  3. OP
    OP
    Stiltzkin

    Stiltzkin Senior Member

    594
    34
    Nov 1, 2012
    Ireland
    Ugh, that's rather annoying - but thanks for the workaround I guess i'll just have to do it via modulator! Cheers.
     
  4. d.healey

    d.healey Kontakt Monkey

    1,849
    625
    Nov 2, 2011
    England
    He returned!!! :)
     
    polypx and Maxime Luft like this.
  5. Lindon

    Lindon KSP Developer

    467
    76
    Jul 27, 2010
    Republic of Yorkshire
    yeah..let hope the signal to noise ratio improves to where it was when "he" left....
     

Share This Page